Jump to content
  • 0

Roxio Creator 9.0 DE



My system is Dell computer came with XP MCE SP-2.

I had the oppertunity to Upgrade to VISTA OS- I did a clean install of the VISTA Home Premium OS and after that the Dell's factory installed roxio creator was lost.

Now I obtained this Roxio Creator 9.0 DE cd from Dell's company to reinstall VISTA compatible Roxio Creator on my computer.

After installing I was directed to correct the DLA patch incompatibilities from the Rexio official site which I followed as instructed.

My Roxio Creator worked for one day very well.

When I tried it this morning I could not get Roxio going!! Every attemt to open the Roxio results in an window open with a request to Register. Hwever when attempted to Register it suggests already registered.

But still I coulden't get Roxio working.

Can anybody help me resolve this.

Thanking you

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

A common mistake with the register window is forgetting to tick the box that you understand the terms and privacy details - make sure you did that and it should then re-register.


The tick box is a bit obscure unfortunately

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...