Jump to content
  • Who's Online   0 Members, 0 Anonymous, 10 Guests (See full list)

    • There are no registered users currently online
  • 0

Mytv.pvr And Toast 7


garagona

Question

MyTv.PVR allows analog to digital conversion to Mpeg2 formats. When burning the recorded video from my desktop, upon playback on a dvd player the audio does not match video. However the video and audio will match when playing through VLC from my desktop. I can only figure that the burn is not encoding correctly?

 

Is there a way to resolve this issue? Is there something I should do with the original desktop file so that Toast can burn the file with video matching the audio track?

 

Thanks for any help....i have been troubleshooting for three days now.

Link to comment
Share on other sites

14 answers to this question

Recommended Posts

Downloading Mpeg Streamclip by Squared 5 (conversion software, freebie) alerted me to the fact that I needed Apple's Quicktime Mpeg Playback Component. Downloading that little patch from Apple (for $20), Mpeg Streamclip was able to view the mpeg created from MyTV PVR. From there I tried several conversions till I finally went to "Export Mpeg to DV". In the options box there was a box that could be checked, "Resample audio to 48 khz". !!!!! (hence the helpful hint from your 'guru-ness').

 

Resulting in a dv file that I could Save as Disc Image in Toast. Voíla! DVD player was able to view the file, video MATCHING audio sync perfectly. !!!!!!!!!

 

Garagona & Tsantee

I thought I had finally found the solution I was looking for. I was so excited to read that you had solved your problem. I have been working for days to figure out the same thing, the only difference is I am working with a Tivo file that has been stripped of its tivo wrapper, however it appears to be an identical type of file with an identical problem.

I am on a G4 with OSX 10.3.9

I have Toast 7.0.2

I have QuickTime 7.0.4

I have downloaded Streamclip

I have downloaded QuickTime MPEG-2 Playback

 

When I bring the MPEG file into Toast it will burn a DVD but the audio doesn't match the video - the audio lags a few seconds behind the video

 

My mpeg file plays fine in VLC but won't play in QuickTime or DVD Player (The burned DVD will play in DVD player but then the audio is out of sync. The audio is also out of sync on my portable DVD player and my Bose DVD player)

 

In Toast if you go to edit it says

Video: MPEG-2, 480x480, 29.97 fps

Audio: MPEG1, Stereo, 48000 Hz

When I click burn in Toast it encodes

In Quicktime if you go to movie info it says

MPEG2 Muxed, 480x360

FPS: 30

 

I have tried to follow your instructions you posted for fixing the file in streamclip but unfortunately I did not have the success you did. Maybe my settings are not the same as what you used. Could you provide more specifics on what settings you used.

 

How do you know if the Quicktime Playback install properly. You said once you installed it your encoded MPEG file played in quicktime (was that before or after using streamclip?)

 

I am hoping one of you may have some words of wisdom to solve my problem too.

Link to comment
Share on other sites

I keep learning a lot about Toast myself which is one of the reasons I contribute to this forum.

 

Is there any option with your Mytv to change any audio settings?

 

I think we've run out of options for getting the audio in sync without making some change in the files that Toast is using. A major clue is that QuickTime doesn't play this in sync - and Toast uses QuickTime.

 

Does the sound go out of sync over time or is it out of sync from the start?

 

Select the movie in the Toast Video window and click Export and choose AIFF. My guess is the resulting AIFF file will not be the same length as the movie. Let me know if my assumption is correct.

okay u must be psychic....the audio goes out of sync over time.

 

Unfortunately the export to aiff is not an option, since I don't see it as an avail. option.

 

I am playing with the audio delay on mytv.pvr and see where that will take me. or else i will just call the company and ream them for selling such a faulty product.

Link to comment
Share on other sites

Unfortunately, Eskapelabs provides very little technical information on their Web site about the MPEGs created by MyTV or what options you have for encoding. Have you contacted their technical support about this issue?

 

Drag one of the MPEGs to Toast, select it and click Edit. How does Toast describe the MPEG file?

 

Does Toast do encoding or does it just do multiplexing when you click the burn button?

 

When you say it plays right in VLC are you referring to the captured MPEG or do you mean that the burned DVD plays right in VLC but not on the DVD player?

 

Are you using Toast 7.0.2? What version of QuickTime?

 

Are there any audio settings you can make with the MyTV?

Ok, so Tsantee, thanks for the quick response. Yes I have called their tech support and I think I gave them a new food for thought....got alot of "hmmmm....interesting" O and "I hear that Toast does that". But any real answers....ummmm, No.

 

I know that Toast does the encoding I assume since I see that it goes thru that step first.

 

VLC can view the captured MPEG correctly, but the DVD player does not. For egc, Quicktime format is low grade quality and the audio does not match at all. Live TV which seems to be a mpeg 2 format (720 x ...), quality is much better but the audio is off by two seconds.

 

I am not presently in front of my computer to see how toast "describes" the file. Quicktime version and Toast version also unknown for same reason.....will check that out later.

 

I did get one bit of info out of tech support that went over my head though...something about Demuxing....and I just faded out. O and they did say that I should switch usb ports....but I think that what just too silly of an answer.

Link to comment
Share on other sites

I think we're almost home. For some reason Toast doesn't think your MPEGs are fully compliant and wants to re-encode them. Roxio added a nice feature to Toast 7 to force Toast to accept the MPEGs as is. At the bottom of the left window you'll see a button labeled "More." Click that. In the window that appears click "Encoding". Now click "Custom." Next to Reencoding select Never. Now click Okay.

 

Choose Save as Disc Image from the File menu. Toast will now say multiplexing instead of encoding. When the disc image is finished you can mount it using the Image File setting in the Toast copy window. Preview it with DVD Player to see if the audio sync problem is solved. If it is you can burn the image file to DVD from the Copy window. If not, let me know.

 

Good luck.

 

First of all, I am learning alot about toast just thru the few answers that you have provided. I have been testing several settings but the audio is still off by a few seconds.

Toast reads the file as : Video- Mpg2, 720x480, 29.97 fps .... Audio - Mpg1, 48000 hz

 

I noticed that Save as Disc Image has diff. options and I have been experimenting with those. Since the audio lags behind by 2 seconds, I am thinking that the muxing (hehe used new word) is off. Is there a setting that you suggest that would bring the audio track to match the video judging from the info listed above.

 

Thank u for your kind attention ... and thank goodness for this forum I learn alot from it daily....and leads me to investigate the many sides to Toast than just a mere burning software.

Link to comment
Share on other sites

okay u must be psychic....the audio goes out of sync over time.

 

Unfortunately the export to aiff is not an option, since I don't see it as an avail. option.

 

I am playing with the audio delay on mytv.pvr and see where that will take me. or else i will just call the company and ream them for selling such a faulty product.

I think I may have found the problem. Reading the instructions for MyTV it apparently uses by default the Mac's built-in audio controller. This controller can only encode 44.1 khz audio (same as used in audio CDs). However, video DVDs use 48 khz audio. Toast must change the sample rate when it is multiplexing the audio. But if you simply change the rate, you change the length of the file. There are audio editing applications (such as Bias Peak or Sound Studio) that can resample audio without changing its speed or length. However, the audio would have to be in AIFF format to do that.

 

There is another option and that is to use a different audio controller such as the Griffin iMic. It has the ability to set audio encoding at 48 khz. There's a possibility that using an iMic and choosing 48 khz in the Audio Midi Setup application in the Utiliites folder will cause the audio to be encoded in a way that will stay in sync when Toast does the multiplexing.

 

Or I could be wrong about this.

Link to comment
Share on other sites

Ok, so Tsantee, thanks for the quick response. Yes I have called their tech support and I think I gave them a new food for thought....got alot of "hmmmm....interesting" O and "I hear that Toast does that". But any real answers....ummmm, No.

 

I know that Toast does the encoding I assume since I see that it goes thru that step first.

 

VLC can view the captured MPEG correctly, but the DVD player does not. For egc, Quicktime format is low grade quality and the audio does not match at all. Live TV which seems to be a mpeg 2 format (720 x ...), quality is much better but the audio is off by two seconds.

 

I am not presently in front of my computer to see how toast "describes" the file. Quicktime version and Toast version also unknown for same reason.....will check that out later.

 

I did get one bit of info out of tech support that went over my head though...something about Demuxing....and I just faded out. O and they did say that I should switch usb ports....but I think that what just too silly of an answer.

I'll start by explaining demuxing. Your captured MPEG has the audio and video together in the same file. This is "muxed" or more descriptively "multiplexed." When Toast "authors" a video DVD from muxed MPEGs it must first separate the audio from the video (demuxing) and then put them back together in the resulting VOB files. Toast describes this process as "Multiplexing" in the progress bar. If you are seeing "Encoding" instead of "Multiplexing" in the progress bar when you click the burn button, let me know.

 

If you are not using QuickTime 7.0.1 or later you are going to have sound sync issues with Toast. That's why I asked about what version of QuickTime you are using. I'll await more info before making any more guesses.

Link to comment
Share on other sites

. Could you provide more specifics on what settings you used.

 

How do you know if the Quicktime Playback install properly. You said once you installed it your encoded MPEG file played in quicktime (was that before or after using streamclip?)

 

it seems that I have been reading about this audio out of sync with video almost everywhere...hot topic. bear in mind i am not a techie but i think logically.

 

have you ever heard of ffMpegX ? its an encoding software that people on discussion forums have used also when mpeg streamclip doesn't do the job....its shareware. you can research that for a bit if anything the forums say make sense.

 

regarding the Apple QT mpeg component playback....prior to loading the QT patch, Mpeg streamclip actually gave an alert that the patch would be needed to do anything with my mpg2. Once the patch was loaded, Mpeg Streamclip was able to view the file, including Quicktime....hence i knew that the patch loaded correctly. so the steps were...1)loaded qt patch, 2) opened mpeg streamclip, 3) resampled to 48khz, 4) save as disc image in toast with encoding option set to never, toast 'encodes and writes'.

 

Regarding any settings on the mpeg streamclip file, all i did was check the resample audio to 48 khz.

 

i am not familiar with tivo i hope that maybe ffMpegX does the trick. if I get any new info though I will check back.

Link to comment
Share on other sites

I think I may have found the problem. Reading the instructions for MyTV it apparently uses by default the Mac's built-in audio controller. This controller can only encode 44.1 khz audio (same as used in audio CDs). However, video DVDs use 48 khz audio. Toast must change the sample rate when it is multiplexing the audio. But if you simply change the rate, you change the length of the file. There are audio editing applications (such as Bias Peak or Sound Studio) that can resample audio without changing its speed or length. However, the audio would have to be in AIFF format to do that.

 

There is another option and that is to use a different audio controller such as the Griffin iMic. It has the ability to set audio encoding at 48 khz. There's a possibility that using an iMic and choosing 48 khz in the Audio Midi Setup application in the Utiliites folder will cause the audio to be encoded in a way that will stay in sync when Toast does the multiplexing.

 

Or I could be wrong about this.

DRUM ROLL PLEASE.....Trumpet Revelry? I need confetti!!! I am now doing the Snoopy Dance!!!!!

 

Thank u, Tsantee for your indepth answers and actually helping with the research. Your hints were like popcorn trails that Hansel and Gretel followed to try and get home. I am HOME!

 

Putting together all of your hints and last nights greatest boon, the audio encoding at 44.1 khz hint, was what I needed to plant the seed and bring together all the software and research that I had accumulated to solve the problem. And this is how I resolved the problem:

 

Downloading Mpeg Streamclip by Squared 5 (conversion software, freebie) alerted me to the fact that I needed Apple's Quicktime Mpeg Playback Component. Downloading that little patch from Apple (for $20), Mpeg Streamclip was able to view the mpeg created from MyTV PVR. From there I tried several conversions till I finally went to "Export Mpeg to DV". In the options box there was a box that could be checked, "Resample audio to 48 khz". !!!!! (hence the helpful hint from your 'guru-ness').

 

Resulting in a dv file that I could Save as Disc Image in Toast. Voíla! DVD player was able to view the file, video MATCHING audio sync perfectly. !!!!!!!!!

 

NOTE THAT now I am also able to use the file in IMovie (using fine tuning options in Mpeg StreamClip) and I can edit and add affects. I can now, finally, transfer all my Hi8 tapes to DVD.

 

Thank you Thank you Thank you......I now in hindsight wish that i had changed the subject matter to "video will not match audio sync" since the valuable info here would help give others some new insight and avenues to similar issues.

 

Just an added note, since downloading apple's patch, Quicktime can now read the encoded TV PVR mpeg. Also note that DVD Studio Pro and Final Cut Pro have this particular patch already included....software that I do not have but learned about thru my intensive research.

 

THANK YOU AGAIN! There is a true reason you are listed as a Digital Guru....hmmmm.....Tsantee as a new mantra? : )

Link to comment
Share on other sites

I keep learning a lot about Toast myself which is one of the reasons I contribute to this forum.

 

Is there any option with your Mytv to change any audio settings?

 

I think we've run out of options for getting the audio in sync without making some change in the files that Toast is using. A major clue is that QuickTime doesn't play this in sync - and Toast uses QuickTime.

 

Does the sound go out of sync over time or is it out of sync from the start?

 

Select the movie in the Toast Video window and click Export and choose AIFF. My guess is the resulting AIFF file will not be the same length as the movie. Let me know if my assumption is correct.

Link to comment
Share on other sites

I'll start by explaining demuxing. Your captured MPEG has the audio and video together in the same file. This is "muxed" or more descriptively "multiplexed." When Toast "authors" a video DVD from muxed MPEGs it must first separate the audio from the video (demuxing) and then put them back together in the resulting VOB files. Toast describes this process as "Multiplexing" in the progress bar. If you are seeing "Encoding" instead of "Multiplexing" in the progress bar when you click the burn button, let me know.

 

If you are not using QuickTime 7.0.1 or later you are going to have sound sync issues with Toast. That's why I asked about what version of QuickTime you are using. I'll await more info before making any more guesses.

thanks again so much for your reply.

 

Presently I am using Quicktime 7.0.3 and yes when the burns starts, it encodes not multiplexing. When I view the file in toast it says "mpeg 2, muxed", for quicktime files it says "mpeg 1, muxed"

 

i am using toast 7. (Mac OSX 10.3.9) Mac G4.

 

Thank you for explaining what muxed means, it helps alot.

Link to comment
Share on other sites

Unfortunately, Eskapelabs provides very little technical information on their Web site about the MPEGs created by MyTV or what options you have for encoding. Have you contacted their technical support about this issue?

 

Drag one of the MPEGs to Toast, select it and click Edit. How does Toast describe the MPEG file?

 

Does Toast do encoding or does it just do multiplexing when you click the burn button?

 

When you say it plays right in VLC are you referring to the captured MPEG or do you mean that the burned DVD plays right in VLC but not on the DVD player?

 

Are you using Toast 7.0.2? What version of QuickTime?

 

Are there any audio settings you can make with the MyTV?

Link to comment
Share on other sites

thanks again so much for your reply.

 

Presently I am using Quicktime 7.0.3 and yes when the burns starts, it encodes not multiplexing. When I view the file in toast it says "mpeg 2, muxed", for quicktime files it says "mpeg 1, muxed"

 

i am using toast 7. (Mac OSX 10.3.9) Mac G4.

 

Thank you for explaining what muxed means, it helps alot.

I think we're almost home. For some reason Toast doesn't think your MPEGs are fully compliant and wants to re-encode them. Roxio added a nice feature to Toast 7 to force Toast to accept the MPEGs as is. At the bottom of the left window you'll see a button labeled "More." Click that. In the window that appears click "Encoding". Now click "Custom." Next to Reencoding select Never. Now click Okay.

 

Choose Save as Disc Image from the File menu. Toast will now say multiplexing instead of encoding. When the disc image is finished you can mount it using the Image File setting in the Toast copy window. Preview it with DVD Player to see if the audio sync problem is solved. If it is you can burn the image file to DVD from the Copy window. If not, let me know.

 

Good luck.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...