Jump to content
  • 0

Not So Easy Media Creator 9




I purchased EMC 9 online download in June for a specific project. It worked great. I later used it to edit a WMV video in which I added dialog to a movie powerpoint presentation I created. Burned it to DVD and everything was awesome.


Today, having nothing changed on my system of which I am aware, I attempt to edit another video. I'm on a deadline to get this done, so it was important for me to be able to do it today. I started this morning. I got the following error upon importing: "Current production empty or contains invalid files". And from there, nothing works.


I burned my whole day researching the problem on forums and found that many people are having the same symptoms with no one really knowing what the fix is. Sure, there's Vista this and that with DX 10 and moving Divx files around and uninstalling IE 7 as possible solutions, but I don't have Vista, I don't have IE7, video driver is current as I just bought this computer in March, and it was working before. I followed the suggestions on the formum that applied to me, (move around divxdec.ax, do a repair, uninstalled and reinstalled EMC 9, loaded latest DX 9c). I am at a loss.


I tried to contact cust. srvc. but it won't allow me to log in. I can log in to my Roxio profile account, but to contact tech support, the login doesn't work. FRUSTRATING! :angry2:


I don't understand how a program can work one day and then not the next with no change. Even the video I edited successfully in the past, the very same one, is getting the error. I tried AVI files as well and same issue.


This is a major problem. This software has become useless to me now. Worse than that, it has put me behind schedule and cost me $$$$.


I'd ask for suggestions, but I've seen that no one really has an answer, therefore, I guess I'm just venting.



Operating System: Windows XP Home Edition (5.1, Build 2600) Service Pack 2 (2600.xpsp_sp2_gdr.070227-2254)

Language: English (Regional Setting: English)

System Manufacturer: NVIDIA

System Model: 122-CK-NF68

BIOS: Phoenix - AwardBIOS v6.00PG

Processor: Intel® Core2 CPU 6600 @ 2.40GHz (2 CPUs)

Memory: 2814MB RAM

Page File: 372MB used, 4329MB available

Windows Dir: C:\WINDOWS

DirectX Version: DirectX 9.0c (4.09.0000.0904)

DX Setup Parameters: Not found

DxDiag Version: 5.03.2600.2180 32bit Unicode

IE v.6

Link to comment
Share on other sites

1 answer to this question

Recommended Posts


This topic is now archived and is closed to further replies.

  • Create New...