Jump to content
  • 0
jeanrosenfeld

FIX for My DVD crash with wmvdecod.dll error

Question

I did a clean install of EMC 10, and found everything worked fine, except for My DVD, wich crashed with the error event log

 

Event Type: Error

Event Source: Application Error

Event Category: None

Event ID: 1000

Date: 12/09/2007

Time: 10:13:50

User: N/A

Computer: XXXXXX <---edited

Description:

Faulting application videowave10.exe, version 10.0.0.78, faulting module wmvdecod.dll, version 11.0.5721.5145, fault address 0x0002f5a2.

 

After trying reinstall, repair, running chkdsk and other things, none of which fixed the problem, I decided to get to the bottom of this problem, and I'm happy to report that I have found a fix.

 

The problem is caused by the fact that some of the new menu styles in My DVD (EMC 10) use .wmv files that have dimension 1920x1080, which with my Radeon XT800 GTO cause any player to crash if Windows Media Video Acceleration is turned on. Unfortunately the default menu after installing EMC 10 is one of those large dimension HD files. Menu styles using lower resolution. wmv files can be played or used in My DVD with Windows Media Video Acceleration on or off.

 

If you have this problem with an ATI card with Catalyst Control Center installed, in CCC, advanced mode, Video/All settings, scroll to the bottom and uncheck 'Windows Media Video Acceleration', click Apply OK. Then My DVD will open with any menu style selected as default, without crashing.

I have no experience with other graphics card makes, but presumably their control settings will have a similar option.

 

The steps to diagnose and fix the problem were:

 

1. First I noticed that My DVD would open, and start loading the default menu (Home Theater), and that it was whilst loading that menu that the crash occurred.

 

2. I then thought to double click on a dmsd file that I had, that had the Seasons menu style. It opened My DVD and loaded the file without crashing.

 

3. I set the Seasons style as default, closed My DVD. Now it opened from the Home window or from its short cut in Start/programs, without crashing. Changing the menu style to Home Theater, it crashed while loading the new style; some menu styles gave no problems, a few others did.

 

4. I then went to C:\Program Files\Roxio\VideoUI 10\Content\Video which contains the wmv files for the menu styles. I played them in WMP 11. The ones that caused My DVD to crash also caused WMP to crash, if in Tools/Options/ Performance tab/Advanced, the option 'Turn on DirectX Video Acceleration' was checked, but played OK with that option unchecked. The ones that caused no problems in My DVD played fine in WMP with that option checked or unchecked.

 

5. I then unchecked the option 'Windows Media Video Accelration in CCC.

 

6. Now My DVD opens without problems for all the menu styles, including Home Theater and the other ones that previously caused the crash.

 

If in Windows Explorer, you look in the folder C:\Program Files\Roxio\VideoUI 10\Content\Video in details view and add the dimensions column, you will see that the problematic ones are 1920x1080. With my ATI XT800 GTO WMP cannot play that size file with Video acceleration on.

 

I hope this fix will help others with similar problem

Edited by jeanrosenfeld

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Thanks, but no, I did not get the warning to update WMP 10 because I have WMP 11, all updated:-).

 

I've had WMP 11 since it came out and it never caused me any problems with EMC. Also no issues with EMC 10 final, now that I know not to use Windows Media Video Acceleration if I want to use one of those large resolution menu styles.

Share this post


Link to post
Share on other sites
  • 0
Thanks, but no, I did not get the warning to update WMP 10 because I have WMP 11, all updated:-).

 

I've had WMP 11 since it came out and it never caused me any problems with EMC. Also no issues with EMC 10 final, now that I know not to use Windows Media Video Acceleration if I want to use one of those large resolution menu styles.

Looks like that would be built into WMP11. I did that update and have no problems with HD WMV files. I also use nVidia with full acceleration. We need more feedback fromo those using nVidia and WMP11. Edited by ggrussell

Share this post


Link to post
Share on other sites
  • 0

Could be but I think it's also related to the graphics card capabilities.

 

I know that there are some HD.wmv files that I downloaded a long time ago from

 

http://www.microsoft.com/windows/windowsme...ntshowcase.aspx

 

such as Alexander 1080p (which is 1920x1080) that cause WMP to crash if I have directX video acceleration checked in WMP tools/options/performance/advanced. I can use video acceleration for files that are 1480x1080 or smaller, but anything 1920x1080 won't play in WMP, Gspot or PowerDVD 7 on my system, unless i have video accleration off, in which case they play fine.

 

I can't recall whether I could play them in WMP 10. Possibly, in which case it probably is the wmvdecod.dll v 11.0.5721.5145 that is the root cause, as you suggest.

But I prefer WMP 11 to 10, and just turn off the video acceleration when I want to use such a file.

Edited by jeanrosenfeld

Share this post


Link to post
Share on other sites
  • 0

Gary,

 

Spurred on by your comments, I did some more experiments.

 

I moved the pesky wmvdecod.dll out of System32 folder.

 

I then opened one of the 1929x1080 wmv files in WMP. It complauned it did not have a codec, but promptly downloaded and installed another one: wmv9dmod.dll which according to GSpot is WMVideo 9 Decoder DMO, as opposed to wmvdecod.dll, which shows as WMVideo decoder DMO.

 

Now both WMP and Videowave could open and play the 1920 x 1080 wmv files with Video acceleration turned on.

But now, neither could find a codec to open the smaller .wmv files. This time WMP did not download a codec but pointed me to a lonk for the Windows Media 8 codecs.

 

http://www.wmplugins.com/ItemDetail.aspx?&codec=WMV2

 

 

After installing that (wmv8dmod.lll WMVideo 8 Decoder DMO) both WMP and Videowave were happy.

 

End resultm, I can keep Video acceleration on and play all the WMV1, WMV2 and WMV3 files without using wmvdecod.dll.

 

My DVD does not crash, since Videowave can open all the menu styles. I have not, as yet, found any problems not having wmvdecod.dll in its proper place. I'll keep it in a backup folder just in case.

 

Anyway, many thanks for insisting that the problem was with that decoder file and nothing to do with my graphics card.

I'm posting this rAther than sending you a PM, as it may be useful to orthers.

Share this post


Link to post
Share on other sites
  • 0

Jean,

 

does this mean I could remove the wmvdecod.dll from and copy the wmv8dmod.lll and the wmv9dmod.dll files to windows/system32 and this might correct the videowave must close problem? I also have the radeon 800xl video card and adjusted the advanced settings as suggested. This, in and of itself did not fix my problem. I further had to make 2 adjustments in the Advance window of the WMP Options - Performance. Aside from verifying that the Directx acceleration block was unchecked (off), I also had to uncheck the 'use video mixer rendering' under the Video Acceleration section. After these modifications were made I have been able to use MyDVD without VideoWave having to be closed.

 

Thanks for these suggestions. It would be nice to have more documentation on the potential application conflicts.

 

One last question to ask someone to clarify the potential impact of the Hardware/Software Render using selection in myDVD tools/options?

Share this post


Link to post
Share on other sites
  • 0
I moved the pesky wmvdecod.dll out of System32 folder...

 

I have Vista Home Premium 64 bit and thought I'd try this and it didn't work. I removed the wmvdecod.dll from both the System32 and WoW64 folders. Instead of WMP11 searching for the driver, I just got an error message saying the file could not be played (Alexander and Magic of Flight.) The wmv(8&9)dmod.dll files could not be registered due to a 64 bit incompatability issue. It might work with 32 Vista.

 

I don't have a computer, I have a lab rat, lol.

Edited by smonteijr

Share this post


Link to post
Share on other sites
  • 0

If WMP won't play those high resolution HD .wmv files, try tools/options/performance tab, advanced, uncheck directX video acceleration.

 

I have since had to put wmvdecod back into \system32, because some other files would not play in WMP or Videowave (some other .wmv files). I then played around in GSpot, changing merits of various codecs. Now I can open all the files I have in Videowave with Video acceleration on because it does not use wmvdecod.dll (to which I have assigned a low merit order) but wmv9dmod.dll. Unfortunately WMP 11 insists on using wmvencod.dll for the high resolution HD .wmv files and then requires the directX video acceleration to be turned off. That's the only player that now needs to have its Video acceleration off for those files.

 

I don't know about 64bit OS, have never got that far...

Edited by jeanrosenfeld

Share this post


Link to post
Share on other sites
  • 0

I'd like to mention that turning off the acceleration did indeed fix my issues.

 

 

If WMP won't play those high resolution HD .wmv files, try tools/options/performance tab, advanced, uncheck directX video acceleration.

 

I have since had to put wmvdecod back into \system32, because some other files would not play in WMP or Videowave (some other .wmv files). I then played around in GSpot, changing merits of various codecs. Now I can open all the files I have in Videowave with Video acceleration on because it does not use wmvdecod.dll (to which I have assigned a low merit order) but wmv9dmod.dll. Unfortunately WMP 11 insists on using wmvencod.dll for the high resolution HD .wmv files and then requires the directX video acceleration to be turned off. That's the only player that now needs to have its Video acceleration off for those files.

 

I don't know about 64bit OS, have never got that far...

Share this post


Link to post
Share on other sites
  • 0
I'd like to mention that turning off the acceleration did indeed fix my issues.

 

Thanks for letting us know. You would be surprised how many folks don't bother responding once they find a solution so we are left wondering what the solution was, or if they found one. Thanks again!

Share this post


Link to post
Share on other sites
  • 0

BIG thanks to jeanrosenfeld for proviing me with a method for launching my newly accuired EMC 10: unchechking the 'Windows Media Video Acceleration' on my ATI card. You ahve saved my day (week actually). Roxio e-mail support were not on to this ... They do not seem too interested in doing anything with this incopatibility in their software either ...

 

Now, can anyone enlighten me if there is a price to pay for unchecking 'Windows Media Video Acceleration'?

What does it actually do? Will I have poorer perfomance or conflicts elsewhere as a result of unchecking it? Grateful for any advice.

Share this post


Link to post
Share on other sites
  • 0
I did a clean install of EMC 10, and found everything worked fine, except for My DVD, wich crashed with the error event log

 

Event Type: Error

Event Source: Application Error

Event Category: None

Event ID: 1000

Date: 12/09/2007

Time: 10:13:50

User: N/A

Computer: XXXXXX <---edited

Description:

Faulting application videowave10.exe, version 10.0.0.78, faulting module wmvdecod.dll, version 11.0.5721.5145, fault address 0x0002f5a2.

 

After trying reinstall, repair, running chkdsk and other things, none of which fixed the problem, I decided to get to the bottom of this problem, and I'm happy to report that I have found a fix.

 

The problem is caused by the fact that some of the new menu styles in My DVD (EMC 10) use .wmv files that have dimension 1920x1080, which with my Radeon XT800 GTO cause any player to crash if Windows Media Video Acceleration is turned on. Unfortunately the default menu after installing EMC 10 is one of those large dimension HD files. Menu styles using lower resolution. wmv files can be played or used in My DVD with Windows Media Video Acceleration on or off.

 

If you have this problem with an ATI card with Catalyst Control Center installed, in CCC, advanced mode, Video/All settings, scroll to the bottom and uncheck 'Windows Media Video Acceleration', click Apply OK. Then My DVD will open with any menu style selected as default, without crashing.

I have no experience with other graphics card makes, but presumably their control settings will have a similar option.

 

The steps to diagnose and fix the problem were:

 

1. First I noticed that My DVD would open, and start loading the default menu (Home Theater), and that it was whilst loading that menu that the crash occurred.

 

2. I then thought to double click on a dmsd file that I had, that had the Seasons menu style. It opened My DVD and loaded the file without crashing.

 

3. I set the Seasons style as default, closed My DVD. Now it opened from the Home window or from its short cut in Start/programs, without crashing. Changing the menu style to Home Theater, it crashed while loading the new style; some menu styles gave no problems, a few others did.

 

4. I then went to C:\Program Files\Roxio\VideoUI 10\Content\Video which contains the wmv files for the menu styles. I played them in WMP 11. The ones that caused My DVD to crash also caused WMP to crash, if in Tools/Options/ Performance tab/Advanced, the option 'Turn on DirectX Video Acceleration' was checked, but played OK with that option unchecked. The ones that caused no problems in My DVD played fine in WMP with that option checked or unchecked.

 

5. I then unchecked the option 'Windows Media Video Accelration in CCC.

 

6. Now My DVD opens without problems for all the menu styles, including Home Theater and the other ones that previously caused the crash.

 

If in Windows Explorer, you look in the folder C:\Program Files\Roxio\VideoUI 10\Content\Video in details view and add the dimensions column, you will see that the problematic ones are 1920x1080. With my ATI XT800 GTO WMP cannot play that size file with Video acceleration on.

 

I hope this fix will help others with similar problem

This worked for me the very first time. I thought I had attempted everything and it was just a bad program bug. I never even knew that there was a little checkbox way down on the all settings tab.

Share this post


Link to post
Share on other sites
  • 0

I've tried to do all this and i'm still not able to open my dvd10 it still crashes any more help from ne one. I dont know how to get to advanced mode, Video/All settings, scroll to the bottom and uncheck 'Windows Media Video Acceleration', click Apply OK I do have a ATI GRaphic card siome one please help me

Share this post


Link to post
Share on other sites
  • 0
I've tried to do all this and i'm still not able to open my dvd10 it still crashes any more help from ne one. I dont know how to get to advanced mode, Video/All settings, scroll to the bottom and uncheck 'Windows Media Video Acceleration', click Apply OK I do have a ATI GRaphic card siome one please help me

 

Do you have Control Center installed?

Share this post


Link to post
Share on other sites
  • 0

i dont think i do have control center installed. do i need this installed and if so where can i install this from.

Thank you any help would be great :)

Share this post


Link to post
Share on other sites
  • 0
i dont think i do have control center installed. do i need this installed and if so where can i install this from.

Thank you any help would be great :)

 

What ATI video card do you have installed?

Share this post


Link to post
Share on other sites
  • 0
i dont think i do have control center installed. do i need this installed and if so where can i install this from.

Thank you any help would be great :)

 

 

Right click the desktop a window opens, do you see a ATI Catalyst® Control Center?

 

In XP, right click the desktop, click properties, click the settings tab, then the advanced button at the right bottom, another window opens click the adapter tab, your video adapter type is listed (video card). The same window that shows the adapter tab will show a ATI Catalyst® Control Center tab if you have it installed.

 

cd

Share this post


Link to post
Share on other sites
  • 0

I have ATI radeon express 200 series i right clicked on the desktop and had no CCC+++ i also went to properties setting advance adapt and found nothing some one please help me update my graphic card which one should i use which one is best and free.

Share this post


Link to post
Share on other sites
  • 0

I had the same issue as everyone else. Crashed loading MyDvD and DvD Express with error blaming VideoWave or somthing close to that anyway.

 

I'm running Vista Home Premium with an Nvidia Graphics card. My solution was to go into Windows Media Player, Click on "Tools" and then go down and click on "Options". Two rows of Tabs appear with various labels so just go to the tab that says "Performance" and click on it. The second item from the bottom is "Turn on DirectX Video Acceleration for WMV files", remove the check mark so that this option is NOT selected.

 

Apply the changes and thats what worked for me.

 

Hope it helps

Later

Share this post


Link to post
Share on other sites
  • 0

Thank you, sir. Your ATI CC fix seemed to do the trick. MyDVD and MyDVD Express ran. Now I will take them for a test drive to see if they are fully functional.

 

I did a clean install of EMC 10, and found everything worked fine, except for My DVD, wich crashed with the error event log

 

Event Type: Error

Event Source: Application Error

Event Category: None

Event ID: 1000

Date: 12/09/2007

Time: 10:13:50

User: N/A

Computer: XXXXXX <---edited

Description:

Faulting application videowave10.exe, version 10.0.0.78, faulting module wmvdecod.dll, version 11.0.5721.5145, fault address 0x0002f5a2.

 

After trying reinstall, repair, running chkdsk and other things, none of which fixed the problem, I decided to get to the bottom of this problem, and I'm happy to report that I have found a fix.

 

The problem is caused by the fact that some of the new menu styles in My DVD (EMC 10) use .wmv files that have dimension 1920x1080, which with my Radeon XT800 GTO cause any player to crash if Windows Media Video Acceleration is turned on. Unfortunately the default menu after installing EMC 10 is one of those large dimension HD files. Menu styles using lower resolution. wmv files can be played or used in My DVD with Windows Media Video Acceleration on or off.

 

If you have this problem with an ATI card with Catalyst Control Center installed, in CCC, advanced mode, Video/All settings, scroll to the bottom and uncheck 'Windows Media Video Acceleration', click Apply OK. Then My DVD will open with any menu style selected as default, without crashing.

I have no experience with other graphics card makes, but presumably their control settings will have a similar option.

 

The steps to diagnose and fix the problem were:

 

1. First I noticed that My DVD would open, and start loading the default menu (Home Theater), and that it was whilst loading that menu that the crash occurred.

 

2. I then thought to double click on a dmsd file that I had, that had the Seasons menu style. It opened My DVD and loaded the file without crashing.

 

3. I set the Seasons style as default, closed My DVD. Now it opened from the Home window or from its short cut in Start/programs, without crashing. Changing the menu style to Home Theater, it crashed while loading the new style; some menu styles gave no problems, a few others did.

 

4. I then went to C:\Program Files\Roxio\VideoUI 10\Content\Video which contains the wmv files for the menu styles. I played them in WMP 11. The ones that caused My DVD to crash also caused WMP to crash, if in Tools/Options/ Performance tab/Advanced, the option 'Turn on DirectX Video Acceleration' was checked, but played OK with that option unchecked. The ones that caused no problems in My DVD played fine in WMP with that option checked or unchecked.

 

5. I then unchecked the option 'Windows Media Video Accelration in CCC.

 

6. Now My DVD opens without problems for all the menu styles, including Home Theater and the other ones that previously caused the crash.

 

If in Windows Explorer, you look in the folder C:\Program Files\Roxio\VideoUI 10\Content\Video in details view and add the dimensions column, you will see that the problematic ones are 1920x1080. With my ATI XT800 GTO WMP cannot play that size file with Video acceleration on.

 

I hope this fix will help others with similar problem

Share this post


Link to post
Share on other sites
  • 0

this was great information,,, thanks for solving it... those nuts at Roxio should have known that and posted something to that extend. I just turned off the video accelration , then rebooted, and all else works fine.. i guess in the long wrong my video card needs updating..

 

thanks again

Share this post


Link to post
Share on other sites
  • 0

I really want to thank everybody for sharing.... I am no tech wizard- I bought this system to edit baby and vacation movies..

XP w/ 1gb (im not launching rockets right?)

 

NOT USING the "movieroom" style of menu seems to have solved everything for me! (after toggling the Acceleration box for my NVIDIA GeForce 6100 driver which solved the issue of playing a movie to select chapters?)

 

So yes I had figured out how to update my driver and dirextx... didnt help (at least Roxio got me that far)

 

starting in that menu "style" made the program run slow.... i mean like -it has to have hung up slow, then would flicker and spit back to life.

 

Now by switching to a different style, it actually seems to run rather smoothly.

 

Come on! Roxio!! This isn't a rarely used part of the software!!

 

Thanks again for helpping out.... and if anyonce comes up with way to set the Menu Style to blank, or anything.. post it! Or any toher little bugs I have yet to crash with.

Share this post


Link to post
Share on other sites
  • 0

Hello all!

I'm facing this same problem, but I tried to disable the accelerator and it didn't work, even using the method in the first post.

The message appears when I try to open any of the MyDVD's menus.

 

Each time I go to the Control Panel and repair the EMC 10 it works just fine, but as soon as I restart the PC again the error start occurring.

 

Is there anything else that can be done to prevent this?

My video card is a NVIDIA GeForce 6500 and I have WMP 11, btw.

 

Thanks all!

Edited by Risada

Share this post


Link to post
Share on other sites
  • 0
Guest ml
Now by switching to a different style, it actually seems to run rather smoothly.

 

Thanks again for helpping out.... and if anyonce comes up with way to set the Menu Style to blank, or anything.. post it! Or any toher little bugs I have yet to crash with.

 

If you've found a menu style that works smoothly, then I'd suggest you make a project with that menu and no movie. ( You can use any picture or video of your own as a background also.)

 

Do a File/Save as... and give it a descriptive name.... like MYDVD Menu Template. Note where the file is stored and perhaps create a shortcut on your Windows Desktop to that file.

 

Next time you want to create a DVD, open that file, do a File\Save as and give the file another project name.

 

For your other problems, you might want to contact Roxio Tech Support.

 

Hello all!

I'm facing this same problem, but I tried to disable the accelerator and it didn't work, even using the method in the first post.

The message appears when I try to open any of the MyDVD's menus.

 

Each time I go to the Control Panel and repair the EMC 10 it works just fine, but as soon as I restart the PC again the error start occurring.

 

Is there anything else that can be done to prevent this?

My video card is a NVIDIA GeForce 6500 and I have WMP 11, btw.

 

Thanks all!

 

Risada,

You need to start another New Topic and post exactly what is happening and your system specifications.

 

And try Roxio Technical Support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×