Jump to content
  • 0

v9.1 won't install?


Imageman

Question

Windows Vista Ultimate 64 bit / Roxio Easy Media Creator Home

 

Friends - Version 9 of "Roxio Easy Media Creator Home" was bundled with my Plextor DVD drive. Neither version of the 9.1 upgrade will install. Both go through the extraction process, then give an error message saying "Setup cannot find a valid version of this software to upgrade . . . ."

 

I'm just about at the limit of time I'm willing to spend trying to make Roxio work. I'd be happy to upgrade tp version 10 if I thought it was compatible with my system.

 

Does anyone have Vista 64 running properly with v10? All Roxio functions work?

 

Any suggestions? Thank you for your help - IM

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

Windows Vista Ultimate 64 bit / Roxio Easy Media Creator Home

 

Friends - Version 9 of "Roxio Easy Media Creator Home" was bundled with my Plextor DVD drive. Neither version of the 9.1 upgrade will install. Both go through the extraction process, then give an error message saying "Setup cannot find a valid version of this software to upgrade . . . ."

 

I'm just about at the limit of time I'm willing to spend trying to make Roxio work. I'd be happy to upgrade tp version 10 if I thought it was compatible with my system.

 

Does anyone have Vista 64 running properly with v10? All Roxio functions work?

 

Any suggestions? Thank you for your help - IM

You have an OEM version of the software.

 

The software update page for 9.1 states that you must have a full, valid retail version.

 

Please read before downloading:

  • You must have a valid copy of the full, retail version of Easy Media Creator 9 or Easy Media Creator 9 Deluxe Suite on your system in order to install this update. If you did not purchase a retail copy of Creator, this update will not work for your version of Creator 9.
Link to comment
Share on other sites

Windows Vista Ultimate 64 bit / Roxio Easy Media Creator Home

 

Friends - Version 9 of "Roxio Easy Media Creator Home" was bundled with my Plextor DVD drive. Neither version of the 9.1 upgrade will install. Both go through the extraction process, then give an error message saying "Setup cannot find a valid version of this software to upgrade . . . ."

 

I'm just about at the limit of time I'm willing to spend trying to make Roxio work. I'd be happy to upgrade tp version 10 if I thought it was compatible with my system.

 

Does anyone have Vista 64 running properly with v10? All Roxio functions work?

 

Any suggestions? Thank you for your help - IM

Hi Imageman,

The 9.1 update only applies to the retail version of Easy Media Creator. You have an OEM version, which the updater is not designed to update.

 

Easy Media Creator 10 is certified for Vista, including 64 bit.

 

Tom

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...