Jump to content
  • Who's Online   0 Members, 0 Anonymous, 15 Guests (See full list)

    • There are no registered users currently online
  • 0

Cannot launch Sonic Record Now applications due to "unknown error"



When I launch any of the following applications, I got the same "Could not complete the last command because: Unknown error".


- Multimedia Center Home

- Record Now Audio (

- Record Now Copy (

- Record Now Data (


My PC is a Lenovo T61 notebook running on Windows XP SP2.


I tried what are recommended in http://kb.roxio.com/content/kb/General%20I...N?set-locale=en but still get the same error.


BTW, Sonic Express Labeler ( can launch successfully.

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

Interesting. I've also got a Thinkpad, mine is a T60p running XP SP2, and I'm having the same problem. Roxio's fix, which is to register msxml3.ddl, also didn't solve my problem. Sonic Express Labeler will not start on my pc. I get the same error as with the other Roxio preinstalled applications.


Inasmuch as the Roxio suite comes preinstalled on the Thinkpads, I'm wondering if one of Lenovo's System Updates has caused this problem.


Have you by any chance checked with Lenovo on this?

Link to comment
Share on other sites

If it came with the computer (or a burner, as far as that goes), it's an OEM [Original Equipment Mfgr] Version. That means the OEM has contracted for it, and usually requested modifications, and has agreed to provide support.


So check with Lenovo and see what they have to say.



Link to comment
Share on other sites

I'm wondering if "WWW" ever got their problems resolved ... I have the exact same issue after upgrading to Lenovo's System Update 3 which included up to 80 patches after receiving my Thinkpad Z61T. I am planning on giving this Laptop as a gift to my daughter for college; and intend to fix before I wrap it up. I've looked through the Logs associated with the aforementioned Vendor-driven updates, and can view several notations where their OEM supplied software looks at various Sonic related registry entries. Whether it is actually updating anything Sonic related is speculative - not well defined within those logs. However, I'll make the assumption it just not making these inquiries without reason. I'd like to ask WWW (or anyone that has information on this issue) if they ever got a response from Lenovo. I will volunteer that I contacted them; and their response was very simply, that I should use the hidden image to restore the PC back to the original state. The problem with doing should be obvious but, I'll state here for clarification: Lenovo sent the PC missing many (like maybe 50 hotfixes after XP SP2) updates, since the last "Patch Tuesday". Unless they are advising their PC image is bulletproof against the latest Virus attacks, I and anyone who knows anything about Windows vulnerabilities knows you have to keep up on the latest. Number 2: If I don't update the Lenovo patches, I run the risk the hardware will crash at some point, as Lenovo's System Update patches the hardware to the latest BIOS on several components, as well as many other Lenovo supplied utilities. Other than those two items, the OS/Applications are exactly the way I've found them. I haven't added anything new ... yet. I promised myself I wouldn't "get my dander up" with Lenovo, until I put in my best effort to find a fix. Neither Lenovo, Sonic Solutions or the parent Roxio offer any fixes for the versions of Record Now that WWW lists in the beginning of this thread. So ... I'm appealing to all interested parties here: Can this thing be fixed, or should I take this to the next level with Lenovo? I'd appreciate anyone's opinion. Worse case: I have to purchase a newer version but, my sense is something Lenovo updated is causing this issue; and there's no way to tell if I'd cure the problem with a newer version of Record Now.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...