Jump to content
  • 0

Emc8 Suite - Mydvd Won't Load


malcolm.bott

Question

Whenever trying to load MyDVD either from EMC Home or directly from the Start menu, this fails with the message 'The certificate file is missing or has been corrupted. Please reinstall it'.

 

Any ideas how to fix this, or where this file may be found?

 

I have tried both the 'Repair' reinstall, and removing then reinstalling the DVD & Video components of the EMC8 product.

 

PC spec is 2.6GH, Pentium 4, 512mb memory, so I don't think that is the problem, as that appears to be well within the minimum requirement. I don't have problems with other video editing and authoring software (Ulead VideoStudio 9), or with my previous EMC 7.

 

Thanks

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

I'm having the same problem. I've tried uninstalling EMC8, and reinstalling it logged in under administrator with no success. Today I also tried to just reinstall EMC7, with it resulting in the computer failing to boot. At this point I've restored the computer to a earlier check-point. I did find a link to what apears to be a fix, but I would like to know that this is a safe fix. After all this is a brand new program; it should work without messing with the registry! Here's the link: http://www.msfn.org/board/lofiversion/index.php/t23033.html

Link to comment
Share on other sites

This worked for version 7 and should work fine for 8 in fixing the certificate file error.1. Fix registry permissions

 

a. Click on "Start" choose "Run", then type "regedit" and click "OK".

b. In the Registry Editor, click on the "+" next to "HKEY_Local_Machine".

c. Now click on the "+" next to "Software".

d. Right-click on the key (folder) called "Roxio" and choose "Permissions".

e. Make sure that "Administrators" and "System" have checkmarks for "Full Control" - "Allow".( This does not apply in win2000!)

2.

f. If you had to add those checkmarks, click on "Apply".

g. Click on "Advanced".

h. Put a checkmark in "Replace permission entries on all child objects with the entries shown here that apply to child objects".

i. Click "OK".

j. Click "OK" again.

k. Now close the Registry Editor

Link to comment
Share on other sites

Problem now solved - for me at any rate!

 

1. Uninstalled the EMC8 software.

2. Deleted any EMC7 and 8 folders from the 'C:\Program Files' folder (these apeared to be empty anyway, as I had originally selected the 'uninstall previous versions' option).

3. However, I also discovered some 'Sonic' folders with some clutter in. As I don't/didn't currently have any other Sonic products installed, I deleted these too.

4. Did a Norton Utilities check to try to tidy up any rogue registry entries (optional, depending on your view of Norton!). This found and 'fixed' a whole lot of 'Sonic' related issues.

5. Reinstalled the product.

6. Re-downloaded and applied the patch.

 

Thanks to those that responded.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...