Jump to content
  • 0

Drag to Dic copier DVD-R size not recognized



I have Roxio 9.1 (added the update this morning). I wasted about 3 DVD blanks because I couldn't get the update to install. FYI if you're trying to run update I succeeded by running it immediately after it downloaded rather than waiting. I had to throw away the first 9.1 update downloaded because it wouldn't run. When I downloaded from Roxio's tech supp. link and ran immediately after download, it worked quickly.


Back to my current issue. After updating I tried to copy a DVD using drag to disc. When it tells me to insert blank DVD after inserting and program recognizes disc it tells me that the DVD-R blank is not large enough that it needs another 102 mb. I currently am running Vista Home Basic. I used to have XP Pro with Roxio EC v6 and was able to create copies of this DVD (ISO image) using the same DVD-R blanks with no problem. I have checked past forum discussion posts and have not seen this issue. Any ideas or help anyone? PLEASE? :(

Thank you.

Link to comment
Share on other sites

3 answers to this question

Recommended Posts



Drag 2 Disc will not burn an ISO to disc to make a duplicate of the original disc. You need Disc Copier for that Job, like Larry said.


Drag 2 Disc will format the disc and then store a copy of the ISO on the disc, but that won't be any good to you if you're trying to make a duplicate of the original disc. Also as Jim said, formatting significantly reduces the storage space on a disc in 'overhead'.


Stick with Disc Copier.




Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...