Jump to content
  • 0

Mydvd Tells Me That My Dma Is Turned Off For One Or More Recording Devices


D S B

Question

MyDVD tells me that my DMA is turned off for one or more recording devices attached to the system etc. As a consequence, when I try to produce a DVD it goes through the process of producing the DVD but the computer won't recognize it to play. I have not knowingly done anything to turn off the DMA and all the indications I can find tell me its switched on ('when available'). Any advice would be very welcome as I can no longer sucessfully use the software.

 

Best wishes.

Link to comment
Share on other sites

9 answers to this question

Recommended Posts

DSB,

 

There is a setting you can alter for each device [DMA if available in your case] and a report from Windows telling you the Current Transfer Mode.

 

When you set for DMA Windows will obey and set a DMA mode, however if there are too many errors Windows will reset back to PIO - the slow but reliable mode. [and MyDVD complains to you about that].

 

By uninstalling the channel and allowing Windows to reinstall it you have caused a reset. Windows should now hold the channel at the mode you have set unless it starts to get errors again.

 

 

 

Link to comment
Share on other sites

QUOTE (D S B @ Feb 16 2008, 05:12 PM) <{POST_SNAPBACK}>
MyDVD tells me that my DMA is turned off for one or more recording devices attached to the system etc. As a consequence, when I try to produce a DVD it goes through the process of producing the DVD but the computer won't recognize it to play. I have not knowingly done anything to turn off the DMA and all the indications I can find tell me its switched on ('when available'). Any advice would be very welcome as I can no longer sucessfully use the software.

 

Best wishes.

 

 

Try # 3 in my signature...

 

cd

Link to comment
Share on other sites

Thanks for your help, Cdanteek. Have checked the #3 instructions (as I have done several times before) but there is no need for me to alter anything - it comes up as DMA enabled. That's why I can't understand why MyDvd keeps telling me that the DMA is turned off.

 

Best wishes

Link to comment
Share on other sites

QUOTE (D S B @ Feb 16 2008, 05:50 PM) <{POST_SNAPBACK}>
Thanks for your help, Cdanteek. Have checked the #3 instructions (as I have done several times before) but there is no need for me to alter anything - it comes up as DMA enabled. That's why I can't understand why MyDvd keeps telling me that the DMA is turned off.

 

Best wishes

 

 

What are the current transfer modes for Device '0' '1'? Check the Primary IDE Controller Device '0' '1' also.

 

cd

Link to comment
Share on other sites

Device '0' and '1' read: DMA if available. Device '0' has Device Type: Auto Detection (greyed out) and Current Transfer mode: Ultra DMA Mode 6. Device '1' has Device Type: Auto Detection and Current Transfer Mode: Not Applicable.

 

If I go to the Secondary IDE Channel Properties, Device '0' and '1' come up as Device Type: Auto Detection (greyed out), Transfer Mode: DMA if available, Current Transfer Mode: PIO Mode.

 

I suspect it t is to do with the Current Transfer mode being PIO, but you can't change it from this window.

 

If I go to SiS PCI IDE UDMA Controller and click on device property, my DVD drive comes up as 'Philips SPD6000L1' (this is my DVD drive) and PIO mode 4. I presume I need to change this to DMA, but I know not how.

 

Thank for your help so far.

 

Best wishes

 

Link to comment
Share on other sites

QUOTE (D S B @ Feb 16 2008, 04:10 PM) <{POST_SNAPBACK}>
Device '0' and '1' read: DMA if available. Device '0' has Device Type: Auto Detection (greyed out) and Current Transfer mode: Ultra DMA Mode 6. Device '1' has Device Type: Auto Detection and Current Transfer Mode: Not Applicable.

 

Sorry, I should have said this paragraph refers to my Primary IDE Channel

 

Best wishes

Link to comment
Share on other sites

Operating System is correctly identified as XP. In Secondary IDE Transfer mode says DMA but Current transfer mode says PIO. I can alter the 'Transfer Mode' (which I don't need to as it already says DMA) but there is no option to alter the third box, 'Current Transfer Mode' which says PIO. Now I'll go and read #3 again but i can't remember it telling me how to alter the third box Current Transfer Mode.

 

Best wishes

Link to comment
Share on other sites

I have decided to unistall the Secondary IDE Transfer. After reinstalling etc. the settings come up exactly the same, but when I checked the SiS PCI IDE UDMA Controller and click on device property, the 'Philips SPD6000L1' now comes up as UDMA mode 2. When I sarted MyDVD the original warning message has now disappeared. I'm now trying to burn the DVD again as I write this, and I have every confidence that it will work this time. Although the Secondary IDE Transfer settings were coming up the same, by uninstalling and re-installing these it has altered the SiS PCI IDE UDMA Controller settings for the Philips DVD drive.

 

I can't begin to understand why - I just put it down to the wierd and wonderful ways of Windows. By merely uninstalling and installing the Secondary IDE Transfer, it did the trick.

 

If the DVD fails, I'll be back, but if all is successful, I say thank you so much for all your help and for #3!

 

Best wishes and kind regards.

 

D S B (in the U.K.)

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...