Jump to content
  • Who's Online   0 Members, 0 Anonymous, 8 Guests (See full list)

    • There are no registered users currently online
  • 0

Bamakid's Vent


bamakid

Question

We were pleased to see that PC Magazine gave Easy Media Creator 10 a very positive review, making it their Editors Choice.

 

The review is here... http://www.pcmag.com/article2/0,1759,2194635,00.asp

 

Go read the "User" reviews of the product including mine nearl all give the product rating of ONE STAR!!!

 

 

They do, and it can be found on the following page (along with other contact methods). Keep in mind you probably would have gotten the same advise as has been posted here already. The program file needs to be downloaded again because the one you have is corrupt.

 

http://www.roxio.com/enu/support/emc10/contact.html

 

Now I have downloaded the program 3 different times, followed all the instructions of

using MSConfig to disable services and startup programs. I have wasted 3

days of my time trying to get this piece of CRAP to load on my XP SP2

computer. I have 1.5GB Ram, C=160GB, 120 of that is free, D=160GB, a USB WD

1TGB drive, have uninstalled all of Roxio 9.0 (which was working fine) and

other programs labeled Sonic but it still does not work.

 

Now everytime after I installed it on the computer my computer continually

reboots over and over until intervene with F8 and do a Safe Load and restore

to my restore point before I last attempted to install this junk.

 

I have been a user of Roxio since at least 5.0 and never was asked or had to

go into MSConfig. I have been working with computers since 1957 so I have

no trouble doing those things but think about a someone who is not real

knowledgeable doing those things. I have been a Beta tester for several

software programs in the past and never seen anything as buggy/junky like this one.

 

Roxie needs to correct the problems with this piece of crap and give us a download site to

try it. No more of this version/build number will be of value. The only

other option left is to refund my monies entirely to my PayPal credit card.

No one should have to do all this to get a off the shelf program.

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

Go read the "User" reviews of the product including mine nearl all give the product rating of ONE STAR!!!

 

 

 

 

Now I have downloaded the program 3 different times, followed all the instructions of

using MSConfig to disable services and startup programs. I have wasted 3

days of my time trying to get this piece of CRAP to load on my XP SP2

computer. I have 1.5GB Ram, C=160GB, 120 of that is free, D=160GB, a USB WD

1TGB drive, have uninstalled all of Roxio 9.0 (which was working fine) and

other programs labeled Sonic but it still does not work.

 

Now everytime after I installed it on the computer my computer continually

reboots over and over until intervene with F8 and do a Safe Load and restore

to my restore point before I last attempted to install this junk.

 

I have been a user of Roxio since at least 5.0 and never was asked or had to

go into MSConfig. I have been working with computers since 1957 so I have

no trouble doing those things but think about a someone who is not real

knowledgeable doing those things. I have been a Beta tester for several

software programs in the past and never seen anything as buggy/junky like this one.

 

Roxie needs to correct the problems with this piece of crap and give us a download site to

try it. No more of this version/build number will be of value. The only

other option left is to refund my monies entirely to my PayPal credit card.

No one should have to do all this to get a off the shelf program.

 

 

 

Were just users on here,just like you, tell Roxio

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...