Jump to content
  • 0
Mwm

Cineplayer "unhandled" Error In Vista

Question

After spending about six hours of my life with this problem, thought I'd post in the forlorn hope that my lost investment of time will benefit others. Just installed Creator V10 with Cineplayer on Vista Business.

 

When starting cineplayer, I immediately got a "threw an unhandled exception" error as soon as the app opens. After re-installation of V10 and various other deadends, I found the fix in http://kb.roxio.com/content/kb/Cineplayer/000001CP.

 

You have to run cineplayer the first time with the "run as administrator" option. No problems after that - but who'd have thought it?

 

Sorry I didn't write down the exact error message - God knows I saw it enough times to remember it, but I'm old. And now that it works, the message is gone.

Share this post


Link to post
Share on other sites

15 answers to this question

Recommended Posts

  • 0
After spending about six hours of my life with this problem, thought I'd post in the forlorn hope that my lost investment of time will benefit others. Just installed Creator V10 with Cineplayer on Vista Business.

 

When starting cineplayer, I immediately got a "threw an unhandled exception" error as soon as the app opens. After re-installation of V10 and various other deadends, I found the fix in http://kb.roxio.com/content/kb/Cineplayer/000001CP.

 

You have to run cineplayer the first time with the "run as administrator" option. No problems after that - but who'd have thought it?

 

Sorry I didn't write down the exact error message - God knows I saw it enough times to remember it, but I'm old. And now that it works, the message is gone.

I have found another strange wrinkle with Cineplayer on Vista Business. It can also hang if you try to start the program with a U3 drive attached to a USB port.

 

Admin mode does not fix the problem. But just unplug the drive and away it goes.

 

My guess is that it is something to do with Vista recognising the U3 stick as a CD and Cineplayer getting confused when it tries to play it.

 

On which, how can I turn off autoplay? It is turned off in Windows, but Cineplayer does not seem to respect that setting.

 

 

 

 

 

 

Share this post


Link to post
Share on other sites
  • 0
Guest ml
On which, how can I turn off autoplay? It is turned off in Windows, but Cineplayer does not seem to respect that setting.

 

Open Cineplayer and choose Settings from the menu. ( It's the wrech icon.)

 

Under the Playback tab set Default media player to NO. If that doesn't work, then it's probably still a Windows setting.

Edited by ml

Share this post


Link to post
Share on other sites
  • 0
Open Cineplayer and choose Settings from the menu. ( It's the wrech icon.)

 

Under the Playback tab set Default media player to NO. If that doesn't work, then it's probably still a Windows setting.

Good suggestion. Doesn't work.

 

For once it seems like Windows is at fault rather than Roxio's tat.

 

Share this post


Link to post
Share on other sites
  • 0
Guest ml

It's also possible that Windows tries to open Cineplayer as the default program to play that file.

 

In Vista, go to the Control Panel, then Default programs to see what files Windows has associated with Cineplayer.

Share this post


Link to post
Share on other sites
  • 0
It's also possible that Windows tries to open Cineplayer as the default program to play that file.

 

In Vista, go to the Control Panel, then Default programs to see what files Windows has associated with Cineplayer.

Nothing is associated with Cineplayer, beyond my aggravation.

 

The odd thing is that autoplay is disabled. If I put a DVD into the PC when Cineplayer is closed, nothing happens. But if I add a DVD with the software running, it tries to be helpful and offers to start the thing. (I have it set to ask about resuming.)

 

This only happens if I insert a DVD that Cineplayer has seen before. Try it on something new and nothing happens.

 

This is just plain crazy, not to mention annoying.

 

I would avoid Cineplayer altogether but neither RealPlayer nor Windows Media Player want to handle DVDs.

 

Media Player tells me to change the display settings, which is rubbish, and turns out to be an error that you may also see when it cannot find a DVD decoder.

 

I was under the impression that Media Player would recognise Cineplayer and handle DVDs.

 

Share this post


Link to post
Share on other sites
  • 0
Nothing is associated with Cineplayer, beyond my aggravation.

 

The odd thing is that autoplay is disabled. If I put a DVD into the PC when Cineplayer is closed, nothing happens. But if I add a DVD with the software running, it tries to be helpful and offers to start the thing. (I have it set to ask about resuming.)

 

This only happens if I insert a DVD that Cineplayer has seen before. Try it on something new and nothing happens.

 

This is just plain crazy, not to mention annoying.

 

I would avoid Cineplayer altogether but neither RealPlayer nor Windows Media Player want to handle DVDs.

 

Media Player tells me to change the display settings, which is rubbish, and turns out to be an error that you may also see when it cannot find a DVD decoder.

 

I was under the impression that Media Player would recognise Cineplayer and handle DVDs.

 

My WMP (ver 10) has no problem with DVDs. What version are you using. I don't understand what you mean by "Media Player would recognise Cineplayer". WMP and Cineplayer are 2 separate programs and one does not depend on the other. Of course I am using XP and will not touch Vista until I have to :angry2:

Edited by myguggi

Share this post


Link to post
Share on other sites
  • 0
Nothing is associated with Cineplayer, beyond my aggravation.

 

The odd thing is that autoplay is disabled. If I put a DVD into the PC when Cineplayer is closed, nothing happens. But if I add a DVD with the software running, it tries to be helpful and offers to start the thing. (I have it set to ask about resuming.)

 

This only happens if I insert a DVD that Cineplayer has seen before. Try it on something new and nothing happens.

 

This is just plain crazy, not to mention annoying.

 

I would avoid Cineplayer altogether but neither RealPlayer nor Windows Media Player want to handle DVDs.

 

Media Player tells me to change the display settings, which is rubbish, and turns out to be an error that you may also see when it cannot find a DVD decoder.

 

I was under the impression that Media Player would recognise Cineplayer and handle DVDs.

 

 

I don't like Cineplayer either but I like RealPlayer much lees. I like to keep both off my pc!

 

DVD Decoder (MPEG-2 Decoder) Plug-ins

 

Plug-ins for Windows Media Player

Plug-ins are optional components that you can add to Windows Media Player to extend its functionality. For example, you can add audio, video, or rendering effects as well as DVD playback capabilities.

 

http://www.microsoft.com/windows/windowsme...er/plugins.aspx

 

cd

Share this post


Link to post
Share on other sites
  • 0
Guest ml
The odd thing is that autoplay is disabled. If I put a DVD into the PC when Cineplayer is closed, nothing happens. But if I add a DVD with the software running, it tries to be helpful and offers to start the thing. (I have it set to ask about resuming.)

This only happens if I insert a DVD that Cineplayer has seen before. Try it on something new and nothing happens.

This is just plain crazy, not to mention annoying.

 

I would avoid Cineplayer altogether but neither RealPlayer nor Windows Media Player want to handle DVDs.

 

Media Player tells me to change the display settings, which is rubbish, and turns out to be an error that you may also see when it cannot find a DVD decoder.

I was under the impression that Media Player would recognise Cineplayer and handle DVDs.

Actually, the fact the when you have Cineplayer open and insert a DVD that you've played before, the program asks if you want to resume playback makes sense. Unfortunately, I don't see an option to turn off it seeing that DVD. It obviously ignore DVDs that it hasn't seen before.

 

One last thing you can try..... go to Start \ All Programs\ Accessories\ choose Run. Type msconfig You'll get a pop-up window (after the Windows Vista warnings). Go to the Startup tab, find the DMXLauncher..... note that the program is c:\..... Roxio\Cineplayer....... Uncheck the tab and click Apply, Ok.

 

That will keep Cineplayer from launching at startup and should keep it quiet until you want to manually start it from the EMC10 menu and use it.

 

You can blame Microsoft for Media Players problems with DVDs. Vista Business doesn't include Windows Media Center which plays DVDs. Of course, that program isn't perfect either.

Share this post


Link to post
Share on other sites
  • 0
My WMP (ver 10) has no problem with DVDs. What version are you using. I don't understand what you mean by "Media Player would recognise Cineplayer". WMP and Cineplayer are 2 separate programs and one does not depend on the other. Of course I am using XP and will not touch Vista until I have to :angry2:

I should have said, "Media Player would recognise Cineplayer's decoder".

 

My version of Vista, Business, does not come with a DVD decoder. In earlier versions of Windows, Media Player, and other DVD players, recognised other DVD decoders and worked just fine.

 

If you follow Microsoft's misleading information trail for the "No decoder" scenario, you end up at a page which offers to sell you the Cineplayer Codec pack. Er, I thought I had that as a part of the Roxio Suite. Media Player doesn't want to know.

 

The only reason why I installed Roxio on the new PC was to get the DVD decoder. (Sadly, it does not allow you to install just that, so I had to include most of the package.)

 

I was like you with Vista. But I needed to build a new PC and didn't want to mess around with Vista in a year or two. In the event, the experience has been mostly fine. I had to turn off the excessively nannying User Account Control. But apart from that, the system has been very stable. All of my software and hardware work.

 

I did hang back until Vista SP1 was imminent. I installed that yesterday. Like many people, it seems, I lost my sounds. But reinstalling the drivers fixed that.

 

Share this post


Link to post
Share on other sites
  • 0
Guest ml

Back to your problem.....

 

Did you try disabling Cineplayer on startup (my previous post) and see if that stopped the program from opening up every time you inserted the USB or a previously inserted DVD? ( I'm curious to know if it works, and if it doesn't, you can reverse the process.)

Share this post


Link to post
Share on other sites
  • 0
Back to your problem.....

 

Did you try disabling Cineplayer on startup (my previous post) and see if that stopped the program from opening up every time you inserted the USB or a previously inserted DVD? ( I'm curious to know if it works, and if it doesn't, you can reverse the process.)

Thanks. I had disabled all the Roxio start up stuff.

 

Well, I thought I had. But following your message I went back in an found that the one you listed was checked. It sat alongside a disabled version of the same thing!

 

I will report back when I have had some time to test the results.

 

Share this post


Link to post
Share on other sites
  • 0
Back to your problem.....

 

Did you try disabling Cineplayer on startup (my previous post) and see if that stopped the program from opening up every time you inserted the USB or a previously inserted DVD? ( I'm curious to know if it works, and if it doesn't, you can reverse the process.)

Nope that has no effect. At least, here's what happened.

 

Do as you suggest.

 

Insert DVD into drive. Start Cineplayer. DVD does not start.

 

Start DVD. Stop DVD. Shutdown Cineplayer.

 

Leave DVD in drive. Start Cineplayer. DVD starts playing.

 

There is a missing button in Cineplayer. On the Playback Options tab, it offers three choices for "Resume Playback of Previously Viewed Title"

 

The missing button is "Do nothing".

 

 

 

Share this post


Link to post
Share on other sites
  • 0
Guest ml
Nope that has no effect. At least, here's what happened.

Do as you suggest.

Insert DVD into drive. Start Cineplayer. DVD does not start.

Start DVD. Stop DVD. Shutdown Cineplayer.

Leave DVD in drive. Start Cineplayer. DVD starts playing.

There is a missing button in Cineplayer. On the Playback Options tab, it offers three choices for "Resume Playback of Previously Viewed Title"

The missing button is "Do nothing".

We're now talking about different things.

 

You're original question was..... "..... how can I turn off autoplay? It is turned off in Windows, but Cineplayer does not seem to respect that setting."

 

By disabling Cineplayer in the msconfig Startup tab, you're preventing Cineplayer from automatically starting and looking for DVDs in that DVD drive. That will eliminate Cineplayer automatically playing a previously viewed DVD when you put it in the drive.

 

However, that means that when you want to play a DVD, you'll have to launch EMC 10, launch Cineplayer, put the DVD in the drive and either wait for Cineplayer to recoginze the DVD or Browse the folders to find your DVD drive.

 

You can't have it both ways. Either you let Cineplayer start on startup and let it attempt to play the DVDs or launch it only when you need to play a DVD.

 

One more thing....Check under the Tools\ DVD and make certain that your DVD drive is the default drive for playback. ( This also might address the U3 drive problem if that is selected as the default drive. However, it might not have anything to do with it.)

Share this post


Link to post
Share on other sites
  • 0
We're now talking about different things.

 

You're original question was..... "..... how can I turn off autoplay? It is turned off in Windows, but Cineplayer does not seem to respect that setting."

 

By disabling Cineplayer in the msconfig Startup tab, you're preventing Cineplayer from automatically starting and looking for DVDs in that DVD drive. That will eliminate Cineplayer automatically playing a previously viewed DVD when you put it in the drive.

 

However, that means that when you want to play a DVD, you'll have to launch EMC 10, launch Cineplayer, put the DVD in the drive and either wait for Cineplayer to recoginze the DVD or Browse the folders to find your DVD drive.

 

You can't have it both ways. Either you let Cineplayer start on startup and let it attempt to play the DVDs or launch it only when you need to play a DVD.

 

One more thing....Check under the Tools\ DVD and make certain that your DVD drive is the default drive for playback. ( This also might address the U3 drive problem if that is selected as the default drive. However, it might not have anything to do with it.)

I clearly have not explained what I am doing well enough.

 

I do not want Cineplayer to Autoplay or Autostart. (You seem to be the one confusing two things here.)

 

You say:

 

You can't have it both ways. Either you let Cineplayer start on startup and let it attempt to play the DVDs or launch it only when you need to play a DVD.

 

That's now how it is working. I have Cineplayer turned off at startup, always have. I don't want it to attempt to play any CDs when it starts. No matter how I start it. Automatically or manually.

 

Sadly, the idea that your suggestion will "eliminate Cineplayer automatically playing a previously viewed DVD when you put it in the drive" is just plain wrong from my experience.

 

I am happy to launch it when I want to play a DVD.

 

What I don't want is for it to automatically play a DVD when I start it.

 

I want Cineplayer to start and sit there until I tell it to do something.

 

I don't want it to peek into the DVD tray, see something and spring into action.

 

I don't want it to to say to itself, "Hey, he has just put a DVD in the tray. I had better play it."

 

In other words, I want it to behave like Media Player, Real Player or any other software.

 

I want it to do what I tell it, not what it takes it into its head to do.

 

Looking at it, my original question was spot on.

 

"how can I turn off autoplay? It is turned off in Windows, but Cineplayer does not seem to respect that setting".

 

I think perhaps the key is in the second bit "Cineplayer does not seem to respect that [autoplay turned off] setting".

 

Apologies for not explaining it at greater length in my original message.

 

I have now described what happens in so many ways that I hope it is clearer what is happening.

 

My guess is that my description baffled you because Cineplayer behaves differently on your PC. This does not surprise me given the mess that Roxio has created by creating this sloppy bundle of disparate software.

 

 

Share this post


Link to post
Share on other sites
  • 0
Guest ml

I understand what you are saying and you are correct. The problem doesn't occur in my Windows Vista Home Premium.

 

In Cineplayer, under Tools\ Options, I have selected the option "Set as Default DVD Player" to NO and when I insert a DVD into the drive, Cineplayer does NOT launch even when I insert a previously played DVD. It simply doesn't see the DVD until I launch Cineplayer. ( I also have it disabled from lauching automatically at startup under the msconfig Startup tab.)

 

Why it behaves differently on Vista Business doesn't make much sense to me.

 

I'd suggest you contact Roxio Tech Support via email and tell them of the problem.

Edited by ml

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×