Jump to content
  • 0
JCochranUSN

Crossfade Not Working

Question

The most bizarre thing is happening to me. I've never ANY trouble with crossfading tracks on Toast. Recently, I upgraded to Toast 9 and my crossfades arent working properly.

 

I will set the custom crossfade and then "apply" but it doesnt save. The crossfade doesnt set, it just goes back to the tracklist and it's like I never did the crossfade. I can preview the crossfade in the crossfade window and it sounds perfect, but it doesnt save.

 

I've noticed that it only does this with certain tracks. I really dont get it. I uninstalled Toast 9 and went back to Toast 8, and now Toast 8 is doing it too!

 

 

Does anyone have any ideas how to stop this?

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

I suggest trashing the Toast plist and prefs files from your User>Library>Preferences folder and relaunching Toast.

Share this post


Link to post
Share on other sites
  • 0
I suggest trashing the Toast plist and prefs files from your User>Library>Preferences folder and relaunching Toast.

 

 

This still didn't work:( Man, why does stuff like this always have to happen to me....all i want to do is make a simple audio CD.

 

 

ANyone else have any ideas? This is such BS. I'm so pissed. I used to be able to make such great CDs where every track blended together.

 

ANYONE??

Share this post


Link to post
Share on other sites
  • 0
This still didn't work:( Man, why does stuff like this always have to happen to me....all i want to do is make a simple audio CD.

 

 

ANyone else have any ideas? This is such BS. I'm so pissed. I used to be able to make such great CDs where every track blended together.

 

ANYONE??

What kind of details can yo provide so that I can try doing the same thing with the same kind of source audio files? What kind of Mac are you using and which OS?

Share this post


Link to post
Share on other sites
  • 0
What kind of details can yo provide so that I can try doing the same thing with the same kind of source audio files? What kind of Mac are you using and which OS?

 

 

I'm using a brand new (3 months old) IMac with Leopard on it.

 

The files I'm working with are all mp3s only. All of them were downloaded from the net.

 

What else would you like to know? I'll tell u anything, i just want to fix this:(

 

 

THANKS FOR YOUR HELP!!

Share this post


Link to post
Share on other sites
  • 0
What kind of details can yo provide so that I can try doing the same thing with the same kind of source audio files? What kind of Mac are you using and which OS?

 

 

Also, i completely re-installed MAC OSX LEOPARD today. The whole entire operating system, and i'm STILL having this error in Toast with certain tracks.

 

WTF!!!???

Share this post


Link to post
Share on other sites
  • 0
Also, i completely re-installed MAC OSX LEOPARD today. The whole entire operating system, and i'm STILL having this error in Toast with certain tracks.

 

WTF!!!???

You say this happens with some files and not others and your files are mp3's that likely were encoded from different sources. If you don't already have them in iTunes add the mp3s to iTunes. Select in iTunes one of the ones that works in Toast choose Get Info. Note the bit rate, sample rate, channels and other info about the files. Now do the same with one that doesn't work. Are there any differences in how the mp3s are described?

 

A good workaround could be to set iTunes encoder preference to AIFF and convert those mp3s in iTunes to AIFF files (44.1 khz, 16-bit). Then add those to the Toast windown. You could skip iTunes altogether by adding the mp3s to the Toast Convert window and convert to AIFF. Toast has to do this anyway in order to create the audio CD so you're just doing it as a separate step.

 

I don't have any problems with setting crossfades in Toast with the mp3s I've downloaded from eMusic.com and I don't know what is different with your files.

Share this post


Link to post
Share on other sites
  • 0
You say this happens with some files and not others and your files are mp3's that likely were encoded from different sources. If you don't already have them in iTunes add the mp3s to iTunes. Select in iTunes one of the ones that works in Toast choose Get Info. Note the bit rate, sample rate, channels and other info about the files. Now do the same with one that doesn't work. Are there any differences in how the mp3s are described?

 

A good workaround could be to set iTunes encoder preference to AIFF and convert those mp3s in iTunes to AIFF files (44.1 khz, 16-bit). Then add those to the Toast windown. You could skip iTunes altogether by adding the mp3s to the Toast Convert window and convert to AIFF. Toast has to do this anyway in order to create the audio CD so you're just doing it as a separate step.

 

I don't have any problems with setting crossfades in Toast with the mp3s I've downloaded from eMusic.com and I don't know what is different with your files.

 

 

Does the bitrate really matter? The only differences between the two files I was trying to crossfade are the bitrate...the first one was 320, the second one was 128. Would that really make them NOT crossfade? everything else was the same...44.1khz, mpeg 1-layer 3, stereo channels

 

so can the bitrate really cause the two files to not crossfade?

Share this post


Link to post
Share on other sites
  • 0
Does the bitrate really matter? The only differences between the two files I was trying to crossfade are the bitrate...the first one was 320, the second one was 128. Would that really make them NOT crossfade? everything else was the same...44.1khz, mpeg 1-layer 3, stereo channels

 

so can the bitrate really cause the two files to not crossfade?

I agree with you that the bit rate shouldn't matter. Now that I know the specs on your files I can check if I have the same issue with mp3s encoded at 128 kbps.

 

Let me know if converting that mp3 to AIFF succeeds as a workaround.

Share this post


Link to post
Share on other sites
  • 0
I agree with you that the bit rate shouldn't matter. Now that I know the specs on your files I can check if I have the same issue with mp3s encoded at 128 kbps.

 

Let me know if converting that mp3 to AIFF succeeds as a workaround.

 

 

I'm at work right now so I can't do the converting at this time, but i will the MINUTE i get home and I'll let you know.

 

something else i forgot to mention, the songs that are NOT crossfading now...used to crossfade perfectly before. so something happened that made it stop working.

 

now that I think about it, when I upgraded to Toast 9 is when i noticed this problem. tracks the previously would crossfade perfectly just stopped working. Also, its not always the SAME tracks that don't crossfade. sometimes a certain track will work and other will not...and vice versa. its very bizzarre

 

 

when I tried to downgrade back to Toast 8, the problem still occured.

 

 

NIGHTMARE

Share this post


Link to post
Share on other sites
  • 0
I'm at work right now so I can't do the converting at this time, but i will the MINUTE i get home and I'll let you know.

 

something else i forgot to mention, the songs that are NOT crossfading now...used to crossfade perfectly before. so something happened that made it stop working.

 

now that I think about it, when I upgraded to Toast 9 is when i noticed this problem. tracks the previously would crossfade perfectly just stopped working. Also, its not always the SAME tracks that don't crossfade. sometimes a certain track will work and other will not...and vice versa. its very bizzarre

 

 

when I tried to downgrade back to Toast 8, the problem still occured.

 

 

NIGHTMARE

I just tested with some mp3s I created in iTunes and the cross fades work perfectly on my MacBook Pro running 10.5.2. I'm sorry that I can't figure out why this isn't working right on your Mac. I'm not aware of anyone else who has posted with a similar issue.

Share this post


Link to post
Share on other sites
  • 0
I just tested with some mp3s I created in iTunes and the cross fades work perfectly on my MacBook Pro running 10.5.2. I'm sorry that I can't figure out why this isn't working right on your Mac. I'm not aware of anyone else who has posted with a similar issue.

 

 

 

ahh...just my luck i guess. should i try a complete ERASE & INSTALL of the operating system?

 

what all folders should I inidividually delete to remove EVERY LAST TRACE of the Toast program? i want to delete EVERYTHING that involves Toast and then do another clean install of Leopard.

 

 

also...will Roxio help me with this?

 

and where did you buy your copy of Toast...or did you download it?

Share this post


Link to post
Share on other sites
  • 0
ahh...just my luck i guess. should i try a complete ERASE & INSTALL of the operating system?

 

what all folders should I inidividually delete to remove EVERY LAST TRACE of the Toast program? i want to delete EVERYTHING that involves Toast and then do another clean install of Leopard.

 

 

also...will Roxio help me with this?

 

and where did you buy your copy of Toast...or did you download it?

Trash the Toast folder and the two files in your User>Library>Preferences folders that have toast in their name. One is a plist and one is a prefs file. That removes Toast.

 

Do you have DiskWarrior? If not I recommend getting it because I consider it essential for Mac users. Running it may fix some issue that's triggering the problem with Toast. You also might download and apply the latest Combined System Update because that also sometimes fixes odd problems that can occur following an incremental system update.

Share this post


Link to post
Share on other sites
  • 0
Trash the Toast folder and the two files in your User>Library>Preferences folders that have toast in their name. One is a plist and one is a prefs file. That removes Toast.

 

Do you have DiskWarrior? If not I recommend getting it because I consider it essential for Mac users. Running it may fix some issue that's triggering the problem with Toast. You also might download and apply the latest Combined System Update because that also sometimes fixes odd problems that can occur following an incremental system update.

 

 

forgive me if this is a stupid question...but what is a Combine System Update and where can I find it? Is this different than the normal updates that my computer gets and warns me I need to restart?

 

Where do i download combined system updates?

 

 

Thanks again for your help!

Share this post


Link to post
Share on other sites
  • 0
forgive me if this is a stupid question...but what is a Combine System Update and where can I find it? Is this different than the normal updates that my computer gets and warns me I need to restart?

 

Where do i download combined system updates?

 

 

Thanks again for your help!

Go to This Page and you'll see the combo update listed in the Featured Downloads box. It is different from the the incremental update that was installed using the Software Updates page but in theory you should end up with exactly the same as you have now. However, there are times when incremental software updates don't get everything quite right and the fix for this is to apply the combo update.

Share this post


Link to post
Share on other sites
  • 0

I personally suspect that the problem is with the source files. Try taking both files and re-encoding them in iTunes. Just set the encoding properties you want in the iTunes preferences (under Advanced - importing), and then with the file selected in iTunes go to the Advanced menu and select "convert selection to..."

Share this post


Link to post
Share on other sites
  • 0
I personally suspect that the problem is with the source files. Try taking both files and re-encoding them in iTunes. Just set the encoding properties you want in the iTunes preferences (under Advanced - importing), and then with the file selected in iTunes go to the Advanced menu and select "convert selection to..."

 

 

 

I thought this could be the case also...but then why would the same songs have WORKED before but not now? How could they have changed overnight?

Share this post


Link to post
Share on other sites
  • 0
I thought this could be the case also...but then why would the same songs have WORKED before but not now? How could they have changed overnight?

 

I'm not sure. I have several files that didn't play properly on my iphone and then i noticed that these were the same ones I had problems with in Toast. I just encoded them over again and the problem went away. I'm not sure what the cause was, but that was the solution for sure.

Share this post


Link to post
Share on other sites
  • 0
I'm not sure. I have several files that didn't play properly on my iphone and then i noticed that these were the same ones I had problems with in Toast. I just encoded them over again and the problem went away. I'm not sure what the cause was, but that was the solution for sure.

 

I have the same problem. I have totally wasted $100 because Jam 6 works better with my new 3.06ghz iMac or Penryn-version Macbook Pro than Toast 9, in terms of crossfading. I've been in contact with three telephone service people at Roxio and none know what to do. They've had me trash certain files, download updates, try without updates, go through the computer trashing the myriad of files Toast 9 places in every nook and cranny of the hard drive.... I've clean erased and reinstalled my computer's operating system and all software THREE TIMES and it is IMPOSSIBLE to crossfade without a dropout sound appearing at the point one places the track divider bar. As soon as "Apply" is clicked, the problem is apparent. Only by returning to the crossfade window can you hear the crossfade as it should be. But one has to hit "Apply" before you can do anything with it, and then the fault is there.

 

I went to the Apple Store where I bought this Toast 9 for $99 (!) to check if there were any solutions they could think of. No ideas from them. Fortunately, from a quick test of Jam 6, it seems that works with the latest version of OSX. Deeper inspection might show some incompatibilities I suppose, but having tested the main crossfade function, it works. But tonight I was stupid enough to try Toast 9 again... with the same result... and I'll soon be doing another erase and install.

 

It's nothing to do with the audio files. I've used AIFF files from both CDRs and several standard commercial CDs with Toast 9, plus files of tracks previously crossfaded in Jam and burned on previous versions of Toast (like Toast 7), with ALL showing the same problem when used to crossfade in Toast 9.

 

Jam has been my prime crossfade tool for years and now it is apparently ruined. I dare say future OSX updates will render the now-unsupported Jam 6 useless too, not too long from now.

 

UPDATE: Just tried the suggestion of transferring the AIFF files to iTunes (as AIFF files) and importing them to Toast 9 via iTunes. Makes no difference. There is still a sound "bump" in all crossfades made in Toast 9, at the point of the track marker.

 

I shall use Jam 6 for the time being. But as I've paid for this unusable Toast 9 and can't get my money back, I hope Roxio will remedy this soon so I can actually use it sometime! But that seems unlikely, judging from the fact that no-one there seems to have spotted this problem for themselves.

Edited by Sir Cecil

Share this post


Link to post
Share on other sites
  • 0
Jam has been my prime crossfade tool for years and now it is apparently ruined. I dare say future OSX updates will render the now-unsupported Jam 6 useless too, not too long from now.

 

I hate to be the one to tell you this, but the crossfade tool hasn't changed since Jam 6.

 

Be that as it may, I did the following test.

NOTE: I ripped and burned commercial audio for testing purposes only. The final disc that I burned has been shredded. Shredding discs is noisy by the way. I now fear my wife more then the RIAA :D

 

Step 1: Import 3 tracks directly into iTunes from a commercial audio CD. Import settings are set to AIFF (44.8Khz, 16-bit, stereo).

Step 2: Add to Toast 9 and use the crossfade tool to overlap the songs quite a bit with the track change marker set right in the middle of the crossfade.

Step 3 Burned the disc. When I was about to burn, I realized your problem might be here. I confirmed on the advanced tab that DAO was selected. If your burn is set to TAO it is impossible to have a true zero second pause. TAO, by definition, will disengage and reengage the laser between each track.

Step 4: Listened to the final disc in iTunes. I skipped the whole song and just played back the last 10 and first 10 seconds of the crossfaded tracks. I closed my eyes and could not tell at all when the track number changed during playback.

 

I hope your problem is as I suspect in Step 3, otherwise, I cant tell what could possibly be wrong. However, I confirmed here, now, in the middle of the night, sitting in bed, that this works properly when I try it.

Share this post


Link to post
Share on other sites
  • 0

Thanks for the response. And thanks for going to the trouble of checking your Toast 9. But I can confirm the re-vamped "Jam" in Toast 9 still has the problems I've mentioned.

 

The problem becomes apparent before the burning stage, and exhibits itself as soon as "Apply" is clicked after preparing the crossfade and the window changes back to the tracklisting. From that window, every track join ehibits the problem on audition. In any case, the preferences are set to DAO.

 

There is no doubt about this. I'm doing nothing differently than when I'm using Jam 6 (which is fine). Two different computers (Macbbok Pro and iMac) have been tried. It's all the more annoying to now know that Jam 6 and the Toast 9 version are the same (apart from some bug that seems to me to have entered in the cosmetic change from one to the other). It means I've spent $100 for nothing, even if it was working properly! Oh well...

 

THERE HAS BEEN ONE SMALL CHANGE: When I used the Toast 9 install disc yesterday (9.0) and did NOT subsequently download the update, and imported via iTunes, I initially thought the problem might be solved. The first pair of tracks crossfaded (tracks 1 and 2 of 3) DID NOT show the problem when "Apply" was hit. Auditioning the crossfade in the main track window, the crossfade sounded smooth.

I actually got quite excited! But on doing the next crossfade (tracks 2 and 3), that one showed the usual problem and worst than that, the first crossfade was now affected too. Trying again several times, I've been unable to produce another single example of a crossfade without the problem.

Edited by Sir Cecil

Share this post


Link to post
Share on other sites
  • 0

I have the same problem with Toast 9.0.2 on my Mac G5 dual 2.7_10.4.9.

 

But, it only occurs when I playback crossfaded material or anything joined with a "0" sec pause.

 

The burned CD itself does not reproduce the glitch when played back through different software. I-Tunes for example. But if I import the same CD back into Toast 9.0.2 I hear the same glitch.

 

So it seem to me to be a playback issue. At least with me. I am curious. Have you tried playing the CD back with different software or through another computer or CD player?

 

 

 

 

Thanks for the response. And thanks for going to the trouble of checking your Toast 9. But I can confirm the re-vamped "Jam" in Toast 9 still has the problems I've mentioned.

 

The problem becomes apparent before the burning stage, and exhibits itself as soon as "Apply" is clicked after preparing the crossfade and the window changes back to the tracklisting. From that window, every track join ehibits the problem on audition. In any case, the preferences are set to DAO.

 

There is no doubt about this. I'm doing nothing differently than when I'm using Jam 6 (which is fine). Two different computers (Macbbok Pro and iMac) have been tried. It's all the more annoying to now know that Jam 6 and the Toast 9 version are the same (apart from some bug that seems to me to have entered in the cosmetic change from one to the other). It means I've spent $100 for nothing, even if it was working properly! Oh well...

 

THERE HAS BEEN ONE SMALL CHANGE: When I used the Toast 9 install disc yesterday (9.0) and did NOT subsequently download the update, and imported via iTunes, I initially thought the problem might be solved. The first pair of tracks crossfaded (tracks 1 and 2 of 3) DID NOT show the problem when "Apply" was hit. Auditioning the crossfade in the main track window, the crossfade sounded smooth.

I actually got quite excited! But on doing the next crossfade (tracks 2 and 3), that one showed the usual problem and worst than that, the first crossfade was now affected too. Trying again several times, I've been unable to produce another single example of a crossfade without the problem.

 

Share this post


Link to post
Share on other sites
  • 0
I have the same problem. I have totally wasted $100 because Jam 6 works better with my new 3.06ghz iMac or Penryn-version Macbook Pro than Toast 9, in terms of crossfading. I've been in contact with three telephone service people at Roxio and none know what to do. They've had me trash certain files, download updates, try without updates, go through the computer trashing the myriad of files Toast 9 places in every nook and cranny of the hard drive.... I've clean erased and reinstalled my computer's operating system and all software THREE TIMES and it is IMPOSSIBLE to crossfade without a dropout sound appearing at the point one places the track divider bar. As soon as "Apply" is clicked, the problem is apparent. Only by returning to the crossfade window can you hear the crossfade as it should be. But one has to hit "Apply" before you can do anything with it, and then the fault is there.

 

I went to the Apple Store where I bought this Toast 9 for $99 (!) to check if there were any solutions they could think of. No ideas from them. Fortunately, from a quick test of Jam 6, it seems that works with the latest version of OSX. Deeper inspection might show some incompatibilities I suppose, but having tested the main crossfade function, it works. But tonight I was stupid enough to try Toast 9 again... with the same result... and I'll soon be doing another erase and install.

 

It's nothing to do with the audio files. I've used AIFF files from both CDRs and several standard commercial CDs with Toast 9, plus files of tracks previously crossfaded in Jam and burned on previous versions of Toast (like Toast 7), with ALL showing the same problem when used to crossfade in Toast 9.

 

Jam has been my prime crossfade tool for years and now it is apparently ruined. I dare say future OSX updates will render the now-unsupported Jam 6 useless too, not too long from now.

 

UPDATE: Just tried the suggestion of transferring the AIFF files to iTunes (as AIFF files) and importing them to Toast 9 via iTunes. Makes no difference. There is still a sound "bump" in all crossfades made in Toast 9, at the point of the track marker.

 

I shall use Jam 6 for the time being. But as I've paid for this unusable Toast 9 and can't get my money back, I hope Roxio will remedy this soon so I can actually use it sometime! But that seems unlikely, judging from the fact that no-one there seems to have spotted this problem for themselves.

 

Send me a private message with a step by step method to recreate the problem and I'll look in to this...

 

Share this post


Link to post
Share on other sites
  • 0
Send me a private message with a step by step method to recreate the problem and I'll look in to this...

 

Thanks. But there's nothing I can add that I haven't said already. Using the latest iMac 3.06ghz or a Macbook Pro, even with Toast 9 being the only application added after a clean erase and install, the crossfades exhibit a fault (dropout effect) at the point of the track marker after "Apply" is clicked in the crossfade window on completion of the crossfade process. All crossfaded tracks in the main window exhibit the fault, though it is not apparent in the individual crossfade windows themselves, while constructing the crossfade.

 

This does not happen in Jam 6. It happens with all crossfades in Toast 9, whatever import option has been chosen for the tracks – and whether AIFF, SDII or whatever. The effect is OBVIOUS through headphones (whether using the computer's own headphone or a third-party audio interface) and renders the software useless. The problem is the same whether using the recent Toast 9 software update or not.

 

The software has been re-installed four times, with and without updates, and always shows the same problem, regardless of the machine used. Tracks are set for zero pause. Rather than hope for a solution, all I'm hoping for at present is that someone at Roxio will actually recognize this obvious fault!

Share this post


Link to post
Share on other sites
  • 0

Just made the mistake of trying again, installing Toast 9 after a fresh erase and install of the latest OSX. Total waste of time. Dropouts at every crossfade point. I'd have been better off not buying a new computer or Toast 9 and sticking with Panther and Jam 6. Why was it that I knew if something was going to destroy the pleasure of upgrading, it would be something that Roxio had a hand in? Weeks go by and they say they can't even detect the problem. Yet four people out of four I've spoken to are in the exact same boat as me. Pitiful.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×