Jump to content
  • Who's Online   0 Members, 0 Anonymous, 15 Guests (See full list)

    • There are no registered users currently online
  • 0

EMC8 Asking To Register On Every Launch


quiquef

Question

Every time I launch MC8 or any of its components I get the get registered window.

Every time, I enter the information, I send the info and the I can start working from that point on.

 

I am sure it connects and sends the registration information because:

1.- My firewall warns me of the connection attempt (that I allow)

2.- I get a thank you for registering message.

 

But, next time I'll have to go through the same process again.

 

If I select the do not want to register, leave me alone option, it makes no difference.

 

It is becoming quite an annoyance.

 

How can I get rid of that process?

Link to comment
Share on other sites

12 answers to this question

Recommended Posts

The creating a new account test I suggested doesn't have a user entering the registry at all, but it is testing the same thing. The reason I have seen for this issue is incorrect permissions in the registry. Creating a new administrator account recreates the permissions for the new user based on the hidden Administrator account.

 

William

Link to comment
Share on other sites

Sorry William, but in my reply I was trying to refer back to the post made by himanshuatrox, which had the OP going into the Registry and making some changes etc.

 

I was not referring to the other test you suggested regarding creating a new administrator account. I hope that gets me off the hook. :)

 

Frank....

Link to comment
Share on other sites

I can't follow this. I'm using Windows XP Home SP2 on a new Dell machine and logged into an account I created which has administrator privs. I am not using the standard logging prompt, just the icon login but with passwords. Basically you state a bunch of stuff in the long version and then at the end you say you "corrected the access rights". Can you explain what that means? I don't see the full path like you said. There is nothing after Software\Sonic\ like "Registration" which I think is what you were saying in most of the paragraphs. Do I need to log on to the Administrator account like you said? Dell doesn't tell you what the Administrator account is. Perhaps I can create a user with that name and set the password for the first time myself?

 

Matt

 

 

OK Got it finally working.

 

How I did it?

 

-- SHORT VERSION ----------------

I added access rights to the admin group to the HKCU\Software\Sonic key.

The solution to my (our) problem had nothing to do with HKCU\Software\Roxio or HKLM\Software\Roxio, but with HKCU\Software\Sonic.

-- LONG VERSION ------------------

Once upon the time I installed EMC8 with my user. My user belongs to the administrators group but it is not the administrator user. So far this has worked with all the SW I've installed (and believe me it is quite a few). In my environment, working directly from the Administrator account is considered ... inappropiate.

 

Anyhow, I logged in as Administrator, and checked with regedit that "HKEY_CURRENT_USER\Software\Sonic\Registration\Roxio Easy Media Creator 8" was not there (thanks for the info, this really pointed to the solution)

 

Then I launched EMC8, and voila, ... please get registred ... that was expected, so I registered once again. Inmediately went to the registry and the key was created , .. good ... tryied launching EMC8 again and the get registered window did not show up.

 

Then I logged out as administrator, logged in as myself (belonging to the administrators group). Before trying to launch EMC8 I just had a look at the registry (yes, I am that kind of guy), and shoot, key was not there.. but I saw it ... but now it is gone.

 

Even tryied launching EMC8 (yes I also believe in fairies), and obviously I got the get registered window.

 

Well HKEY_CURRENT_USER points to exactly that: CURRENT_USER, and I am not the admin any longer, but a member of the admin group.

 

As I am a little lazy I logged in as admin again, exported that branch of the registry, re-logged back as myself, imported the reg file ... and didn't work, because the HKEY_CURRENT_USER\Software\Sonic key does not have the correct access rights (well it had none of them for nobody).

 

I corrected the access rights, imported the file, and had my problem solved.

Thanks for your help

Quique

Link to comment
Share on other sites

Well i`ve gone through the above procedure twice now, just to be sure i didn`t miss a stage.....

 

But Emc8 still continues to lauch the registration screen :huh:

 

 

 

Any other ideas on a fix?

 

Someone else must have this problem, starting to think i should of brought nero :)

Link to comment
Share on other sites

I went through the proposed fix ... no difference ... I keep getting the "Get Registered" window.

 

Is there any additional information you (Roxio team) might need in order to locate the reason for this behaviour? Please let us know

Link to comment
Share on other sites

OK Got it finally working.

 

How I did it?

 

-- SHORT VERSION ----------------

I added access rights to the admin group to the HKCU\Software\Sonic key.

The solution to my (our) problem had nothing to do with HKCU\Software\Roxio or HKLM\Software\Roxio, but with HKCU\Software\Sonic.

 

 

-- LONG VERSION ------------------

Once upon the time I installed EMC8 with my user. My user belongs to the administrators group but it is not the administrator user. So far this has worked with all the SW I've installed (and believe me it is quite a few). In my environment, working directly from the Administrator account is considered ... inappropiate.

 

Anyhow, I logged in as Administrator, and checked with regedit that "HKEY_CURRENT_USER\Software\Sonic\Registration\Roxio Easy Media Creator 8" was not there (thanks for the info, this really pointed to the solution)

 

Then I launched EMC8, and voila, ... please get registred ... that was expected, so I registered once again. Inmediately went to the registry and the key was created , .. good ... tryied launching EMC8 again and the get registered window did not show up.

 

Then I logged out as administrator, logged in as myself (belonging to the administrators group). Before trying to launch EMC8 I just had a look at the registry (yes, I am that kind of guy), and shoot, key was not there.. but I saw it ... but now it is gone.

 

Even tryied launching EMC8 (yes I also believe in fairies), and obviously I got the get registered window.

 

Well HKEY_CURRENT_USER points to exactly that: CURRENT_USER, and I am not the admin any longer, but a member of the admin group.

 

As I am a little lazy I logged in as admin again, exported that branch of the registry, re-logged back as myself, imported the reg file ... and didn't work, because the HKEY_CURRENT_USER\Software\Sonic key does not have the correct access rights (well it had none of them for nobody).

 

I corrected the access rights, imported the file, and had my problem solved.

 

 

Thanks for your help

Quique

Link to comment
Share on other sites

I also have the same problem, and it is more than annoying as it asks me to register everytime a different tool opens.

 

My version did complete the onlne registration as the cdkey now appears in the "my roxio" folder online

 

Anyone got any ideas on a solution/where to get help from.....?? without paying £1 a minute to ring up someone in the uk??

 

 

 

help ppl ?

Link to comment
Share on other sites

In the registry, you can check to determine if this key exists. HKEY_CURRENT_USER\Software\Sonic\Registration\Roxio Easy Media Creator 8.

This key is where the software keeps track of whether it has been registered or not. If this key has not been created due to registry permission issues, you can see the problems you are describing.

 

Another test is to create a new Administrator account on the computer. Log into the new administator account, and launch the software. Run through the registration process. Close the program, and reopen it. Does the registration run again?

 

William

Link to comment
Share on other sites

Reading this particular posted problem, I assume it is not just an isolated case from one person. Am I to believe that for those that this happening too have to be that "Registry" knowlegeable to solve the problem ? Sounds like those posting here have but I would think that there should be a better and more simple way of solving the registration problem than having to deal with the registry. I'm guessing that there are a lot of other users out there that shouldn't be playing around with their registry, as they will probably really get themselves in a mess. BTW, I'm not "knocking" EMC 8. Can't Roxio come up with a downloadable fix for those that this is happening to ? (Just a suggestion).

 

Frank.....

Link to comment
Share on other sites

In the registry, please check permissions:

 

Backup the Registry :

 

- Click the START button and select RUN from the menu.

- Type "regedit" and press ENTER

- First, we need to make a backup of your registry. Click on FILE in the upper left hand corner, and choose EXPORT.

- Name the file BACKUP, and choose to save it on your desktop.

- Before clicking on SAVE, make sure that ALL is selected under EXPORT RANGE (located at the bottom of the screen).

- Click SAVE, and that should return you to the registry editor.

 

Checking Permissions :

 

1. Click on Start and select Run

2. At the Run box type "regedit", (do not include quotes) and click OK.

3. Now you are in the Registry Editor

4. Click on the + sign beside HKEY_Current_User

5. Click on the + sign beside Software

6. Locate the Roxio folder

7. Right click on the Roxio folder and select Permissions

8. From the Permissions for Roxio box click on the Advanced button on the bottom.

9. In the Advanced Settings box, remove the checkmark beside "Inherit from parent the permission entries that apply to child objects. Include these with entries explicitly defined here." Once you uncheck this you will get a Security box, click on Copy.

10. Click Ok.

11. Back at the Permissions for Roxio box ensure that you have the following Group or user names listed: Administrator (xxxxx\Administrators), your user name(xxxxx\Administrator(s)) & SYSTEM.

12. Click on each item listed in the box and ensure they have Full Control and Read rights. If these are missing from any of the items listed, please click on Full Control.

13. Once you have verified that the users have full control, click on the Advanced button one more time.

14. Click on the checkbox beside "Replace permission entries on all child objects with entries shown here that apply to child objects.

15. Click Apply and Ok. This may take a moment as it may need to replace permissions.

16. Click on the + sign beside HKEY_Local_Machine

14. Click on the + sign beside Software.

Please perform the exact steps listed above for HKEY_Current_User.

15. Once you have completed all the steps above, restart your computer.

 

Regards

Roxio Technical Support

Link to comment
Share on other sites

I can't follow this. I'm using Windows XP Home SP2 on a new Dell machine and logged into an account I created which has administrator privs. I am not using the standard logging prompt, just the icon login but with passwords. Basically you state a bunch of stuff in the long version and then at the end you say you "corrected the access rights". Can you explain what that means? I don't see the full path like you said. There is nothing after Software\Sonic\ like "Registration" which I think is what you were saying in most of the paragraphs. Do I need to log on to the Administrator account like you said? Dell doesn't tell you what the Administrator account is. Perhaps I can create a user with that name and set the password for the first time myself?

 

Matt

Matt,

Sorry I've been so unclear.

I also own a Dell (Precision 470) and I believe I experienced the same frustration you are experiencing now. It has nothing to do with Dell, that's my belief.

I need to assume that you are using a computer with English XP. In my case it is Spanish so I'll translate into English (please have this in mind,my translation might not match exactly what you read in your computer).

 

I am not writing the whole thing again, just the doubts you describe in your post.

 

In my case the only way to solve the proble was log-into my computer with the administrator user, yes you need the administrator password.

 

The first time you boot the computer you are asked for the information that configures and activates the XP OS.

There is a point, during that process, you are asked for the administrator account password. Then you are given the possibility of creating new accounts (up to 5 as far as I remember).

 

If you don't remember what password was provided for the administrator in that step, you can still recover the admin password, provided that you have a user with admin rights (but you do, because you state that in your post).

 

In order to change the administrator password you need to right click in MyComputer and select the Manage entry from the popup menu.

That will bring you the computer management window. Navigate the left tree view to the users branch. That will provide you, in the right view, with the list of users of your computer. Among them you should find the administrator. If you right click in the administrator name you will open a popup menu that will give you the chance to change the administrator password (without knowing the old one).

 

Now that you know the administrator password, you need to login as the administrator. You will not find an Administrator icon to open the session. How to do it?. When you are presented with the icons of the different users you have enabled in your computer press Control-Alt-Del. (In my computer I have to press them twice, don't ask me why). You will then be presented with a window that allows you to enter user (administrator) and password (the one you now know).

 

 

Now second part of your doubts. The "corrected access rights" thing in fact means corrected registry permissions, this was explained by HimanshuatRox in the third post of the thread, but I am copying it for you below with the Roxio versus Sonic correction:

 

Backup the Registry :

 

- Click the START button and select RUN from the menu.

- Type "regedit" and press ENTER

- First, we need to make a backup of your registry. Click on FILE in the upper left hand corner, and choose EXPORT.

- Name the file BACKUP, and choose to save it on your desktop.

- Before clicking on SAVE, make sure that ALL is selected under EXPORT RANGE (located at the bottom of the screen).

- Click SAVE, and that should return you to the registry editor.

 

Checking Permissions :

 

1. Click on Start and select Run

2. At the Run box type "regedit", (do not include quotes) and click OK.

3. Now you are in the Registry Editor

4. Click on the + sign beside HKEY_Current_User

5. Click on the + sign beside Software

6. Locate the Sonic folder

7. Right click on the Sonic folder and select Permissions

8. From the Permissions for Sonic box click on the Advanced button on the bottom.

9. In the Advanced Settings box, remove the checkmark beside "Inherit from parent the permission entries that apply to child objects. Include these with entries explicitly defined here." Once you uncheck this you will get a Security box, click on Copy.

10. Click Ok.

11. Back at the Permissions for Sonic box ensure that you have the following Group or user names listed: Administrator (xxxxx\Administrators), your user name(xxxxx\Administrator(s)) & SYSTEM.

12. Click on each item listed in the box and ensure they have Full Control and Read rights. If these are missing from any of the items listed, please click on Full Control.

13. Once you have verified that the users have full control, click on the Advanced button one more time.

14. Click on the checkbox beside "Replace permission entries on all child objects with entries shown here that apply to child objects.

15. Click Apply and Ok. This may take a moment as it may need to replace permissions.

16. Click on the + sign beside HKEY_Local_Machine

14. Click on the + sign beside Software.

Please perform the exact steps listed above for HKEY_Current_User.

15. Once you have completed all the steps above, restart your computer.

 

Hope this helps.

Quique

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...