Jump to content
  • Who's Online   0 Members, 0 Anonymous, 10 Guests (See full list)

    • There are no registered users currently online
  • 0

Ttg Stopped Working - Possible Jdk 6 Update?


xneog37

Question

So my TTG stopped seeing my DVR and all programs already downloaded to the local computer. Been working fine for months.

 

When I try running the program directly from the terminal I get this error:

 

/Applications/Toast 8 Titanium/Tivo Transfer.app/Contents/MacOS 12% ./TiVo\ Transfer

_NSJVMLoadLibrary: NSAddLibrary failed for /System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Libraries/libjvm.dylib

-[NSJavaVirtualMachine initWithClassPath:] cannot load Java virtual machine library

SetUserPrefs: Error trying to write preferences file!2008-05-08 23:25:51.851 TiVo Transfer[72900:807] Can't find debugging class!

2008-05-08 23:25:52.127 TiVo Transfer[72900:807] *** NSThread: ignoring exception '*** -[NSCFArray removeObjectAtIndex:]: index (0) beyond bounds (0)' that raised during thread perform of target 0x1504d0 and selector 'updateProviders:'

^C

I'm using the latest java from Apple (1.6):

 

/Applications/Toast 8 Titanium/Tivo Transfer.app/Contents/MacOS 13% java -version

java version "1.6.0_05"

Java SE Runtime Environment (build 1.6.0_05-b13-120)

Java HotSpot 64-Bit Server VM (build 1.6.0_05-b13-52, mixed mode)

Anybody else install the java 6 update from Apple having this issue?

I've tried submitting a ticket with Roxio but so far I've just got the level 1 support "try this list of things" -- which I did and none worked. So I thought I'd try the forums to see if I was alone in this issue.

 

I also checked the Tivo and it looks like there might have been a softwre update, but I'm not sure. I can't remember the last version. It's a tivo series 3.

 

Thanks much,

Steve

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

Same problem here. But solved it by switching back to runtime 1.5. All is well again.

 

java version "1.5.0_13"

Java 2 Runtime Environment, Standard Edition (build 1.5.0_13-b05-237)

Java HotSpot Client VM (build 1.5.0_13-119, mixed mode, sharing)

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...