Jump to content
  • 0

Setting Reencoding To Never Doesn't Always Work


daehl

Question

I'm trying to create a compilation DVD using individual VOB files. Each VOB has an hour's worth of normal MPEG-2 encoded 16x9 video with Dolby Digital 5.1 audio. The VOBs are approximately 1.4GB each. So I want to add 3 to each DVD disc (to fit 4.2GB on a single-layer DVD)

I'm doing it this way because I want menus with chapter stops included.

 

Also, I've set Toast 9's "reencoding" setting to "Never". I figure that way Toast 9 should just build the menus, include the chapter stops, and then basically just use the VOBs as is without re encoding them. But it's not working consistantly.

 

I've made two such discs so far, and the first will not complete if I try to save it "as a disc image" when the target size is a single-layer "DVD". It goes through the motions of building the disc image, but then after an hour or so just finishes without actually creating a disc image. If I instead choose a double-layer "DVD DL" target, it does create a disc image, but it ends up being about 8GB. But that doesn't seem right at all since reencoding was definitely set to "Never", but the VOBs must have been re-encoded to doubled in size like that.

 

However, I tried another set of 3 (similar but different) VOBs, and that time it works just fine. It created a disc image that fit on a single-layer DVD and included the menus and chapter stops with no apparent re-encoding.

 

So I can't figure out the discrepancy here. The settings were identical yet I get different results. And I'm wondering whether there are some circumstances where Toast 9 overrides the "never" setting for reencoding, and how to avoid that. Maybe based on whether there's a conflict between the "Average Bit Rate" setting and what's encoded in the source VOBs? I left that setting at it's default of 5Mbps (which I would expect would be ignored when reencoding is set to "never"). But even still, that shouldn't be a problem because my VOBs must all be about 3-4 average Mbps based on their sizes.

 

So I'm a bit stumped. Any ideas?

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

Toast rarely works with VOBs dragged directly into the Video window. It is best to use MPEG Streamclip to convert the VOBs to MPEG and add the MPEG files. If your VOBs are in a VIDEO_TS folder you don't need Streamclip. Instead, place the VIDEO_TS folder on the desktop and choose DVD with the top button of the Toast Media Browser. You should be able to figure out how to get to either the title or chapter level of the VIDEO_TS and drag what you want to the Video window. Toast then extracts the MPEG 2 files from the VOB sets.

 

Another possibility is numerous timecode breaks present in the source video. This requires opening in MPEG Streamclip and choosing Fix Timecode breaks. One problem with this is I believe it also will remove any existing chapter markers.

 

Toast does re-encode even when set to Never when it finds the source files to be out of spec with the video DVD standard. Too high a bit rate or an out-of-spec resolution are possibilities. If Toast encounters dropped frames it may re-encode (if it doesn't crash).

 

 

 

 

 

Link to comment
Share on other sites

Toast rarely works with VOBs dragged directly into the Video window.

 

Thanks for the advice & info tsantee,

 

I'll add a bit more explanation: all of my VOBs are home-made using ffmpegX (using the exact same settings) and are in their own VIDEO_TS folders. And they have no menus or encoded timecode breaks

 

Toast 9's "VIDEO_TS Compilation" option works great in every attempt, but that doesn't add menus or chapters. Therefore, the end result isn't very usable.

 

So I'm just looking for a quick way to compile these onto a single DVD with a basic menu and chapters added.. The 2nd disc that I got to work is just what I wanted. And the first was basically more of the same so I was surprised when it didn't end up the same.

 

I'll try using toast's media browser next and then mpeg streamclip if the former doesn't work.

 

Thanks again for the advice!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...