Jump to content
  • Who's Online   0 Members, 0 Anonymous, 5 Guests (See full list)

    • There are no registered users currently online
  • 0

Update Easy Media Creator 8


carmanhere

Question

I just reinstalled my Roxio Media 8. After I did so, I checked for any updates. It gave me one. I downloaded and installed it and then rebooted. Since I just did a reformat and reinstalled from my CD I wanted to make sure that I had any and all updates. After rebooting my PC and starting my Media Creator, I then checked for any updates again, it said that I had 1. It choose to download and install this one to get me up to date. I did the same thing, download,instal and rebooted. Checked again for updates. It is giving me the same update each time that I check for updates. It says that after I installed the updates, that it was installed successfully. But now each time I check for any additional updates, it is giving me the same file. Suggestions?

Thanks

Link to comment
Share on other sites

12 answers to this question

Recommended Posts

Check to see what version you have. From the Start/Programs menu go to Roxio 8 and choose any program and go to it's Help menu then About. Look for the Build version. What does it say?

It's says that I am using version 8 and not it looks like the update 8.5 has not been installed. Suggestions? Thanks for your reply.

Link to comment
Share on other sites

It's says that I am using version 8 and not it looks like the update 8.5 has not been installed. Suggestions? Thanks for your reply.

Yes but what version of 8? Please list the complete version number. And, the update is for 8.05. There is no 8.5.

Link to comment
Share on other sites

I had the same issue. If you go to Add/Remove Programs in Control Panel, then make sure the box at the top of the menu for showing all updates is checkec, then scroll down to Roxio Easy Media Creator 8 Suite, then click on "Click here for support information", you will get a pop-up window that shows Version 8.0.530 which indicates a successful download and upgrade of Version 8.0.530.

Link to comment
Share on other sites

I had the same problem and the only thing I can track it down to is doing a custom install with certain things not installed. I previously did custom installs and did the updates. Nothing was showing as being updated, even though the update stated it was successful. The only single item I found that was successfully updated was BUMP, which no longer gave me the BETA warning. Creator Classic and other base items still showed the original version, I believe 800B85C.

I tried an experiment just to see if it was someing that doesn't get installed with my particular custom install.

Here are the steps I followed on the reinstall (and when I did the custom install)

 

1. Uninstall all of Roxio content.

2. Uninstall the all the rest of Roxio

3. Reboot

4. Run Roxizap

5. Reboot

6. Verify everything gone with Windows cleanup utility

7. Install main programs with custom install, leaving off ONLY Drag and Drop

8. Reboot

9. Install Content

10. Install downloaded update

11. Reboot

12. Verify that CC and other module had the new version, they did this time.

13. Uninstall those items I did not want or need

14. Reboot

15. Verify that the items left installed still have the new verion. They did.

 

I don't believe this is a coincidence, as I had installed multiple time before and still had the version problem.

 

Those items that I did not install in the original installs and removed after install this last time are:

 

Drag and Drop

Photosuite

Videowave

MyDVD

Media Import

Media Manager

Digital Home

Sound Editor

Roxio Backup

Disk Image Loader

Eay Audio Capture

 

That is a lot of the suite, but I either do not need these items or I already software I am used to.

 

I was not about to try each item seperately to find which was cauing the problem as I had spent enough time getting this to work. I also hope in future updates, I don't have to go thru the same procedure.

 

Hope this helps. Marlin

 

Addendum - I should have mentioned that on the earlier installs, it would always say there was and update to apply, even though the update had been applied, and after this last install, when I checked to see if there were any updates, it said no.

Link to comment
Share on other sites

Here is everything that is there. Is this it. I went to copy disc>about. Thanks

 

 

 

Module Name: Roxio Creator 8 Suite Home

Version: 3.0.0

Build: 3.0.86B

Serial Number: NN-9KQBT-KH07S-60S3D

Copyright: Sonic Solutions 2005

 

Module Name: PX Engine

Build: 2.7.17a, 63

Copyright: Sonic Solutions 2005

 

 

 

 

 

Module Name: Roxio RecordNow Audio

Version: 3.0.0

Build: 300B66A, R8S

Copyright: Sonic Solutions 2005

 

Module Name: Roxio RecordNow Copy

Version: 3.0.0

Build: 300B54A, R8S

Copyright: Sonic Solutions 2005

 

Module Name: Roxio RecordNow Data

Version: 3.0.0

Build: 300B49A, R8S

Copyright: Sonic Solutions 2005

 

Module Name: Roxio RecordNow Tools

Version: 3.0.0

Build: 300B38A, R8S

Copyright: Sonic Solutions 2005

Link to comment
Share on other sites

You can't do this from the Home screen (easy anyway) and must use the XP Start button.

Start/All Programs/Roxio Easy Media Creator 8/Copy/Disc Copier. Then click on Help/About Disc Copier. However, based on what I see, I don't think the update did install.

Link to comment
Share on other sites

Hi Paul.

I just went to Roxio home page and downloaded and installed, or at least tried to install the updat again but again , it did not work. Sugg?

Thanks for your help

I don't know what is preventing you from installing the update unless you have the wrong update. Run a defrag on your system to make sure the drive is tidied up and reboot. Then, disconnect from the net, turn off any virus software and firewall software and shutdown all un-needed programs and try again. Maybe if this doesn't work, you can try installing in safe mode. I'm still trying to figure out why this is happening.

Link to comment
Share on other sites

Hi Paul.

I just went to Roxio home page and downloaded and installed, or at least tried to install the updat again but again , it did not work. Sugg?

Thanks for your help

 

You already have the latest version. But, you could do a check, to be sure. Do this:

 

1. Click on the Roxio Home icon on your desktop.

2. At the top, you will see Home. Right below that is Applications. Click on Applications.

3. On the next screen, click on Creator Classic.

4. Once it opens, click on Help, then click on About.

5. Post here what the build number is.

Link to comment
Share on other sites

I just reinstalled my Roxio Media 8. After I did so, I checked for any updates. It gave me one. I downloaded and installed it and then rebooted. Since I just did a reformat and reinstalled from my CD I wanted to make sure that I had any and all updates. After rebooting my PC and starting my Media Creator, I then checked for any updates again, it said that I had 1. It choose to download and install this one to get me up to date. I did the same thing, download,instal and rebooted. Checked again for updates. It is giving me the same update each time that I check for updates. It says that after I installed the updates, that it was installed successfully. But now each time I check for any additional updates, it is giving me the same file. Suggestions?

Thanks

Check to see what version you have. From the Start/Programs menu go to Roxio 8 and choose any program and go to it's Help menu then About. Look for the Build version. What does it say?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...