Jump to content
  • Who's Online   0 Members, 0 Anonymous, 6 Guests (See full list)

    • There are no registered users currently online
  • 0

Update Won't Work


mariahorn

Question

Ok, I miraculously found my CD key (note to self: wear glasses when looking for tiny pieces of paper).

 

I was able to install 7.5 on my new computer, came here to download the update (which I did not have on my previous computer), and it seems like a merry-go-round.

 

I click on Update Center, click the "EMC 7.5," click "Download," then click "Download Patch," and it takes me back two pages to the page that lists all the updates again. I tried this several times. I experimented with clicking on the 7.0 update and that did nothing. Any other ideas?

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

Ok, I miraculously found my CD key (note to self: wear glasses when looking for tiny pieces of paper).

 

I was able to install 7.5 on my new computer, came here to download the update (which I did not have on my previous computer), and it seems like a merry-go-round.

 

I click on Update Center, click the "EMC 7.5," click "Download," then click "Download Patch," and it takes me back two pages to the page that lists all the updates again. I tried this several times. I experimented with clicking on the 7.0 update and that did nothing. Any other ideas?

I don't have the notes but as I recall, the update adds LightScribe support and some portions of the Help files.

 

Is that something you really need?

Link to comment
Share on other sites

I don't have the notes but as I recall, the update adds LightScribe support and some portions of the Help files.

 

Is that something you really need?

 

No. I was hoping maybe the update would help with the stability of everything, but I haven't tried using Videowave on my new computer yet, so maybe it won't be an issue in the first place.

Link to comment
Share on other sites

Ok, I miraculously found my CD key (note to self: wear glasses when looking for tiny pieces of paper).

 

I was able to install 7.5 on my new computer, came here to download the update (which I did not have on my previous computer), and it seems like a merry-go-round.

 

I click on Update Center, click the "EMC 7.5," click "Download," then click "Download Patch," and it takes me back two pages to the page that lists all the updates again. I tried this several times. I experimented with clicking on the 7.0 update and that did nothing. Any other ideas?

 

Hopefully, you have the Retail (boxed) version of EMC 7.5. Try downloading the update from the main Roxio webpage.

 

To get out of the loop that you get, when you are trying to download, disable your pop up blocker software, your antivirus software, and Internet security software. Once you get the patch downloaded, put it all back up again.

Link to comment
Share on other sites

This is a common problem that Roxio has with trying to download updates. For some reason it gets you in this loop you are describing. It was the same problem in version 7. Some time ago I called and got a Roxio rep on the phone and he suggested the following:

Go to START--RUN--and enter MSCONFIG. On the next screen, change the "Normal Startup" button to "Selective Startup". Then remove all of the check marks in the top 4 boxes--click on apply and then O.K.

 

Also, as others have suggested, stop all of your security programming and then re-boot the computer. Now go to the Roxio update for your EMC program and go through the same steps as you did before. This time when you click on Download, it should work O.K.. The file size for the version 7.0 was over 100Mb, so it might take a while to down load the update depending on your computer and your connection to the internet.

 

After making the update, go back now and be sure to change the Startup to "NORMAL" and re-start all your security programs for sure. :)

 

Hope this helps

Redwagon

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...