Jump to content
  • 0
Cambion7

Right-click Explorer Context Menu For Mount Image?

Question

I installed Roxio 2009 this last week and noticed something odd. I make ISO files prior to burning so I can test them, and in the past I've always used Roxio to load the images by right-clicking on the ISO file and using the Mount ISO menu item.

 

I don't have such a menu. I'm running Vista Ultimate and have 'RoxioCentralFX.exe' set to be 'Run as Administrator'.

 

How would one go about repairing/installing these context menus? Thanks in advance.

 

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

You need to 'create' an emulated drive first

 

Go to the Home app and under tools you will find 'Load Disc Image' - click that and it will tell you there are no emulated drives and do you wish to create one

 

Let it make the drive and then it should come under the right click options

Share this post


Link to post
Share on other sites
  • 0

Thanks to all for the replies. I had created a virtual drive, but the context menu was not there. I was able to add the ISO's to the 'Disc Image List' then load the images that way.

 

What I did was a complete uninstall of Roxio products, as I had Roxio 10 and installed Roxio 2009 over that. I had to even go so far as to use Windows Install Cleanup to remove anything Sonic/Roxio, then ran the setup as administrator for 2009.

 

I now have a context menu that works. It simply says LOAD then off that are the various virtual drive letters. But now another question; does the virtual drive allow for loading of the .GI files created when saving audio discs to image? I can't seem to get them to load.

 

Again, I appreciate the responses! A good team here in the forums. :D

 

 

Share this post


Link to post
Share on other sites
  • 0

Roxio's disc image loader does not support .gi files.

 

Open disc image loader, help menu, disc image loader help center, under getting started click supported file types. it lists the file types.

Share this post


Link to post
Share on other sites
  • 0

Good call, and thanks for the post. :)

 

Roxio's disc image loader does not support .gi files.

 

Open disc image loader, help menu, disc image loader help center, under getting started click supported file types. it lists the file types.

 

Share this post


Link to post
Share on other sites
  • 0

If you were using copy disc to image from Roxio's home app, that only allows .gi or .iso formats. Unfortunately for Audio CDs, you can't use .iso, and as you've found out, disc image loader won't load .gi (I pointed this out during beta testing of version 10, but no one listens to me :-),

 

The work around is to use Music Disc Creator to make c2d or cue images.

 

Open music disc creator, click import fom CD/DVD. Select all the tracks, click add; It will ask where to save the files (which you can subsequently delete if you don't want them), select suitable folder. When the tracks have been impported, edit track info, project settings etc. as required, click burn, select image, save as....c2d (or .cue, but I use c2d).

Those you will be able to load with image loader and play in e.g. WMP.

 

You will also be able to use burn image to disc from the home app, as that supports iso, gi, c2d, cue and udi

Edited by jeanrosenfeld

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×