Jump to content
  • Who's Online   0 Members, 0 Anonymous, 8 Guests (See full list)

    • There are no registered users currently online

How To Change File Permission When I Burn My Dvd


stephen65
 Share

Recommended Posts

I am using Easy CD Creator 5.3.5.10.

 

I am trying to create a DVD with installation programs. Those programs are going to run on a Linux box. However, after I created the DVD, the permission of the files are set to :

 

dr-xr-xr-x 4 4294967295 4294967295 220 Jul 27 2007 AIX

dr-xr-xr-x 2 4294967295 4294967295 92 Jul 27 2007 Config

-r--r--r-- 1 4294967295 4294967295 4876 Jul 31 2002 FreeSpace.pm

dr-xr-xr-x 4 4294967295 4294967295 220 Jul 27 2007 HP-UX

-r--r--r-- 1 4294967295 4294967295 913474 Jul 13 2007 install.exe

-r--r--r-- 1 4294967295 4294967295 43 May 17 2002 install.ini

-r--r--r-- 1 4294967295 4294967295 70 Jun 26 2002 install.ksh

-r--r--r-- 1 4294967295 4294967295 69279 Jul 13 2007 install.pl

-r--r--r-- 1 4294967295 4294967295 14040 Jul 13 2007 license

dr-xr-xr-x 4 4294967295 4294967295 220 Jul 27 2007 Linux

-r--r--r-- 1 4294967295 4294967295 27078 Jul 27 2007 mfgpro.ini

dr-xr-xr-x 4 4294967295 4294967295 220 Jul 27 2007 OSF1

-r--r--r-- 1 4294967295 4294967295 23004 Aug 2 2005 QADTools.pm

dr-xr-xr-x 4 4294967295 4294967295 220 Jul 27 2007 SunOS

dr-xr-xr-x 2 4294967295 4294967295 88 Jul 27 2007 win32

 

The permission of file install.ksh is r--r--r--. Which fails to execute, should be r-xr-xr-x. All script files on the DVD are having the same problem. I was using Nero before, I don't have this issue when I burn the DVD using Nero. Any idea?

 

Many Thanks... Stephen

 

 

 

Link to comment
Share on other sites

There's something amiss there in your permissions and the files

 

d is 'directory' and shouldn't have an 'x' permission and *nix doesn't run .exe files - those are DOS/Windows

 

shell scripts are r by default - you run that under BASH which just reads and exectutes the lines - thwe script doesn't execute per se - BASH does that

Link to comment
Share on other sites

There's something amiss there in your permissions and the files

 

d is 'directory' and shouldn't have an 'x' permission and *nix doesn't run .exe files - those are DOS/Windows

 

shell scripts are r by default - you run that under BASH which just reads and exectutes the lines - thwe script doesn't execute per se - BASH does that

 

Thanks for your reply.

 

Don't worry about the .exe files, because this DVD is for both Unix/Linux and Window. So some files are O/S specific, the Unix/Linux script will not call the .exe files.

 

I tested with bash, result is the same. Just wonder is there any option I can use to change the file permission when I burn the DVD.

 

-r--r--r-- 1 4294967295 4294967295 70 Jun 26 2002 install.ksh

 

The above permission will not allow me to run the install.ksh. Is there any way I can change the permission to

 

-r-xr-xr-x 1 4294967295 4294967295 70 Jun 26 2002 install.ksh

 

when I burn the DVD ? (The DVD contains a lot of scripts, all should have the above permission in order to run...)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...