Jump to content
  • 0

Drive Not Detected


buffyhoneybabes
 Share

Question

Hi

 

I am having a problem with my roxio application. Probably best to start at the beginning. I have a Dell Inspiron 9400 laptop.

 

Windows vista lost my dvd drive and I went onto the Dell forum and found the fix - by deleting the upper and lower filters registry files in the regedit.

 

This fixed the problem within windows as the DVD is now showing in My computer but when I try to copy a cd or dvd using roxio emc v9 all I get is that there is no drive detected. I spent last night looking through the forums and cannot find a fix to my problem. Everything I have found has told me to do exactly what I have already done by deleting the upper and lower filters.

 

Can someone please help me? Is there a fix or do I just reinstall Roxio onto my computer?

 

Thanks in advance any suggestions would be much appreciated.

 

Susan

Link to comment
Share on other sites

11 answers to this question

Recommended Posts

  • 0
Can someone please help me? Is there a fix or do I just reinstall Roxio onto my computer?

 

Hi Susan,

 

The Sonic/Roxio software installs a filter in the registry, so if you've deleted the upper and lower filters you would have deleted Roxio's entry too. You do need to reinstall the software after you've deleted filter registry keys - that should reinstall the filter Roxio needs there.

 

Regards,

Brendon

Link to comment
Share on other sites

  • 0
Clear one thing up – V9 was last made in 2007. The current version is confusingly called Creator 2009.

 

Which one do you have?

 

The fix for either is the same, try running the PxEngine – Here

 

Reboot.

 

If that doesn't help, then do the Clean Install.

 

 

Thanks will try this tonight and get back to you.

 

Hi Susan,

 

The Sonic/Roxio software installs a filter in the registry, so if you've deleted the upper and lower filters you would have deleted Roxio's entry too. You do need to reinstall the software after you've deleted filter registry keys - that should reinstall the filter Roxio needs there.

 

Regards,

Brendon

 

 

Thanks for this I am going to try both these fixes and hopefully one will work.

 

Susan

Link to comment
Share on other sites

  • 0
You still haven't answered the question as to which software version you have. EMC 9 is not the same as Creator 2009.

 

 

Sorry for not getting back to you sooner I have (according to the about this software tab) roxio creator de v 9.0.116

 

Does this help - also when I log in to roxio it does say easy media creator 9

 

Susan

Link to comment
Share on other sites

  • 0

Hi everyone its me again - finally got a replacement installation disc from Dell (they were very helpful) - uninstalled roxio and all sonic files as per the uninstall instructions posted on this site and then reinstalled Roxio EMC 9. It still will not recognise the dvd drive. Windows is recognising it - the device manager says the device is working properly - have tried to uninstall device and reinstall it but still Roxio won't pick up the drive. Is there anything else I can do - my husband thinks that the drive is knackered and is about to pay out to take it in to be fixed - but I can't convince him that if it plays normal dvd's then it must be working. Who is right here??????

 

 

Please can someone help me.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...