Jump to content
  • Who's Online   0 Members, 0 Anonymous, 21 Guests (See full list)

    • There are no registered users currently online
  • 0

Creator 2009 Freezes (fixed And Solution Provided)


MGJ
 Share

Question

Hi all,

I hope this may help some of you that are experiencing a Creator crash or your PC freezes up when trying to run an application from creator's user interface.

I work in primary schools as an IT support technician and come across these problems with software on a regular basis so I thought I would give you my resolution to the problem.

 

I purchased Roxio Creator 2009 because of the good write up from a magazine and also because I had Sonic installed as part of my PC build and I wanted a burning program that was more capable.

 

I purchased online and download the full application - No Problems.

I created a system restore point (Win XP Home).

Installed Creator 2009 which also installed as part of its own requirements MS Dot Net Framework 3.5 and Direct x9 and encountered no problems.

Re-booted as required after installation.

On starting Creator 2009 the great looking User Interface loaded up, but when choosing one of the applications from the user interface the software would freeze and lock up my PC.

The only way to exit the software was to ctrl+alt+del and user task manager and quit the following process RoxioCentralFx.exe (running CPU at 100%) and the user interface would quit and free up windows for normal use.

The applications worked fine provided that you did not try to load from Creator's user interface.

I suffered with this for a couple of days and decided to contact Roxio Technical Support with my problem.

Roxio's reply was to alter my startup configuration by using msconfig so that Creator had as much access to the system as possible.

Needless to say msconfig and startup apps were not my problem.

I gave up on Roxio's Tech Support and trouble shooted the software the same way I do any other.

I removed and re-installed Creator 2009 and still had the same problem.

I then checked what other software was installed on my PC.

I noticed and I had installed Dot Net 3.5 SP1 previously to purchasing Creator 2009 so I removed it but I still had the same problem after a reboot.

I then removed Dot Net 3.5 and re-booted and the Roxio would not load at all.

I re-installed Creator 2009 from my download which subsequently installed Dot Net 3.5 ( I ignored the request from DN3.5 to download the upadates) and let Creator 2009 finish the installation.

Re-booted and all works fine now, I will not be installing Dot Net 3.5 SP1 as an update until a patch is supplied by Roxio to support Dot Net 3.5 SP1.

I hope Roxio see this post and looks at the conflict that I have had with Dot Net 3.5 SP1 already being installed and then Creator 2009 installing Dot Net 3.5 over the top which it seems to be cause of why the User Interface locks up the PC when it is used.

 

I didn’t use System Restore or Re-install Windows as part of the problem and troubleshooting process as good software shouldn’t need you to do this unless Windows is faulty.

 

Hope this Helps out there.

 

MGJ :D

 

 

 

Edited to remove confusion with EMC 9

Edited by Brendon
Link to comment
Share on other sites

1 answer to this question

Recommended Posts

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...