Jump to content
  • Who's Online   0 Members, 0 Anonymous, 11 Guests (See full list)

    • There are no registered users currently online

No Supported DVD recorder


Recommended Posts

[Rosszie' date=Nov 2008, 01:10 PM]


Hello, Brandon. It appears that you are doing all the work that Roxio should do. I have almost identical problems with the ones you solved here. I recently added a new hard drive and a different second CDRW/DVD drive to my Win2K system. This resulted in some CD device renaming (because of the additional hard drive). My problem is twofold:


1) during opening ECDC 5, the error message "Engine Initialization has failed" was displayed. This was annoying but when I continued, it appeared to cause no problems. I could create and populate a new project. But eventually I run into problem 2 (below). First I hunted down the Roxio solution for this issue, (ID Number: EEZ000005), and cleared the registry (from LowFilter, HighFilter keys) as instructed. Have to give credit where it's due, it worked. No more "engine initialization" error. But still when trying to Record a project, Roxio responded with a "There are no supported recorders available." error.


2) I read your previous messages, and this is my scenario.


PLEXTOR CD-R PX-W1210A (The original drive)

TSSTcorp CDW/DVD TS-H492A (The recently added drive)


The Registry entries for these devices are:


device001 GENERIC FREECOM48H,GENERIC,FREECOM48H,SAMSUNG48X24,cdrmmc.drv,171,,9

device002 GENERIC FREECOM52H,GENERIC,FREECOM52H,SAMSUNG52X24,cdrmmc.drv,171,,9

device002 PLEXTOR CD-R PX-W4012S,PLEXTOR,CD-R PX-W4012S,STDMMCDDWS,cdrmmc.drv,155,,5,1,,1


I do not know why is the TSST listed twice with apparently only different speeds (48 vs 52), and the PLEXTOR only once.


The PLEXTOR did write using ECDC5 in the past but will not be detected as a recorder now. The TSST wrote just fine in a different computer. This machine is a Win2K OS so I can only try to use InCD from ECDC5, and that also fails in similar fashion: not detecting any drives to use.


I did everything I could think of.

1) after futile attempts to fix the current installation, uninstalled ECDC5 completely, even using the "roxizap.exe" that you were kind enough to supply. It is telling that Roxio is removing this (and other utilities as well) from their website, claiming that the users can't be trusted with it. I am sure the feeling is mutual from the users. I don't think that they trust their own tools!


2) I have a) reinstalled my original ECDC 5.0.xxx, B) updated it to the latest (and likely the last) update fixes ecdc_v5.3.5.10_plt_enu.exe, c) rerun the latest drive detect overlay driveup5.3.5v.exe. And ended up exactly where I have started from: "There are no supported recorders available."


It is inexcusable that for all these years Roxio still could not provide a WORKING solution for this age old drive detect issue. Is there any reason I should trust their newer version and buy it? I have a full version of Roxio Creator 9.0 but I am not brave (or fool) enough to install it on any of my systems. I would appreciate if you'd have some ideas and/or possible solutions for using these drives for recording using ECDC5.




Link to comment
Share on other sites

On a couple of points you raise


ECD5 is a full six versions behind the current version and support for that was dropped many years ago - basically the program is classed as 'obsolete' (there have been a lot of major developments since it came out, including the almost mandatory use of DVD-RW drives in place of CD-RW).


We will, as users, try to help get round some problems but as hardware changes there is a limit to what any of us can do


Windows 2K is NOT supported past version 9.0 (9.1, 10 and Creator 2009 will not work on it)


Later versions of the Roxio programs use the drive firmware instead of a database to report via the OS what is installed, what media is used and the designated maximum burn state. The use of a 'built-in' database is not recommended any more due, in part, to the huge number of drive variations around - far better to let the drive work via the OS than to include a huge database file (which would be out of date in a matter of months, if not weeks).


It's not so much an 'age old drive problem' but an age-old application problem - after all, ECD5 is at the very least 6 - 7 years old and this is a world where even hardware is obsolescent inside 1 - 2 years

Link to comment
Share on other sites



Both your drives should be recognized by a properly installed and updated version without any need for edits.

- The PX-W1210A was first supported in version 4.02d, and has been supported in Easy CD Creator ever since.

- The TS-H492A was first supported by version 5.3.5r [the R DriveUp] and has been supported up to and through 5.3.5v


Recognition of the PX-W1210A is now covered in the version 535 CDEngine.Dll, but the TS-H492A is covered by a registry entry. Open your registry to HKEY_LOCAL_MACHINE\Software\Adaptec\Adaptec Shared\CDEngine\Devices1 and go to device068. [Note that's the Devices1 key off CDEngine, and not the Devices key where you first looked.]


The three drive entries you quoted are recognition entries for three of the 3283 or so drives that 5.3.5v recognizes, but not the ones for your drives. There are over 1,000 in the registry, but the rest are hard-coded into the software.


You should find this value in device068 in the Devices1 key.

TSSTcorp CDW/DVD TS-H492A,TSSTcorp,CDW/DVD TS-H492A,MTK4832_Liteon,cdrmmc.drv,155,,9

If it's not there, something is broken in your registry.


I can't see how adding the TSSTcorp drive should break recognition for both your drives, unless you have other writing software in there which is interfering with Easy CD Creator.

This machine is a Win2K OS so I can only try to use InCD from ECDC5, and that also fails in similar fashion: not detecting any drives to use.

InCD is a Nero packet-writer, so I hope you don't have that installed.


To summarize,

-A properly installed Easy CD Creator 5.3.5V should recognize both your drives, so there's no registry edit I can suggest to recognize them

-You can check the registry to see if the entry for the TS-H429A is present

-either the registry is broken or something is interfering with the recognition system - it might have something to do with the drive letter reassignment you mentioned, but I don't know enough about your old operating system to advise you on that.

-I would suggest uninstallation and removal of ALL burning software from your system, and then a thorough clean out with Roxizap, followed by a careful reinstallation and updating of Easy CD Creator 5. My 5.3.5v burns fine with both my modern drives in XP-SP2 without needing a registry edit for recognition, so it's a good working solution for me.





Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...