Jump to content
  • 0

Audio Passthrough Not Working


miketall

Question

In the Getting Started Guide (pg. 80) for Toast 7, it states:

When you choose PCM, any existing Dolby Digital audio files will be "passed through" without reconverting to PCM.

 

I am not getting this result. I have tested both DD2.0 and DD5.1 files in Toast 7. They both end up being re-encoded to "dvdpcm, 1536kbps, 48kHz, Stereo" audio. This doesn't make sense to me, and besides losing my DD5.1 audio track, the size of the final file blows beyond the prediction shown by Toast 7 and won't fit on to a typical DVD-R.

 

Here is my workflow:

I record from my EyeTV 500 device using EyeTV 2.1 software. All looks good here. I have an ATSC-HD video signal (either 720p or 1080i), and the audio is either DD5.1 or DD2.0, depending on the channel. I send this to Toast 7.02 using the handy little "Toast" button in EyeTV. I have also just dragged and dropped from EyeTV to Toast (same results). At this point, I have to force re-encoding on the video since it was originally in HD format. I choose PCM for the audio as it is indicated it will just be "passed through". Unfortunately, the audio IS re-encoded. Choosing the only other option for audio, Dolby Digital, doesn't seem like a good solution because not only is the encoded audio re-encoded, it is also forced to just stereo.

 

Any thought on how to keep my original audio in its DD5.1 or DD2.0 format with no re-encoding?

 

Thanks,

Mike Tall

Link to comment
Share on other sites

7 answers to this question

Recommended Posts

If you look in ~/Documents/Roxio Converted Items you should only see a video file being created while the encoding process is going on. Make sure you either check before quitting or change Toast's preferences regarding deletion of temporary files.

I've had one more interesting development with "Auto" encoding. It was something I thought might be happening, but wasn't able to observe it till now. Looking in the Roxio Converted Items folder listed above by "ffooky" helped a lot in determining this.

 

I had two files to encode on a single DVD. They were both ATSC-HD sources from EyeTV 500. Both video files were 720x1280 pixels. The audio on one was Dolby Digital 5.1, while the other was Dolby Digital 2.0. On my first test, I had the DD2.0 file first. That encoding went as expected and the audio was passed through untouched. However, when it came time to encode the DD5.1 file, it was downconverted to a Dolby Digital stereo file at 192kbps. Not only does this take more time for encoding, but I lose quality. So, it is a lose, lose situation - makes no sense.

 

On my second test run, I put the DD5.1 first. It automatically passed through the DD5.1 file just fine. When it came time to encode the second file (DD2.0), it was also passed through just fine.

 

After seeing this kind of thing several times in the past, my observation is this:

If you want to encode multiple files to a single DVD-Video disc, when you force encoding, all files will be encoded the same. If you use the auto encoding settings, then the first file encoded is the limiting factor on how the rest of the files are encoded. For example, if the first file is encoded in stereo, then the remaining files don't have hope of anything better than stereo either.

To me, it is essential to keep the highest quality possible, and that is why I'm hounding on this so much. For those that feel the same, keep an eye on the Roxio Converted Items folder during all your encodings. You might be surprised as to what is actually happening to you audio files.

 

If anyone has different or further observations on this, I'd love to see it added to the list. Thanks

-Mike

Link to comment
Share on other sites

Well, if you select PCM and you have Dolby Digital then the audio will be converted form Dolby to PCM. That is not the option you want to use.

 

Since you have Dolby already, just keep the audio settings as Dolby. Toast will passthrough the Dolby audio. It will not re-encode the audio, only the video.

 

Do you know for a fact that the Dolby 5.1 was converted to 2.0, or are you just assuming that will happen? If it does happen, then it's because there is a issue with the original Dolby files that requires re-encoding.

Link to comment
Share on other sites

Your 1st sentence seems to be saying the exact opposite of what the owner's manual states. It really does say that if you select PCM, then originally encoded Dolby Digital files will be passed through and NOT re-encoded. This is a special case for Dolby Digital format, and doesn't apply to any other audio formats. Though, I will give what you say a try. It wouldn't be the first time an Owner's Manual was wrong.

 

From my previous testing, the original Dolby Digital was re-encoded from 5.1 to 2.0 (stereo). Yes, I am sure on this one. I have a Home Theater installation company that specializes in audio & video calibrations. So besides just ffmpegX and MPlayer on my Mac showing me this format, I can also confirm it through my Home Theater demo system and my own hardware calibration equipment. Hope that is good enough :) Keep in mind this is going through the "PCM" setting. Let me try this again with the Dolby Digital setting and cross my figures on the re-encoding. My worry is that if it does get re-encoded, I will have no idea except to use my ear to hear for loss of quality. Hope that makes sense. In other words, it is possible to go from DD5.1 at 384kbps and re-encode it to DD5.1 at 384kpbs.

 

Thanks for the input, and I will get back to you as soon as I am able.

-Mike

Link to comment
Share on other sites

Actually it's easy to tell if you have 5.1 audio. Click the Edit button next to the title and read the description of the audio. For example one of my 5.1 sources says Dolby Digital 3/2/LFE 48000. After you burn your DVD you can import the video back to Toast and read if the audio type has changed.

Link to comment
Share on other sites

My worry is that if it does get re-encoded, I will have no idea except to use my ear to hear for loss of quality. Hope that makes sense. In other words, it is possible to go from DD5.1 at 384kbps and re-encode it to DD5.1 at 384kpbs.

 

If you look in ~/Documents/Roxio Converted Items you should only see a video file being created while the encoding process is going on. Make sure you either check before quitting or change Toast's preferences regarding deletion of temporary files.

Link to comment
Share on other sites

If you look in ~/Documents/Roxio Converted Items you should only see a video file being created while the encoding process is going on. Make sure you either check before quitting or change Toast's preferences regarding deletion of temporary files.

 

Thank you "ffooky". I ran about a dozen test cases, and having this folder displayed helped very much. It was very useful in determining if a Dolby Digital file was being re-encoded to the same format or actually passed through.

 

So, here are the results of my dozen test:

 

I ran 6 tests on a DD2.0 test file, and 6 tests on a DD5.1 test file. As expected results from both DD2.0 & DD5.1 files were the same. Results where not as expected from reading the User's Guide. Also, the biggest thing I noticed is what effect the "Video Reencoding" selection has on the Audio Reecoding. Makes no sense, but it sure happens.

TEST 1: ENCODING SET TO "AUTOMATIC". Worked great on the test file, but be careful with this as I have seen it change video aspect ratio, and do other oddities as you approach maximum disc capacity. Audio file passed through untouched.

 

TEST 2: ENCODING SET TO "CUSTOM", w/all DEFAULT and auto setting within custom view (default audio settings are Dolby Digital @192kbps). Worked great on test file, but be careful as I have also seen video aspect ratio issues on occassion. Audio file passed through untouched.

 

TEST 3: "CUSTOM" ENCODING, forced VIDEO REENCODING to ALWAYS, and Audio set to DolbyDigital-AUTOMATIC. Reencoded audio file to DD Stero at 192kbps. Does NOT pass through audio.

 

TEST 4: "CUSTOM" ENCODING, forced VIDEO REENCODING to ALWAYS, and Audio set to PCM. Reencoded audio file to PCM. Does NOT pass through audio.

 

TEST 5: "CUSTOM" Encoding, forced VIDEO REENCODING to "AUTO", and Audio set to PCM. Audio was passed through fine, and all worked great.

 

TEST 6: "CUSTOM" Encoding, forced Video Reencoding to "ALWAYS", and Audio set to Dolby Digital at the same rate as the source file. The audio was REENCODED. While the resulting audio was still in Dolby Digital format and of the same bandwidth, it WAS reencoded, AND coverted down to stereo if the source was DD5.1.

Here is my suggestion to the end user after running all these tests. I'd love to use the standard "Auto" everything setting in Toast 7, but I can't rely on it 100%. For the amount of time it takes to re-encode this stuff, it just isn't worth a risk.

 

So, with that in mind, I would suggest going to "CUSTOM ENCODING". Under the Custom Video options set "Reencoding" to automatic. With the Custom Audio options set to either DD-Automatic or PCM, the audio file was passed through.

 

I find one fault with my tests so far. I did not try auto video reencoding in conjunction with a specific Dolby Digital rate setting. Anyone who has time to try that, feel free. I think I'm pooped right now, and I was able to get the results I needed.

 

What I would suggest to Toast Tech Support (if they read this) is that they make the audio settings independent of what the video settings are. Forcing video reencoding should not force audio reencoding unless I tell it to. Make sense?

 

-Mike

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...