Jump to content
  • 0

Can't Run Once Installed



What a nightmare.


This is what I tried..


Installed Creator 2009. When I try to run the main application I get the Roxio logo and then nothing. Running just certain applications will yield "No permissions to launch application".


Running it under administrator.

Running Direct X10.

Installed newest Microsoft .net 3.5 SP1. (even uninstalled it and let Roxio install it)

Installed SP1 for Roxio Creator.


Uninstalled it and wife tried to run it on her computer. It won't launch either.

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

Follow this KB Article: KB Ref


Unless to many posts were trimmed from this thread, I see no mention of OP and this issue! :unsure:




During the installation of DirectX 9 portions of Creator 2009, the installation halts, rolls back, then gives an error that the install has been interrupted and cannot be completed.



Installed SP1 for Roxio Creator.



The Creator 2009 Service Pack 1 download includes the following updates and fixes:


Updated Roxio Central content

Resolves a Windows XP compatibility issue with .Net Framework

Resolves program crash issue when using keyboard arrow keys to select a drive

Miscellaneous Roxio Online service fixes



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...