Jump to content
  • 0

Disc capacity indicator strangeness


quarterwit

Question

I have a 600mb avi, and a 600mb mpg, both of the same duration--about an hour.

 

If I drag the 600mb avi to to the DVD-Video pane, it takes up most of the capacity, as expected.

 

If I drag the 600mb mpg, it takes up very little indeed.

 

That's the first weirdness. Why does that happen? I thought it was the duration of the footage that mattered.

 

Secondly:

 

If I drag the mpg to the pane, *then* that avi, the avi takes up as little as the mpg did!

 

So all I need to do is start with an mpg and I can fit 12 hours of footage on a DVD?

 

Looks like something's wrong there...

 

Toast 702, Mac OS X 10.4.3.

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

I'm guessing the MPEG file you are dragging over is in MPEG-2 format. If so, Toast is probably just deciding to NOT re-encode it because it is already in a format compatible with DVD-Video. In that case, it is only taking up 600MB of the total 4+GB of space. You still have more than 3.4GB to spare.

 

Since you are in the DVD-Video pane, it has to convert the AVI file to MPEG-2 format, the standard for DVD-Video. In this case, it will pretty much fill the entire DVD if it is about 1-hr long.

 

I have not tried dragging in both an MPEG file and an AVI file at the same time. My only guess is that Toast is automatically choosing a setting that would be most similar across the board. I don't like to use the automatic settings that often when using Toast. Sometimes you don't know what will happen as you are experiencing here. There is some rhyme and reason to it I am sure, but there are so many possible different files you can use in to Toast, I hesitate to guess at all possible results.

 

Hope that makes sense.

-Mike

Link to comment
Share on other sites

Thanks, Mike.

 

Okay. But, if I go into the "more" menu and click "always" re-encode, it still takes up the same amount of space?

 

And why would mpeg-1 take up a tiny amount of space, and the mpeg-2 made from the avi take up a huge amount of space?

 

And the anomaly of the mpeg+avi taking up a tiny space remains to be answered. Anyone?

Link to comment
Share on other sites

Okay. But, if I go into the "more" menu and click "always" re-encode, it still takes up the same amount of space?

 

And why would mpeg-1 take up a tiny amount of space, and the mpeg-2 made from the avi take up a huge amount of space?

 

And the anomaly of the mpeg+avi taking up a tiny space remains to be answered. Anyone?

 

That is a strange one. I didn't realize your original MPEG file was in MPEG-1 format. I had been assuming MPEG-2. MPEG-1 is still a standard in the official DVD-Video format; so it is possible that it is not being re-encoded. I have not found any documentation on how Toast determines whether it will re-encode something when you are in the "AUTOMATIC" settings.

 

Though, one thing I have noticed is that Toast seems to reencode all files for DVD-Video to the same format. For example, I don't know of any way to select some titles to be in 4:3 aspect ratio and others in 16:9 aspect ratio. It seems all videos/titles for a DVD-Video are given the same settings across the board. I'd like to see much more flexibility here.

 

When you go in to the Custom settings and force video Reencoding to "ALWAYS", make sure you also adjust the Average Bit Rate and Maximum Bit Rate in that same window pane. I usually set it to the highest possbile setting that will almost fill the DVD.

 

If you adjust the ABR and MBR, does this change the amount of space taken up on the DVD? Also, since you original files are in MPEG-1 and AVI format, I assume their quality isn't comparable to a normal DVD. MPEG-1 used for DVD-Video is usually about equivalent to a VHS recording in quality.

 

About your question on MPEG-1 taking up tiny space and MPEG-2 taking up a lot of space. If the MPEG-1 file is not being reencoded, then that is your answer to the first part. You still have the original 600MB file, but I guess you already knew that part. As for MPEG-2 taking up more space, it is most likely because you have the ABR and MBR settings at their default which are usually 4Mbps and 8Mbps respectively. Feel free to squish these down. If you decide to re-encode MPEG-1 or AVI in to MPEG-2, try cranking the settings for ABR and MBR all the way down to 2Mbps. This will give you a file just a little bit bigger than the orginal.

 

-Mike

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...