Jump to content
  • Who's Online   0 Members, 0 Anonymous, 13 Guests (See full list)

    • There are no registered users currently online
  • 0

USB Device Capture Problem



A previous thread on this topic was closed out for some reason. (I can guess why.) So I am starting this new one. I too am experiencing a frustrating install problem.


I already had Easy CD Creator 2009 installed on my system. I purchased the Easy VHS to DVD on line. It came with the Capture Device, a DVD disc, and somewhat brief instruction booklet. An "errata sheet" came with the instructions which states if you already have Roxio Creator 2009, DO NOT (their caps in bold) install Roxio Easy VHS to DVD. Instead go to http://www.roxio.com/go/videousb

and install the driver for the Roxio Video Capture USB device.


I messed up and did this without connecting the Video Capture device, so it did not work. Something went to the Roxio program, but since it was does in error, I wanted to remove that file. Couldn't do it for some reason. After numerous tries I was finally successful. After connecting the device, tried to download the driver again. It is a zip file. which didn't want to open. So that didn't work either.


Tried the help on line file under support which gave a completely different set of directions. It said to go to http://support.roxio.com and download RoxioC2009USBCaptureDruver.zip and drag the file RoxioC2009USBCaptureDriver.exe to your Desktop and double click the .exe file and follow the on screen instructions. Well, that file is not named that at all. It is named setup.exe. Double clicking that file results in opening it up and installing a file somewhere, but not in the existing Roxio program. It also says to click the Icon on the Desktop to open up the Easy VHS to DVD program. There is not Icon.


I too have submitted several "tickets" to the support group and yet to receive a reply. I am not that thrilled with the Roxio Creator 2009 program as it doesn't support mp3 format! If I ask to return this video device for a refund , they will probably ignore that too.


Judging from the experiences posted elsewhere, I am not alone in my frustration.





I am wonderingif the USB capture problem ever got resolved. I have Roxio Premier 10 and bought the VHS to DVD software. Installing the VHS software made the Roxio not work, so I uninstalled it and installed just the driver for the USB (the recommended download). It seemed to enable the Roxio 10 at first (captured about 7 or 8 film clips) BUT recently, I am getting a "capture" error message every time I try to capture. Can't get it to work right, can't get the driver off. ??? Can't use what I paid for ...

Link to comment
Share on other sites

1 answer to this question

Recommended Posts


This topic is now archived and is closed to further replies.

  • Create New...