Jump to content
  • 0
blackrk5

EMC 8 Label Creator

Question

The EMC 8 Label Creator printing alignment is a step backwards from EMC 7 Label Creator. I have tried unsuccessfully to Calibrate and Fine Tune the location of CD label. I am frustrated with it.

 

In EMC 7, it was fairly straight forward -- just the horizontal and vertical increments and it worked. I am going back to using it.

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

You're not the only one frustrated with it. I spent almost an entire hour trying to get this stupid label to print. It should be easy! I will not waste any more time and effort on Roxio label making again!

Share this post


Link to post
Share on other sites
  • 0

Add me to those disappointed with Label Creator. EMC 7 allowed you to do precise calibrations of your labels-- EMC 8's Calibration tool is a joke.

Share this post


Link to post
Share on other sites
  • 0

I don't know about you folks, but in addition to the problems you describe, I can't print 2-up on my disc labels, and I can't print 2-up on my back covers. Every version since 7 has added problems. It's been many months since 8 came out and no bug fixes, apologies, or updates can be found. I can only assume we've been abandoned by Roxio.

 

The only work-around I've found is to completely DO OVER any covers and labels I've created in earlier versions. I resent having to keep around THREE versions of the same software. It's outrageous and indicates contempt on the part of Roxio that they refuse to fix buggy software. They NEVER even fixed the "lack of scroll bars" problem in 7.5 Label Creator! Now we're stuck with a buggy version 8 with no hope on the horizon.

Share this post


Link to post
Share on other sites
  • 0

I agree that this program is lousy but the 2-up problem was fixed several months ago. :) Take a look at the three posts pinned to the top of this board. The third one is the one you want. The first is a work around that you may not need. The second has to do with lightscribe.

 

I don't know about you folks, but in addition to the problems you describe, I can't print 2-up on my disc labels, and I can't print 2-up on my back covers. Every version since 7 has added problems. It's been many months since 8 came out and no bug fixes, apologies, or updates can be found. I can only assume we've been abandoned by Roxio.

 

The only work-around I've found is to completely DO OVER any covers and labels I've created in earlier versions. I resent having to keep around THREE versions of the same software. It's outrageous and indicates contempt on the part of Roxio that they refuse to fix buggy software. They NEVER even fixed the "lack of scroll bars" problem in 7.5 Label Creator! Now we're stuck with a buggy version 8 with no hope on the horizon.

Share this post


Link to post
Share on other sites
  • 0

Thanks. I didn't notice the pinned post until you mentioned it. That solved that problem.

 

And also thanks to the several other of you whose name I've seen over the years giving helpful advice.

A few of which are you, GGRussell, grandpabruce, and James Hardin.

 

You are truly a dedicated bunch and deserve some appreciation.

Paully

Share this post


Link to post
Share on other sites
  • 0
Thanks. I didn't notice the pinned post until you mentioned it. That solved that problem.

 

And also thanks to the several other of you whose name I've seen over the years giving helpful advice.

A few of which are you, GGRussell, grandpabruce, and James Hardin.

 

You are truly a dedicated bunch and deserve some appreciation.

Paully

 

Thanks for the kind words, Paully.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×