Jump to content
  • Who's Online   0 Members, 0 Anonymous, 7 Guests (See full list)

    • There are no registered users currently online
  • 0

Creator 2009


Lazer
 Share

Question

I purchased Roxio 2009 on line from Dell. Better price. When I downloaded the program I received two files: Creator 2009_11 and EMC11Content_7Lang. I have tried several times to install the software. I have contacted Roxio and they take at least a week to respond, if they even respond. After installation this is what I get. The program tries to open I think and it ends up at a registration screen and it freezes on the desktop. Cannot delete it and have to do a restart to get rid of it. My system is Windows Vista 32 bit business with SP1 installed. I have had Net Framework 3.5.... with it's associated SP1 but I have deleted both the SP and the file. Still nothing. Roxio did say to try SP 3 for their software and still no luck. Then they came back and said do not install the EMC11 file. I have tried that and no luck. I am at a loss. I have tried your claen install a few times now and still no luck. What am I to do. You would think that with all of the problems Roxio has had with the installation they would have a solution. I believe their support is worthless.

Thanks for your time and consideration. I am looking for a step by step procedure that will make it work. I have no problems with any other software. I have no oher associated software like Nero installed. Looking forward to hearing from you.

Edited by Lazer
Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0
Temporarily shut off your firewall and antivirus software. Try the clean install procedure again. If that works then apply Creator 2009 sp3 and reenable your firewall and antivirus software.

 

Big Dave, I have shut the firwall off and the antivirus off for all of my attempts to get this software to work and I have had no success. I have tried all of the clean install procedures many times and I am about to throw it away. Thank you for your time and consideration answering my questions.

 

Link to comment
Share on other sites

  • 0

You may want to go to Dell and see if they can give you any help. They also have a users group that may be of help.

 

When you do the clean install, are you sure you are getting all the Roxio and Sonic applications? What about when you use the Microsoft Installer Cleanup Utility. Sometimes those things hid out there.

 

Where there any folders that you has trouble deleting?

 

 

Link to comment
Share on other sites

  • 0
You may want to go to Dell and see if they can give you any help. They also have a users group that may be of help.

 

When you do the clean install, are you sure you are getting all the Roxio and Sonic applications? What about when you use the Microsoft Installer Cleanup Utility. Sometimes those things hid out there.

 

Where there any folders that you has trouble deleting?

 

 

Steve, thanks for the idea but that did not work either. I got so tired of fighting it I reformatted my hard drive and reinstalled everything. The first program was Roxio Creator 2009 and it seems to be working okay ...... for now. I will see. I think it is really ashame that Roxio could not help me get this straight. I have one question that maybe you can answer. I downloaded two files from Dell. One is Roxio Creator 2009 and the second is EMC11 content. What is in this second file? Do I have to install it? I am kind of afraid at this point. Any help would be appreciated.

 

Bob

 

Link to comment
Share on other sites

  • 0
Steve, thanks for the idea but that did not work either. I got so tired of fighting it I reformatted my hard drive and reinstalled everything. The first program was Roxio Creator 2009 and it seems to be working okay ...... for now. I will see. I think it is really ashame that Roxio could not help me get this straight. I have one question that maybe you can answer. I downloaded two files from Dell. One is Roxio Creator 2009 and the second is EMC11 content. What is in this second file? Do I have to install it? I am kind of afraid at this point. Any help would be appreciated.

 

Bob

 

That is all the content (transitions, menu styles, etc.) for VideoWave, MyDVD, PhotoSuite, and maybe things for other programs, in the suite. Load it.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...