Jump to content
  • 0

Updates For EMC 10



This is an unrelated installation issue for updating EMC from v10.0 to v10.1 on Vista Home Premium SP1:


There are two downloadable files from Roxio: the program installer and the content installer. Each are over 700 MB.


Both appear to install without trouble (and uninstall 10.0 in the process). A reboot is required after installation.


After reboot, the Start menu shows the EMC folder containing NEW applications (if your OS is set to show new apps). However, the applications are shown to be 10.0 (or so it seems).


If I launch the Suite ("Start | All Programs | Roxio Easy Media Creator 10 | Easy Media Creator 10 Suite" at C:\Program Files\Common Files\Roxio Shared\10.0\Roxio Central36\Main\Roxio_Central36.exe), it shows the application as being 10.1 in the About.


All is well to this point.


Now I go into a sub-application, from within the Suite (like the one that copies from VHS and other sources direct to DVD), and then I get a pop-up window titled, "Roxio Central Tools" and then another one of the same title over that one that states:


The feature you are trying to use is on a network resource that is unavailable.


Click OK to try again, or enter an alternate path to a folder containing the installation package 'TOOLS.msi' in the box below.


Use source:



{ OK } { Cancel } { Browse... }


At this point, it fails. There are no folders in the Temp directory that even slightly resemble the above.


There are Sonic.tmp, Sonic1.tmp, and Sonic2.tmp folders there but they are empty.


Likewise, I am not using a network resource. My C drive is the drive from which I launched the downloaded installers, and which is set as my Temp folder, and is the drive to which I am installing the applications.


So, I am unable to use the v10.1 applications now. Anyone with theories or the ability to assist?





Link to comment
Share on other sites

1 answer to this question

Recommended Posts

Hey Joe,


You seem to have a fouled-up install of 10.1, which happened a number of times to me when I was trying it out. I got sick of cleaning it all out, reinstalling 10.0, and then removing 10.0 again with this installer so I tried something else.


Why don't you :

[1] extract all the files from your large downloaded "program" archive to a convenient folder on your hard drive, using something like WinZip or WinRar to extract.

[2] install 10.1 from there, using your 10.0 key when requested.


This worked for me. It took 6 minutes to install in this manner when I did it a few minutes ago, into a system which had never seen a Roxio program before. Since you have a broken install there you might need to uninstall or clean out the system a bit first, but the reinstall should go fine.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...