Jump to content
  • 0
Starstruck

Can't burn DVD

Question

I have Easy DVD Copier, Easy CD & DVD Copier, and Easy Media Copy 9. Up until this week I had no problem copying DVDs. I just tried copying four different DVDs, using all three programs, and was unable to burn them. On Easy CD & DVD, at 46%, I got this error message: "Cannot write medium. The recordable speed of this medium is not compatible with the capabilities of this recorder. Unit not ready." Say what? I tried ImgBurn and got similar messages: "Cannot format Medium. Unsupported Medium Write Speed.

 

What do these messages mean? Is it something that I can fix? Is the burner itself broken? I am very dumb technically so I appreciate any help I can get, in simple language. Thank you.

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Did you try updating your drive firmware?

 

Device manager should tell you your drive model and manufacturer then go the the manufacturer's site and look for an update.

 

If you switched media manufacturer then you maight want to try the previous brand. Verbatim is a good brand.

Edited by Big_Dave

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×