Jump to content
  • Who's Online   0 Members, 0 Anonymous, 12 Guests (See full list)

    • There are no registered users currently online
  • 0

Problem with Cineplayer Codec


thegilpins

Question

Hi,

 

I was trying out different codecs with my TV viewing application and it seems to have affected the codec used with Cineplayer 5.

 

When I run Cineplayer it is now using the ffdshow video / audio codec rather than the Roxio one (which I assume is Cinemaster). I know this because an ffdshow audio icon appears in the windows tray.

 

I get audio but no video. I do not know how to resolve this.

 

I tried a clean install of Creator 2009 earlier and that did not work.

 

It seems that Vista is overriding Cineplayer choice of Codec.

 

Can anyone help?

 

I am using Vista 32 Home Premium. I have been using Cineplayer successfully for months. The problem also was affecting DVD within WMP but the clean install solved this. I have also am using Creator 2009 SP4.

Link to comment
Share on other sites

11 answers to this question

Recommended Posts

That may be the case but I think it would have helped if within CinePlayer it would give you an explicit option to choose the codec rather than leaving it to the priority of the filters, much like the MS Media Center Decoder Utility offers.

Link to comment
Share on other sites

Hi, by users I mean Windows users created via Control Panel -> User Accounts. If I create a new windows user then CinePlayer works fine. It is just three existing users that do not work.

 

I ran MS Media Center Decoder Utility and for Video I have "Microsoft MPEG-2 Video Decoder" and for Audio I have "Microsoft MPEG-1/DD Audio Decoder".

 

Note that Media Player and Media Centre still both play DVD successfully.

Link to comment
Share on other sites

Yes I do use IE 8.

 

This issue seems to be with the DirectShow FFD decoder.

 

For uses on the PC that have never used Cineplayer the ffdshow Compatibility Manager is shown and ffd can be switched off.

 

For existing users I cannot seem to change these options or override it.

 

Link to comment
Share on other sites

I was coming to the same conclusion.

 

I also did a system restore yesterday and then reloaded any recent software / driver updates to try and find the cause of the problem.

 

The issue is caused by loading the latest Soundblaster X-Fi Fatal1ty driver available at http://support.creative.com/downloads/welc...erType=1#type_1

 

This driver seems to add in the DirectShow FFD (ffdshow) codec, which from what I read is used more within Windows 7 than it is Vista.

 

Anyway this driver stops Cineplayer working for existing windows users, but interestingly for new windows users, when Cineplayer is run for the first time windows asks whether ffdshow codec should be used. Answering 'no' means that Cineplayer works successfully. Why this choice is not given to existing windows users is beyond me. I shall raise the issue with Soundblaster support.

 

 

 

Link to comment
Share on other sites

Hi,

 

I have managed to stop ffdshow decoder working with Cineplayer but is still seems to be using the wrong codec.

 

For new windows users I create cineplayer works fine, so for the existing users there must be a cineplayer setting somewhere that defines what codec to use, maybe in the registry.

 

Can someone help here?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...