Jump to content
  • Who's Online   0 Members, 0 Anonymous, 10 Guests (See full list)

    • There are no registered users currently online
  • 0

EMC 8 Update Patch for retail purchase version


eugene9387

Question

Hi, my name is Eugene

 

I purchased a retail version of EMC 8 and upgraded from EMC 7.5 which I assumed went smoothly. I then downloaded the update patch per Roxio's web site and tried to install it on several occasions without success. Each time I receive an error message that " the upgrade patch cannot be installed by the Windows Installer service because the program to be upgraded may be missing, or the upgrade patch may update a different version of the program. Verify that the program to be upgraded exist on your computer"

Does anyone have an answer to this problem?

 

I am experiencing lots of crashes with EMC 8 which I did not have with EMC 7.5 or 7. Would this update patch be of anyhelp?

 

My computer is a Dell 8200 with Windows XP SP2 installed, 200 GB hard drive, GeForce4 video card and enough memory and speed.

 

Thank you

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

Hi, my name is Eugene

 

I purchased a retail version of EMC 8 and upgraded from EMC 7.5 which I assumed went smoothly. I then downloaded the update patch per Roxio's web site and tried to install it on several occasions without success. Each time I receive an error message that " the upgrade patch cannot be installed by the Windows Installer service because the program to be upgraded may be missing, or the upgrade patch may update a different version of the program. Verify that the program to be upgraded exist on your computer"

Does anyone have an answer to this problem?

 

I am experiencing lots of crashes with EMC 8 which I did not have with EMC 7.5 or 7. Would this update patch be of anyhelp?

 

My computer is a Dell 8200 with Windows XP SP2 installed, 200 GB hard drive, GeForce4 video card and enough memory and speed.

 

Thank you

 

No patch is going to keep your computer from crashing. You may need to do some maintenance on the computer by getting rid of spyware/malware, checking for viruses, and defragging.

 

Did you download EMC 8, or did you get it retail? If you did not get it retail, then the patch won't work for your version.

 

Also, the patch does not work on the retail versions in the UK.

Link to comment
Share on other sites

Hi, my name is Eugene

 

I purchased a retail version of EMC 8 and upgraded from EMC 7.5 which I assumed went smoothly. I then downloaded the update patch per Roxio's web site and tried to install it on several occasions without success. Each time I receive an error message that " the upgrade patch cannot be installed by the Windows Installer service because the program to be upgraded may be missing, or the upgrade patch may update a different version of the program. Verify that the program to be upgraded exist on your computer"

Does anyone have an answer to this problem?

 

I am experiencing lots of crashes with EMC 8 which I did not have with EMC 7.5 or 7. Would this update patch be of anyhelp?

 

My computer is a Dell 8200 with Windows XP SP2 installed, 200 GB hard drive, GeForce4 video card and enough memory and speed.

 

Thank you

 

Eugene,

 

I am having the exact same problems that you are having. EZ 7.5 ran just fine, but I basically can't complete any project in EZ Creator 8. My computer crashes, freezes up etc. I AM VERY FRUSTRATED!!!. I am very computerate literate. I don't have any virus problems, spyware and my disk does not need defragging! All other programs run just fine on my computer EXFCEPT for EZ 8. I am so frustrated. I don't have an answer for you but just want to let you know that I feel that this is Roxio's problemm, not yours.

KEN

Link to comment
Share on other sites

Eugene,

 

I am having the exact same problems that you are having. EZ 7.5 ran just fine, but I basically can't complete any project in EZ Creator 8. My computer crashes, freezes up etc. I AM VERY FRUSTRATED!!!. I am very computerate literate. I don't have any virus problems, spyware and my disk does not need defragging! All other programs run just fine on my computer EXFCEPT for EZ 8. I am so frustrated. I don't have an answer for you but just want to let you know that I feel that this is Roxio's problemm, not yours.

KEN

 

And your computer specs are? What programs do you have running in the background? Have you got the latest updates for your video card? What other burning software do you have running on your computer?

Link to comment
Share on other sites

No patch is going to keep your computer from crashing. You may need to do some maintenance on the computer by getting rid of spyware/malware, checking for viruses, and defragging.

 

Did you download EMC 8, or did you get it retail? If you did not get it retail, then the patch won't work for your version.

 

Also, the patch does not work on the retail versions in the UK.

 

Thanks, Bruce

 

I purchased the software retail here in the USA at Best Buy. It is my understanding that the update patch was required if EMC 8 is a retail version. In fact I had just reformatted my hard drive and had the necessary safety features installed for virus, malware, etc. EMC 8 was the one of the first software I installed to complete a project I had started before. The trouble is that I did not experience this kind of problem with EMC 7.5.

 

Thanks again

Link to comment
Share on other sites

Thanks, Bruce

 

I purchased the software retail here in the USA at Best Buy. It is my understanding that the update patch was required if EMC 8 is a retail version. In fact I had just reformatted my hard drive and had the necessary safety features installed for virus, malware, etc. EMC 8 was the one of the first software I installed to complete a project I had started before. The trouble is that I did not experience this kind of problem with EMC 7.5.

 

Thanks again

 

Okay, open the software from the Roxio Home icon on your desktop. Then click on Applications, then open Creator Classic, click on Help, then click on about. If the build number starts with 8.05..., you already have the latest version, and you do not need the patch.

 

If you just bought it, it is doubtful that it isn't the latest build. Post back with what you find out.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...