Jump to content
  • Who's Online   0 Members, 0 Anonymous, 21 Guests (See full list)

    • There are no registered users currently online
  • 0

Import Video problems


JLS
 Share

Question

I am trying to import video using Roxio Creator Premier

Version: 10.2.606 SP1 (I got with my new Dell computer) and it recognizes my JVC camcorder and then this error pops up:

"Failed to setup system components for showing picture or sound"

I am not sure what to do, can anyone help me please?

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0
I am trying to import video using Roxio Creator Premier

Version: 10.2.606 SP1 (I got with my new Dell computer) and it recognizes my JVC camcorder and then this error pops up:

"Failed to setup system components for showing picture or sound"

I am not sure what to do, can anyone help me please?

 

I'm not trying to pass the buck but it sounds like there is something more than just the OEM software that you have. Contact Dell tech service. They specified the software and installed it. They are responsible for the support of that software and of course the computer. Did you check their web site or users group for a fix/update?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...