Jump to content
  • 0

Trouble logging into support


dan  McCarter
 Share

Question

I am having trouble logging into support to report a problem with CD Spin Doctor. when I key in my e-mail address and my password the message appears that my e-mail address is incorrect. I have no problem getting into the forum, or getting to the website to change my password, and view my products.

 

I just called the telephone number for support and they want to have credit card information and will clear my credit for approximately $30.00 before I explain my problem. And My problem is that their website doesn't work, I have had the same e-mail address for over 10 years.

My e-mail address d_mccarter@mac.com does have a special character it. Some website don't seem to like the underscore character but I have other addresses that do not use an underscore and they don't work either.

Thanks

 

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0
I am having trouble logging into support to report a problem with CD Spin Doctor. when I key in my e-mail address and my password the message appears that my e-mail address is incorrect. I have no problem getting into the forum, or getting to the website to change my password, and view my products.

 

I just called the telephone number for support and they want to have credit card information and will clear my credit for approximately $30.00 before I explain my problem. And My problem is that their website doesn't work, I have had the same e-mail address for over 10 years.

My e-mail address d_mccarter@mac.com does have a special character it. Some website don't seem to like the underscore character but I have other addresses that do not use an underscore and they don't work either.

Thanks

 

Hi Dan -

 

Underscores are accepted (one of my logins has one and never had an issue) and it seems you have successfully submitted tickets before with your address.

 

When did you try to login and have you tried again?

 

Thanks,

 

Jon

Link to comment
Share on other sites

  • 0
I am having trouble logging into support to report a problem with CD Spin Doctor. when I key in my e-mail address and my password the message appears that my e-mail address is incorrect. I have no problem getting into the forum, or getting to the website to change my password, and view my products.

 

I just called the telephone number for support and they want to have credit card information and will clear my credit for approximately $30.00 before I explain my problem. And My problem is that their website doesn't work, I have had the same e-mail address for over 10 years.

My e-mail address d_mccarter@mac.com does have a special character it. Some website don't seem to like the underscore character but I have other addresses that do not use an underscore and they don't work either.

Thanks

 

Have you tried "forgot my password"?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...