Jump to content
  • 0

EMC install on Vista


Jason J.
 Share

Question

3 answers to this question

Recommended Posts

  • 0
I had EMC 7.5 on my old computer(XP) and can't install it on my new one with Vista. Do I have to purchase the newest version or can I update 7.5? Thanks

 

EMC 7.5 will only partially work in Vista. All versions, 9.1 and later, work with Vista.

 

The latest version is Creator 2010. (Not to be confused with Easy Media Creator 10, which is an earlier version.)

Link to comment
Share on other sites

  • 0
EMC 7.5 will only partially work in Vista. All versions, 9.1 and later, work with Vista.

 

The latest version is Creator 2010. (Not to be confused with Easy Media Creator 10, which is an earlier version.)

 

 

Do I have to purchase the newest version or can I update 7.5? Thanks

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...