Jump to content
  • 0

Can't Open Easy Media Creator Suite 10


Shane Stevens
 Share

Question

Hello, I have had the Easy Media Creator Suite 10 for about 3 years now. I haven't used it for about 12 months. When trying to use it yesterday I could not open the software. I have tried re-instatlling the software but it still won't open. I have an anti virus software so I have phoned the makers of this and they told me how to disconnect the firewall but I still cannot open the software. I have Windows 98. Is anyone able to help me with this problem.

 

Thanks Melissa

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0
Hello, I have had the Easy Media Creator Suite 10 for about 3 years now. I haven't used it for about 12 months. When trying to use it yesterday I could not open the software. I have tried re-instatlling the software but it still won't open. I have an anti virus software so I have phoned the makers of this and they told me how to disconnect the firewall but I still cannot open the software. I have Windows 98. Is anyone able to help me with this problem.

 

Thanks Melissa

 

Are you sure you had it running on the Windows 98 in the past? That OS is not supported.

 

Minimum requirements

•Microsoft® Windows Vista, Windows XP (Service Pack 2)

 

Did you buy the product or did it come with your computer orther piece of hardware? Sometimes hardware manufacturers tweak a cut down version to fit their hardware.

 

 

Link to comment
Share on other sites

  • 0

I have had EMC 10 for 2 years running on a Dell with Windows XP Media Center Edition. I purchased EMC 10. it was not bundled. As reported by Melisa, if I don't use it for several weeks, I can't open it. I 'double click' repeatedly, or 'right click' and click 'open', to no avail. The icon is dead. I must uninstall and reinstall. Then it works again for awhile. To uninstall is very time consuming. Please solve this problem. Can you send me another application file to install? or whatever works!

Link to comment
Share on other sites

  • 0

I'm afraid Easy Media Creator 10 is "Legacy" software now, it's about two and a half years old and Sonic/Roxio doesn't sell it any more.

 

This board is populated by customers such as yourself, so I'm sorry but we're not in a position to give you other software.

 

Please read around the messages on this forum. I suspect that you'll probably find you have a registry cleaner which is killing the software. There is a message pinned HERE which explains the fault mechanism and offers cures. The 'Repairer' should cure the problem permanently once you run it against a broken installation and give it the CD key.

 

Regards,

Brendon

Link to comment
Share on other sites

  • 0
I'm afraid Easy Media Creator 10 is "Legacy" software now, it's about two and a half years old and Sonic/Roxio doesn't sell it any more.

 

This board is populated by customers such as yourself, so I'm sorry but we're not in a position to give you other software.

 

Please read around the messages on this forum. I suspect that you'll probably find you have a registry cleaner which is killing the software. There is a message pinned HERE which explains the fault mechanism and offers cures. The 'Repairer' should cure the problem permanently once you run it against a broken installation and give it the CD key.

 

Regards,

Brendon

 

 

Brendon,

 

Thanks very much. It's late here. I'll try it in the morning.

 

Vol

Link to comment
Share on other sites

  • 0

To Brendon,

 

I finally got back to my problem with EMC 10. I uninstalled and reinstalled. It worked fine (copying a DVD). Several days later, it still opens and works. I then ran the "repairer" that you sent me. A dialog box said "repair completed succesfully." It did not ask me for my CD code. If EMC 10 stops working again, I will run the"repairer" again. Perhaps then it will ask for my CD code and fix it permanently. Thanks very much for your help.

 

I am not sure that I understand this website. I now take it that you are a volunteer and not an employee of Roxio. If that is the case, then my original post was a bit rude, and I apologize.

 

I must say though that I am a bit put off by Roxio's concept of "legacy software." Suppose that you took your 2-year old Honda Accord in for service and were told "sorry, no parts available, your Accord is now a Legacy! " However, I assume that Rpxio is not alone in this practice.

 

Again, Brendon, thanks for your help and the "repairer" application.

 

Vol

 

 

 

Link to comment
Share on other sites

  • 0
I am not sure that I understand this website. I now take it that you are a volunteer and not an employee of Roxio. If that is the case, then my original post was a bit rude, and I apologize.

 

I must say though that I am a bit put off by Roxio's concept of "legacy software." Suppose that you took your 2-year old Honda Accord in for service and were told "sorry, no parts available, your Accord is now a Legacy! " However, I assume that Rpxio is not alone in this practice.

 

Again, Brendon, thanks for your help and the "repairer" application.

Hi Vol,

 

Yes I am not an employee. Like the others, I just volunteer to help where I can.

 

I like your analogy about the Honda, but if it turned into a Legacy that would make it a Subaru. :)

Seriously though, I don't think Sonic/Roxio is alone in this practice nowadays although not all companies have that policy. I understand why your post was a bit terse.

 

I'm glad I could help you, and hope the Repairer has done its job properly.

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...