Jump to content
  • Who's Online   0 Members, 0 Anonymous, 16 Guests (See full list)

    • There are no registered users currently online
  • 0

No digital audio on DVD created from MPEG2 TS files


neilski
 Share

Question

Hi

 

I have a number of MPEG-2 transport stream files which I'm trying to put on a DVD using Toast 10.

 

The DVDs appear to be created correctly. Audio plays on the DVD Player app, and on a Toshiba TV with built in DVD player, but on my main DVD player - a Panasonic DMR-ES10 - nothing comes through the optical audio output.

 

I've tried various settings on the burn screen. I'm keen not to re-encode the video, so encoding is set to "Custom". I've tried setting Audio as "Dolby Digital" and as PCM, same result.

 

DVDs burned with iDVD are fine.

 

Any help appreciated, thanks!

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0
If the DVD audio plays fine in the DVD player app as well as Toshiba player, check to see if the Panasonic Player offers Audio settings?

 

Thanks. I should have added that sound seems to come through the SCART chain (DVD -> Freeview HDD recorder -> 5.1 amp) but that I have to switch the amp to the Freeview channel for that to work. I don't have to do that for any other DVD (commercial or produced through iDVD).

 

Link to comment
Share on other sites

  • 0
Thanks. I should have added that sound seems to come through the SCART chain (DVD -> Freeview HDD recorder -> 5.1 amp) but that I have to switch the amp to the Freeview channel for that to work. I don't have to do that for any other DVD (commercial or produced through iDVD).

If the source video has MPEG audio then the problem can likely be fixed by going to the audio setup in the Panasonic player and activating the MPEG-to-PCM audio option.

Link to comment
Share on other sites

  • 0
If the source video has MPEG audio then the problem can likely be fixed by going to the audio setup in the Panasonic player and activating the MPEG-to-PCM audio option.

 

Thanks, but I can't find any such setting on my player. The player does tell me that audio track 1 is MPEG audio, but nothing from the digital output. :(

Link to comment
Share on other sites

  • 0
Thanks, but I can't find any such setting on my player. The player does tell me that audio track 1 is MPEG audio, but nothing from the digital output. :(

I downloaded the manual for your player and don't see that option listed. This may mean the MPEG audio only plays via the analog audio output with that player. So what you can you do? The simplest is to choose always re-encode in Toast's custom encoder settings window so that Toast re-encodes the audio to AC-3. It also means the video will be re-encoded but it should still look very much the same.

 

Lots of devices create MPEG audio with the MPEG 2 video such as several EyeTV models and Roxio's Easy VHS to DVD for Mac. It seems strange to me that a brand-name like Panasonic doesn't have that support.

Link to comment
Share on other sites

  • 0

I recreated the image, re-encoding the video to as high a bitrate as would fit on the disc (to preserve video quality as much as possible), and lo & behold the audio behaves correctly on all players. Takes 8 hours on my Intel Mini (which is why it's taken me so long to post this), but it does work

 

Thanks for your help tsantee!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...