Jump to content
  • Who's Online   0 Members, 0 Anonymous, 14 Guests (See full list)

    • There are no registered users currently online
  • 0

Cineplayer BD won't playback Avatar


Turbo Z
 Share

Question

As most other players soft or hard had already update their BD+ to support Avatar, I find it hard to believe Cineplayer is the only one left behind. In fact I see no single update since I bought it when it was first released. It sure needs bug fix as this is the only player that can't handle interlaced bluray content. Also the mouse pointer and control panel at the bottom pop up unexpectedly from time to time without me touching the mouse. And is it the only one that won't bitstream HD audio?

 

I mean, is there any update or bug fix in progress? Or it is as it is? :blink:

 

Link to comment
Share on other sites

14 answers to this question

Recommended Posts

  • 0
As most other players soft or hard had already update their BD+ to support Avatar, I find it hard to believe Cineplayer is the only one left behind. In fact I see no single update since I bought it when it was first released. It sure needs bug fix as this is the only player that can't handle interlaced bluray content. Also the mouse pointer and control panel at the bottom pop up unexpectedly from time to time without me touching the mouse. And is it the only one that won't bitstream HD audio?

 

I mean, is there any update or bug fix in progress? Or it is as it is? :blink:

 

Send a ticket to Roxio to see if they are working on it. We don't have that information so let us know what you find out. There is free Tech support for a time after you buy the flagship product so you might want to call them.

Link to comment
Share on other sites

  • 0

I see people mention using Cineplayer BD version 5.5 but I am still stuck with 5.3 since my purchase and I can't find anyway to update or patch. The in-program check for update always return nothing. Customer service offer no help but ask me to wait. But newer version is definitely out. How can I get it?

Link to comment
Share on other sites

  • 0

Not having a Blu-Ray drive yet, I can't be specific, but I seem to recall that firmware upgrades were required to handle the new encryption system on Avatar.

 

To me this would suggest that the problem lies with the drive firmware rather than the software (it can only handle what the drive is capable of sending to it). If the drive can't read the disc, then it simply won't be sent to the software.

 

Update - not that I've heard mentioned

Link to comment
Share on other sites

  • 0

I see people mention using Cineplayer BD version 5.5 but I am still stuck with 5.3 since my purchase and I can't find anyway to update or patch. The in-program check for update always return nothing. Customer service offer no help but ask me to wait. But newer version is definitely out. How can I get it?

 

You do have the BD play back plugin?

 

http://forums.support.roxio.com/topic/57002-creator-2010-high-defblu-ray-disc-plug-in-and-blu-ray-playback-plug-in/page__pid__293823#entry293823

 

 

http://www.roxio.com/enu/products/creator/playback/overview.html

 

cd

Link to comment
Share on other sites

  • 0

I have the same problem and I definately have the blu-ray playback plugin cineplayer reports 5.3 and say's no upgrade available!

Link to comment
Share on other sites

  • 0

I have the same problem and I definately have the blu-ray playback plugin cineplayer reports 5.3 and say's no upgrade available!

 

 

What problem is that?

 

1. Cineplayer BD won't playback Avatar

 

2. Cineplayer BD version 5.5 but I am still stuck with 5.3

 

We are not sure # 2 is a problem yet!

Link to comment
Share on other sites

  • 0

I bought the standalone Cineplayer BD back in January and so far no update I can find either checking within the program or from this site. I also own other software players and their update is pretty frequent to fix all kinds of playback issues. I have no problem playing Avatar using other players so my hardware/firmware is not to blame. What I don't understand is that people definitely are using version 5.5 if they buy it recently but we who bought it early are left with no support or patch. This can't be right.

Link to comment
Share on other sites

  • 0

I bought the standalone Cineplayer BD back in January and so far no update I can find either checking within the program or from this site. I also own other software players and their update is pretty frequent to fix all kinds of playback issues. I have no problem playing Avatar using other players so my hardware/firmware is not to blame. What I don't understand is that people definitely are using version 5.5 if they buy it recently but we who bought it early are left with no support or patch. This can't be right.

Not so sure about that…

 

One source I saw indicated it was a Firmware issue, even with BD Players! Here

 

I see there is a Firmware update for my BD drive, I will apply it, but I have to find another BD disc to use as a test for it and the CinePlayer 5.3...

 

Update: I did not apply the firmware update yet but I did pick up a BD movie The Book of ELI... It plays OK in CinePlayer BD with my drive. Can other users play that one OK in CP?

Edited by Jim_Hardin
Link to comment
Share on other sites

  • 0

Not so sure about that…

 

One source I saw indicated it was a Firmware issue, even with BD Players! Here

 

I see there is a Firmware update for my BD drive, I will apply it, but I have to find another BD disc to use as a test for it and the CinePlayer 5.3...

 

Update: I did not apply the firmware update yet but I did pick up a BD movie The Book of ELI... It plays OK in CinePlayer BD with my drive. Can other users play that one OK in CP?

 

 

I understand firmware update is important even to standalone players. I have 3 of those and no problem playing Avatar. There are 2 LG BD/HD combo drives with latest firmware connected to my PC and all other software players including PowerDVD 9/10, Windvd 2010, TMT2 (needs patch) and TMT3 (needs patch) can playback Avatar fine. Only CinePlayer BD won't start like the old and abandoned Nero Showtime, as well as Powerdvd 7, 8 and Windvd 9, all are previous versions. Usually Anydvdhd can fix this kind of new BD+ problems but not with CinePlayer (TMT2 and 3 before patches, and all versions of Powerdvd and Windvd old and new work if Anydvdhd, the version that supports Avatar, is enabled). The only reply I got from Roxio customer service is that the work is still in progress. But Avatar is already months old. And what troubles me is that if new buyers are using CP 5.5 why no patch is release to us?

 

I don't have The Book of Eli to test but all disc protection are not made equal and Avatar seems to be the most troublesome disc when it was released causing many software/hardware players to fail. Only I never thought the problem could have got this long without fix in CinePlayer.

Edited by Turbo Z
Link to comment
Share on other sites

  • 0

What problem is that?

 

1. Cineplayer BD won't playback Avatar

 

2. Cineplayer BD version 5.5 but I am still stuck with 5.3

 

We are not sure # 2 is a problem yet!

 

 

Oooops sorry been a bit busy.......but answer is number 2! I am still on 5.3 and it reports no upgrade available. Don't own Avatar so couldn't tell you if it plays for me or not. But if a newer version of Cineplayer is out I sure would like to be upgraded maybe it fixes some of the hdcp issues.

Link to comment
Share on other sites

  • 0

Oooops sorry been a bit busy.......but answer is number 2! I am still on 5.3 and it reports no upgrade available. Don't own Avatar so couldn't tell you if it plays for me or not. But if a newer version of Cineplayer is out I sure would like to be upgraded maybe it fixes some of the hdcp issues.

 

Well after almost a year of waiting for some kind of an answer or reply from Roxio about the Blu-ray plugin not supporting repeaters I have never received a response from staff through phone support, IM, or the forum. At this point I guess it was safe to give up and purchase a competing product, now I have a product that will work with my projector pass HD Master Sound and works very sweet (I am happy). But this has left a sour taste in my mouth because this product cost slightly more the the Roxio BD plugin that has never worked or served its purpose and no patches in almost a year. After this experience I don't think any Roxio products are in my future. It is too bad when a company forgets that it's customers want a product that works this was my second generation product I originally had Roxio 2009 pro that I really liked and was basically forced to upgrade to 2010 after not too long if I wanted to run Windows 7 pro 64bit wihout bugs. I think Roxio has become a company that has totally forgot customers and I do not understand how they fiqure they can get repeat sales. I guess they would rather fool the first time customer get the money and run!

 

Thanks Roxio (for not much)

Link to comment
Share on other sites

  • 0

Well after almost a year of waiting for some kind of an answer or reply from Roxio about the Blu-ray plugin not supporting repeaters I have never received a response from staff through phone support, IM, or the forum. At this point I guess it was safe to give up and purchase a competing product, now I have a product that will work with my projector pass HD Master Sound and works very sweet (I am happy). But this has left a sour taste in my mouth because this product cost slightly more the the Roxio BD plugin that has never worked or served its purpose and no patches in almost a year. After this experience I don't think any Roxio products are in my future. It is too bad when a company forgets that it's customers want a product that works this was my second generation product I originally had Roxio 2009 pro that I really liked and was basically forced to upgrade to 2010 after not too long if I wanted to run Windows 7 pro 64bit wihout bugs. I think Roxio has become a company that has totally forgot customers and I do not understand how they fiqure they can get repeat sales. I guess they would rather fool the first time customer get the money and run!

 

Thanks Roxio (for not much)

I've reached the same point too, Roxio - You have lost a long time customer, for good.

Link to comment
Share on other sites

  • 0

I've reached the same point too, Roxio - You have lost a long time customer, for good.

 

No posts, no questions, just complaints. How do you know that you have he same problem and not just the same symptom? Do you have Vista or W7? What video device do you have? Did you turn off Video Acceleration?

Edited by sknis
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...