Jump to content
  • 0

Green Screen overlay problem


G Man 45
 Share

Question

I am trying to create a video using green screen effects. I followed the creating green screen effects instructions on the Roxio learning center page, but did not get the results I anticipated.

 

I placed a photo in my project and overlayed it with a video of a moving object.

 

First, when I use the chroma key setting to eliminate my green screen, the green background does not become transparent. However, it does work; I just have to click on the OVL1 button next to my video twice in order to see the results.

 

Second, when I run the video my moving object moves behind my photo instead of on top of it as it moves. There is a hole (the outline of my object) in the photo and when it moves, it moves behind the photo. There is an outline in the photo after the object moves and you can see my green screen filling the hole.

 

I've created several videos trying to figure out the problem and always get the same results.

Link to comment
Share on other sites

10 answers to this question

Recommended Posts

  • 0

Yes, my photo is on the first track and my video on the overlay track. Before I run the video, the video appears on top of the photo. It's when I run my production, my moving image moves behind the photo and not infront of it leaving a hole in the photo exposing the green screen that was behind the photo.

 

Thanks

 

Gary M

 

On what track are you placing the image that you want in the background? That image should be on the main video track (1st one). The green screen video can be on any overlay track.

 

Link to comment
Share on other sites

  • 0
Yes, my photo is on the first track and my video on the overlay track. Before I run the video, the video appears on top of the photo. It's when I run my production, my moving image moves behind the photo and not infront of it leaving a hole in the photo exposing the green screen that was behind the photo.

Thanks

 

Gary M

 

Where is the green screen - on the video or on the photo? The one with the green screen should be on the overlay track. Are the video and the photo the same length? Are you really using a green screen and is it uniformly lighted so that there are no shadows? What color are you using? Is the same color in both the video AND the photo?

Link to comment
Share on other sites

  • 0

Yes, the green screen is on the video and there are no shadows. I have tried several things such as placing my moving object over a black and white photo as well as a color photo, all with the same results. I've even used different shade of green for my screen. And yes, the video and photo are the same length.

 

Thanks for your input

 

Gary M

 

 

Where is the green screen - on the video or on the photo? The one with the green screen should be on the overlay track. Are the video and the photo the same length? Are you really using a green screen and is it uniformly lighted so that there are no shadows? What color are you using? Is the same color in both the video AND the photo?

 

Link to comment
Share on other sites

  • 0

What do yo mean by "used different shade of green for my screen"? How are you creating the background? You know that the green screen is something that is shot WITH the video at the same time. You can't add it later. Just so we're on the same page.

 

Video works similar to these still images. You first shoot your subject in front of a green screen. The computer software then makes the 'green' invisible so you can put something else behind your subject.

post-49-1275623003.jpg

post-49-1275623008.jpg

post-49-1275623017.jpg

Link to comment
Share on other sites

  • 0

I have used a darker and lighter shade of green for my backdrop and have filmed myself and other moving objects in front of it with the same results.

 

I have followed the tutorial on the Roxio learning center page. I have first place a photo on the first track (Video track) and then placed the video with green screen on the Ovl1 track. At the stage where I use the chroma key to eliminate the green (selecting the eye dropper), the green background does not become transparent to reveal any of the photo behind the green. I have found that at that point, if I double click on the Ovl1 tab the video first dissapears from the preview screen (first click) and then reappears (second click) with the green background removed. My image at that point is still placed on top of the background photo. But when I preview my production, the image moves behind the photo instead of on infront of it, leaving a hole in the photo where the image originally was placed.

 

Thanks,

Gary M

 

What do yo mean by "used different shade of green for my screen"? How are you creating the background? You know that the green screen is something that is shot WITH the video at the same time. You can't add it later. Just so we're on the same page.

 

Video works similar to these still images. You first shoot your subject in front of a green screen. The computer software then makes the 'green' invisible so you can put something else behind your subject.

 

Link to comment
Share on other sites

  • 0
I have used a darker and lighter shade of green for my backdrop and have filmed myself and other moving objects in front of it with the same results.

 

I have followed the tutorial on the Roxio learning center page. I have first place a photo on the first track (Video track) and then placed the video with green screen on the Ovl1 track. At the stage where I use the chroma key to eliminate the green (selecting the eye dropper), the green background does not become transparent to reveal any of the photo behind the green. I have found that at that point, if I double click on the Ovl1 tab the video first dissapears from the preview screen (first click) and then reappears (second click) with the green background removed. My image at that point is still placed on top of the background photo. But when I preview my production, the image moves behind the photo instead of on infront of it, leaving a hole in the photo where the image originally was placed.

 

Thanks,

Gary M

 

This should be immediate. Make sure you have the overlay track selected when you use the eyedropper. There should be a dotted line around it.

 

I recently answered another post about green screen so I tried it within the last 2 weeks. It does work for me.

Link to comment
Share on other sites

  • 0

Gary,

 

Problem solved.

 

All of the emails back and forth challenged me to take another look at the program. Under the "Tools" tab I selected "Options." My options selection "Render Using" was set for "Hardware." I changed that option to "Software" to see what would happen and found that it solved my problem. I will post this solution so others who offered help are aware of this.

 

I plan to use this tool to promote a show that I do. Please visit www.morrison-tg.com.

Again, thanks again for you assistance and patients with me.

 

Gary

 

 

I don't have any issues with green screen either. Could you post (YouSendIt, MegaUpload, Etc.) a short clip that you are using? See if we can duplicate your issue.

 

 

Gary,

 

Problem solved.

 

All of the emails back and forth challenged me to take another look at the program. Under the "Tools" tab I selected "Options." My options selection "Render Using" was set for "Hardware." I changed that option to "Software" to see what would happen and found that it solved my problem. I will post this solution so others who offered help are aware of this.

 

I plan to use this tool to promote a show that I do. Please visit www.morrison-tg.com.

Again, thanks again for you assistance and patients with me.

 

Gary

 

 

I don't have any issues with green screen either. Could you post (YouSendIt, MegaUpload, Etc.) a short clip that you are using? See if we can duplicate your issue.

 

Link to comment
Share on other sites

  • 0

What video card do you have? Kind of strange that the 'hardware' setting would cause this type of issue. Did you ever run the 'graphics test'? Unfortunately, it doesn't always recognize older card correctly and doesn't set that accordingly.

 

Thanks for letting us know!

Edited by ggrussell
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...