Jump to content
  • Who's Online   0 Members, 0 Anonymous, 7 Guests (See full list)

    • There are no registered users currently online
  • 0

"insert A Blank Dvd" When Burning Dl



Update: Not sure why it would not work, but did find a work around.


Mount the GI image in a Roxio (or other tool) virtual drive. Then simply used the Copy Disc To Image to create an ISO. Now I can burn the ISO using the same computer, drives, and media.


I'll never use that piece of junk GI format again.



My Roxio 2010 has worked fine on my laptop up until a couple of weeks ago. Now when I try to burn a gi image (approx 6.7GB) to a DVD+R/DL disk it pops the DVD out and tells me to insert a blank DVD. I put a KNOWN blank DVD+R/DL disc into the drive and wait a few seconds. It even shows 'DVD+R DL, Blank Media' once it has read the disc (see attached Roxio-1.png). Click on the green arrow and !@#!#@$%#%^%@#$%^#$#@% it pops the disc out and shows that I need to put another disc in (see attached Roxio-2.png.


I have applied all Roxio updates. I've updated the firmware on my optical drives (tried this with an internal TSST L632H and a USB TSST SN-S083N). Nothing seems to fix it.


I am using Memorex 8x DVD+R DL. Yes, I have been able to burn to this media before. I'm running XP 32-bit with SP3.


This does work on my desktop running Windows 7 32-bit with the same version of Roxio and the same media.

post-46894-065369200 1280184849.png

post-46894-001943500 1280184861.png

Link to comment
Share on other sites

1 answer to this question

Recommended Posts


This topic is now archived and is closed to further replies.

  • Create New...