Jump to content
  • Who's Online   0 Members, 0 Anonymous, 13 Guests (See full list)

    • There are no registered users currently online
  • 0

Clean Win 7 Pro (64B) Install - Roxio 2011 Won't Install



Like others that I read here, I'm kind of in the same boat. I first tried to install from DVD but had unplugged my Cat 5 cable, so when it ask me if I wanted to check for updates, I said no, and then it said that my machine didn't meet the mim. I think the developers need to learn how to check software better. Sorry guys! This is Windows 7 Professional (64bit) 4 gigs Ram, AMD 6 Core on an MSI 870FX MOBO, GeForce 9500 GT Video card, 128 Gig SSD, 3 internal HD's each 1TB, and numerous external drives.


So, I tired the second time and the software doesn't even seem to check to see if my system is right or not, it just gives me the standard doesn't meet the min's GOODBYE.


I searched the reg files and removed on line that was showing the DVD in the drive, rebooted and still nothing. Anti Virus is off, all background stuff is turned off. I'm not launching it with compatibility mode so, that shouldn't be an issue either.


So the bottom line is that this is my third purchase and maybe my last. I can't get 09 or 10 to install, and now 11? I really love this software, but when it won't install, what good is it? My old XP machine before it dies worked great. I had 10 on it and LOVED IT. That machine died so I built a new one and nothing will load. I've gone from normal hard drives to SSD's, Quad to a 6 Core, you name, i've wasted money on it. NOTHING. So now I just wasted another $100 for something that won't install.


I the one tech that responds by saying that his machine doesn't have a problem? What kind of help is that? Really, you work for Roxio and your system is running fine? Wow, that's nice, now please help fix mine! Sorry, but that really get's me when tech's say it works fine on their machine. Of Course it does!


Can you read the discontent in my writing? Roxio Tech Support, please help. I'm still in my 30 days that I ordered the disc from you and I really don't want to call and ask for my money back. Your software is much better than Nero, and I want to be able to use it again. Please help. I'm not the smartest person, but with a little help we can get this thing up and running. I'm new to Windows 7 and still may go back, but that's another topic for another day.



Link to comment
Share on other sites

1 answer to this question

Recommended Posts

I don't work for Roxio and I can say the same thing - it installed and runs fine on my machine here (and I'm not even on the same continent)


The 'minimum requirement' problem is usually caused by the app trying to install in compatability mode. If there's a hiccup Windows will shove it back to 'run this as Vista with no service pack' (which isn't supported, hence the message).


Copy the files on the disc to a temp folder on your hard drive, right click on setup.exe, go to properties, compatability and make certain the box isn't ticked. Then just run setup.exe from the folder.


You mightn't have selected compatability mode - but that doesn't mean MS didn't do it for you


Creator 2009 will NOT run on Windows 7. If you have a problem with both Creator 2010 and 2011 (and it says it's the same problem), it's probable something is badly messed up on the OS side

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...