Jump to content
  • 0
JDTakoma

Audio Capture With Spin Doctor

Question

I am trying to capture streaming audio from the Internet using Spin Doctor, as described in the Spin Doctor User Guide (esp. pp 22ff). I have repeatedly talked to Roxio tech support both by phone and via email. Finally they had me provide a copy of my System Profiler file and "escalated" the ticket. The result of that was to tell me to uninstall and reinstall the Toast 10 program (something I had already done multiple times). I did it one more time without success. Here is the response I provided back to tech support, describing what I did and what the problem is. I'm wondering if anyone else has encountered this problem and found a solution.

 

MY REPORT TO ROXIO TECHNICAL SUPPORT: I uninstalled the software and re-installed it per your instructions. Once in Spin Doctor I also installed Audio Capture Support, closed Spin Doctor, and re-opened it. The Start Auto Music Capture button was active. Following the instructions in your Spin Doctor User Guide (page 22) I went selected "start a new recording" and selected various parameters. CDSD Audio Capture was one of the input options. I clicked on the "start" button and immediately got an error message. After that the Auto Music Capture button was no longer active and CDSD audio capture was no longer one of the input options.

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

I had trouble getting that to work so now I access it from the Advanced window rather than the start screen. I choose Start a New Recording and then click the Advanced button. In the window that appears I choose CDSD System Audio Capture as the input device. From this point it works for me.

 

I also had trouble installing the CDSD audio capture support in the first place. If that seems to be an issue for you I can go through the workaround I did for that.

Share this post


Link to post
Share on other sites
  • 0

I had trouble getting that to work so now I access it from the Advanced window rather than the start screen. I choose Start a New Recording and then click the Advanced button. In the window that appears I choose CDSD System Audio Capture as the input device. From this point it works for me.

 

I also had trouble installing the CDSD audio capture support in the first place. If that seems to be an issue for you I can go through the workaround I did for that.

 

I am starting from the Advanced window - but I still can't get CDSD as a choice for input device. If you have advice on the installation of the audio capture support I'd like to hear it. Also, I was temporarily successful - I will post a separate "update" message.

Share this post


Link to post
Share on other sites
  • 0

UPDATE: I again uninstalled everything and reinstalled. I did not install the Auto Capture Support feature in Spin Doctor. I was able to successfully record from an internet stream, saved it, and then started another recording. After the second recording I quit Spin Doctor and re-opened it. Now I have the same problem as before: the Auto Capture button does not work and CDSD is not an input option. Back to the same situation as before. I tried quitting both Toast and Spin Doctor and re-opening them but it didn't make a difference.

Share this post


Link to post
Share on other sites
  • 0

UPDATE: I again uninstalled everything and reinstalled. I did not install the Auto Capture Support feature in Spin Doctor. I was able to successfully record from an internet stream, saved it, and then started another recording. After the second recording I quit Spin Doctor and re-opened it. Now I have the same problem as before: the Auto Capture button does not work and CDSD is not an input option. Back to the same situation as before. I tried quitting both Toast and Spin Doctor and re-opening them but it didn't make a difference.

In your System>Library>Extensions folder delete the CDSDAudioCaptureSupport.kext file. Now control-click on the CD Spin Doctor application and choose Show Package Contents. In the Resources folder double-click on the CDSDAudioCaptureSupport.pkg to launch the installer and run it. Log out and log back in. Now launch CD Spin Doctor and it should work.

Share this post


Link to post
Share on other sites
  • 0

In your System>Library>Extensions folder delete the CDSDAudioCaptureSupport.kext file. Now control-click on the CD Spin Doctor application and choose Show Package Contents. In the Resources folder double-click on the CDSDAudioCaptureSupport.pkg to launch the installer and run it. Log out and log back in. Now launch CD Spin Doctor and it should work.

 

OK - I tried that. Didn't make any difference. Still can't see CDSD as an input source, nor is Auto Music Capture active.

Share this post


Link to post
Share on other sites
  • 0

OK - I tried that. Didn't make any difference. Still can't see CDSD as an input source, nor is Auto Music Capture active.

Have you also tried shutting down and then restarting the Mac? Which version of CD Spin Doctor are you using in which version of OS X?

Edited by tsantee

Share this post


Link to post
Share on other sites
  • 0

Have you also tried shutting down and then restarting the Mac? Which version of CD Spin Doctor are you using in which version of OS X?

 

After many long conversations with Roxio technical support and many emails it is finally working. I really don't know what I did. They suggested trying with a different user on the Mac, which I did, and it immediately worked fine. I uninstalled and re-installed several times and for some reason it has now decided to work on my normal user account. BUT.... new problem. Even though auto capture says it is capturing streamed audio, it actually cuts off quite quickly. For example, if I record a stream for 10-15 minutes, stop, and look at the resulting file I find that recording stopped somewhere along the line. Sometimes after only 30 seconds, sometimes after 5-6 minutes. I've tried several different approaches, different user accounts on the computer, etc. and there is no pattern to this except that recording stops at some point even though the program says it is continuing. I've looked at all the settings I can find and don't see anything related to this.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×