Jump to content
  • Who's Online   0 Members, 0 Anonymous, 11 Guests (See full list)

    • There are no registered users currently online
  • 0

Mydvd Has Disappeared-Creator 10


Oswald
 Share

Question

I have a dell brand Roxio Creator Premier SD 10.2, and it worked perfectly fine a few months ago. Recently however I went in to create some home videos with MyDVD, but it was curiously gone. Dell is uncomfortably unhelpful, and because it came with my computer Roxio support say they can't help me, so I was hoping someone on here could.

 

I've tried reinstalling, no change. My thought was that somehow a subscription might have expired, but there was no evidence of this, and I can't see how only MyDVD would be effected, not copy, or burn image, or data disc.

 

Please help

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

I have a dell brand Roxio Creator Premier SD 10.2, and it worked perfectly fine a few months ago. Recently however I went in to create some home videos with MyDVD, but it was curiously gone. Dell is uncomfortably unhelpful, and because it came with my computer Roxio support say they can't help me, so I was hoping someone on here could.

 

I've tried reinstalling, no change. My thought was that somehow a subscription might have expired, but there was no evidence of this, and I can't see how only MyDVD would be effected, not copy, or burn image, or data disc.

 

Please help

 

You have a OEM version from Dell (they provide ALL support for their product).

 

I can't answer the "subscription issue" question (maybe Dell can).

 

Have you made any changes since you last used the program, like updates/new programs installed.

Link to comment
Share on other sites

  • 0

I have a DVD of the product that I put into the computer, and ran a reinstall on it. I know it's an OEM, and roxio has told me it's Dell's issue, and Dell has told me it's a roxio product, go ask them.

I haven't used the program in several months, in which time I have upgraded several other programs, so it could be any number. I know I upgraded to microsoft works, I installed an old Cool Edit Pro, and I know there's been a few others.

Link to comment
Share on other sites

  • 0

I have a DVD of the product that I put into the computer, and ran a reinstall on it. I know it's an OEM, and roxio has told me it's Dell's issue, and Dell has told me it's a roxio product, go ask them.

I haven't used the program in several months, in which time I have upgraded several other programs, so it could be any number. I know I upgraded to microsoft works, I installed an old Cool Edit Pro, and I know there's been a few others.

 

 

Did you upgrade to Win 7.... your version is not compatible.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...