Jump to content
  • Who's Online   0 Members, 0 Anonymous, 16 Guests (See full list)

    • There are no registered users currently online
  • 0

Cannot Install Roxio EMC 8


Chas

Question

Hardwar/Sofware

 

Windows XP

Pentium 4—3.0GHz

120 GB Hard Drive

Radeon 9200 Graphics

DVD R/RW

CD R/W

 

 

Problem: EZ Media Creator 8 won’t install on my desktop. Everything seems normal during installation—progress indicator bar moves along normally until the end and then it shuts down and re-boots with an EZ Media Creator shortcut on the screen. Except this is the blue-bordered vanilla windows shortcut instead of the stylized Roxio shortcut which should be there. When I click on this, a “Missing Shortcut” message appears saying : "Windows is looking for Roxio central.exe." I checked Program Files, and there’s a “Roxio” folder there with a bunch of files which appear to be the various applications, but there’s no roxio central.exe. I've repeated this process about 8 or 10 times so far shutting off anti-virus, running a registry cleaner suggested on this site, etc. but with no success yet.

 

I have a laptop which I use occasionally, so I tried installing Roxio 8 on it—and everything seemed to work just fine—installed OK, and all the apps seem to be there. So we know the disc is OK—must be something on my desktop that’s messing things up.

 

Can somebody help, please

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

Chas, did Tony's (Ogdens) suggestion help? It would be nice to know.

 

Thanks to all three (so far) folks who’ve tried to help. I checked the thread supplied by ogdens and one of the suggestions it contained was to use a registry cleaner. So I downloaded and used Registry Mechanic on what would appear to have been the world’s dirtiest registry. I’m sure that needed doing anyway but, unfortunately, it didn’t solve my problem.

 

The target file for the shortcut in the laptop (which works) is “C:\Program Files\Common Files\Roxio Shared\Roxio Central\Main\Roxio_Central.exe”. The entire “RoxioCentral sub-folder is always missing from my (many) installation attempts on the desktop computer, but present in the working version on the laptop. There’s also a “Tutorial” folder missing, but I expect I can do without that.

 

I’m now considering copying the two errant folders from the laptop to a CD-RW (it’s about 14mb) and then loading them into the desktop. But that’ll still leave the main question unanswered—why doesn’t the installation work OK in the first place?

 

Chas

Link to comment
Share on other sites

Thanks to all three (so far) folks who’ve tried to help. I checked the thread supplied by ogdens and one of the suggestions it contained was to use a registry cleaner. So I downloaded and used Registry Mechanic on what would appear to have been the world’s dirtiest registry. I’m sure that needed doing anyway but, unfortunately, it didn’t solve my problem.

 

The target file for the shortcut in the laptop (which works) is “C:\Program Files\Common Files\Roxio Shared\Roxio Central\Main\Roxio_Central.exe”. The entire “RoxioCentral sub-folder is always missing from my (many) installation attempts on the desktop computer, but present in the working version on the laptop. There’s also a “Tutorial” folder missing, but I expect I can do without that.

 

I’m now considering copying the two errant folders from the laptop to a CD-RW (it’s about 14mb) and then loading them into the desktop. But that’ll still leave the main question unanswered—why doesn’t the installation work OK in the first place?

 

Chas

Just a shot in the dark - could this be an NTFS permissions problem?

 

Lance

*****

Link to comment
Share on other sites

Hardwar/Sofware

 

Windows XP

Pentium 4—3.0GHz

120 GB Hard Drive

Radeon 9200 Graphics

DVD R/RW

CD R/W

Problem: EZ Media Creator 8 won’t install on my desktop. Everything seems normal during installation—progress indicator bar moves along normally until the end and then it shuts down and re-boots with an EZ Media Creator shortcut on the screen. Except this is the blue-bordered vanilla windows shortcut instead of the stylized Roxio shortcut which should be there. When I click on this, a “Missing Shortcut” message appears saying : "Windows is looking for Roxio central.exe." I checked Program Files, and there’s a “Roxio” folder there with a bunch of files which appear to be the various applications, but there’s no roxio central.exe. I've repeated this process about 8 or 10 times so far shutting off anti-virus, running a registry cleaner suggested on this site, etc. but with no success yet.

 

I have a laptop which I use occasionally, so I tried installing Roxio 8 on it—and everything seemed to work just fine—installed OK, and all the apps seem to be there. So we know the disc is OK—must be something on my desktop that’s messing things up.

 

Can somebody help, please

 

 

I found this thread by doing a "search" (top right) on roxio central.exe.

 

See if it helps

 

http://forums.support.roxio.com/index.php?...ntral\.exe

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...