Jump to content
  • 0
raverhaze

Problem Eliminating Gap Between Songs

Question

hey everyone,

 

i just recently got toast titanium 10...i've been trying to burn cd's with absolutely no gap whatsoever in between tracks. i've tried selecting DAO and putting 0 second gap between each track but i still get a milli-second gap between every song. it's almost like a hiccup when it goes from one track to the next. i know for certain that toast 10 supposedly allows me to burn seamlessly, but i'm just having an issue with this, i'm trying to burn a mix cd. if anyone can help, it'd be greatly appreciated. thank you.

 

 

Regards,

 

Mike S

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

Is this audible on the burned audio CD? Toast's preview does have an audible gap but in my experience there is none in either a sd2f disc image or on a burned audio CD.

Share this post


Link to post
Share on other sites
  • 0

The problem has to do with the number 2352, which is the number of bytes in an Audio CD sector, and the fact that a new track must start at the beginning of a sector. So, if the track that's just finished, ends 16 bytes into its last sector, the rest of that sector is written as zeros, which is silence, and the next track will start at the beginning of the next sector, almost 1/75th of a second later. So, since you're hearing a "millisecond" gap, basically, Toast 10 is doing what it's supposed to be doing, within the limits of the audio files you're giving it.

 

How do you fix it? The easiest way would be to trim the "previous" track so it ends just at the end of a sector. You're not likely to "hear" the missing fragment as you do the silence. I'm a PC person, so I've never used Toast, nor do I know what other tools might be available to you, but you need something that will let you "prep" the tracks for burning to CD. I use GoldWave, which I'm pretty sure has that option.

 

Alternatively, if you need that fragment of song included, you'd essentially need to combine all your tracks into a single .WAV file, then use a tool that splits files out on CD sector boundaries.

 

So, there's what's happening, and why.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

The problem has to do with the number 2352, which is the number of bytes in an Audio CD sector, and the fact that a new track must start at the beginning of a sector. So, if the track that's just finished, ends 16 bytes into its last sector, the rest of that sector is written as zeros, which is silence, and the next track will start at the beginning of the next sector, almost 1/75th of a second later. So, since you're hearing a "millisecond" gap, basically, Toast 10 is doing what it's supposed to be doing, within the limits of the audio files you're giving it.

 

How do you fix it? The easiest way would be to trim the "previous" track so it ends just at the end of a sector. You're not likely to "hear" the missing fragment as you do the silence. I'm a PC person, so I've never used Toast, nor do I know what other tools might be available to you, but you need something that will let you "prep" the tracks for burning to CD. I use GoldWave, which I'm pretty sure has that option.

 

Alternatively, if you need that fragment of song included, you'd essentially need to combine all your tracks into a single .WAV file, then use a tool that splits files out on CD sector boundaries.

 

So, there's what's happening, and why.

Very informative, Dave. I've done track trimming in Toast with some live recordings downloaded from emusic. Another option could be to crossfade the tracks.

Share this post


Link to post
Share on other sites
  • 0

The problem has to do with the number 2352, which is the number of bytes in an Audio CD sector, and the fact that a new track must start at the beginning of a sector. So, if the track that's just finished, ends 16 bytes into its last sector, the rest of that sector is written as zeros, which is silence, and the next track will start at the beginning of the next sector, almost 1/75th of a second later. So, since you're hearing a "millisecond" gap, basically, Toast 10 is doing what it's supposed to be doing, within the limits of the audio files you're giving it.

 

How do you fix it? The easiest way would be to trim the "previous" track so it ends just at the end of a sector. You're not likely to "hear" the missing fragment as you do the silence. I'm a PC person, so I've never used Toast, nor do I know what other tools might be available to you, but you need something that will let you "prep" the tracks for burning to CD. I use GoldWave, which I'm pretty sure has that option.

 

Alternatively, if you need that fragment of song included, you'd essentially need to combine all your tracks into a single .WAV file, then use a tool that splits files out on CD sector boundaries.

 

So, there's what's happening, and why.

 

 

 

i understood what you said...but now i'm not so sure how to execute it. are you telling me i should open each track in a sound editor and trim the ends off each track?

Share this post


Link to post
Share on other sites
  • 0

I guess it depends on the options available in the editor Toast has. If it will simply trim the track to the end of a CD sector, yes, do that. Hopefully Tsantee can give you some more details. At the very least, open each track in an editor, and make sure there isn't any silence that is actually part of the track. Obviously if there is, then get rid of that first, and see what happens.

 

Good luck.

Share this post


Link to post
Share on other sites
  • 0

It is audible on the burned cd. It sounds like there a gap in between tracks of like a mill-second. Like a hiccup almost in the music. But it's a lot quicker than a normal gap...

 

Question...is there a way I could load up the entire cd uncut and create tracks within toast 10?...if that's the case then I'll load up the entire 60 minute set then chop it up within toast...it might be easier

Share this post


Link to post
Share on other sites
  • 0

Again, I don't know Toast. If I were doing it, yes, if the whole CD is available as a single track, I'd load it into CDWave, and split it up with that. It automatically moves to a CD sector boundary. That guarantees no "blip" dropout between tracks.

Share this post


Link to post
Share on other sites
  • 0

It is audible on the burned cd. It sounds like there a gap in between tracks of like a mill-second. Like a hiccup almost in the music. But it's a lot quicker than a normal gap...

 

Question...is there a way I could load up the entire cd uncut and create tracks within toast 10?...if that's the case then I'll load up the entire 60 minute set then chop it up within toast...it might be easier

When the tracks are in Toast click on the track's length and a window pops up that has Track Trim... at the bottom. Select that and trim off a little. I found it easy to figure out how much to trim from the emusic.com tracks by clicking a crossfade button and choosing Custom. There I can see the waveform and preview the audio at the end of the track. Once I saw how much needed to be trimmed I did this with Track Trim.

 

As for your question about loading up the entire CD you can choose Save as Disc Image and Toast will save a sd2f file. I believe you can open that sd2f file in CD Spin Doctor where it will appear as one very long track. There you can break it into new tracks and fine tune the start and end points. Then send those tracks back to Toast to make the new audio CD. If CD Spin Doctor won't open the .sd2f file you can open it as a single audio file in iTunes and use iTunes to convert it to aiff for import to CD Spin Doctor.

Edited by tsantee

Share this post


Link to post
Share on other sites
  • 0

hey everyone,

 

i just recently got toast titanium 10...i've been trying to burn cd's with absolutely no gap whatsoever in between tracks. i've tried selecting DAO and putting 0 second gap between each track but i still get a milli-second gap between every song. it's almost like a hiccup when it goes from one track to the next. i know for certain that toast 10 supposedly allows me to burn seamlessly, but i'm just having an issue with this, i'm trying to burn a mix cd. if anyone can help, it'd be greatly appreciated. thank you.

 

 

Regards,

 

Mike S

 

Hi raverhaze (Mike),

 

I don't know if you solve your problem. I was having the same issue. Even with DAO and 0 second pause, there was still a small/tiny tiny gap between songs. Search the web and found this on Audacity page:

 

«Additionally, make sure you don't export MP3 files for burning to your gapless CD, even if you're burning a "data CD", because MP3s have inherent silence padding due to a restriction of the MP3 format.»

source:

http://manual.audaci...c_files_to_a_CD

 

And that solved my problem. Instead of using MP3 files in Toast 11, I export my 1 hour MP3 in small AIFF files and, MAGIC, no gap between songs !!

 

So maybe this can help someone ;)

 

Eric

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Easy fix....Toast & Window's Media player both place a sight pause between MP3 file tracks. To fix this problem just convert your MP3 file(s) into a .wav file(s). Record (burn) your tracks as "audio), and NOT MP3 in both these applications. I import my straight audio file into Sony Sound Forge and split the tracks where I want the track marker to be. Then save each individual track as a new track...name each track as Track 1, Track 2, Track 3, etc. Then import these .wav tracks into Toast or Window's Media player in sequencial order....the burn the CD as "audio".

 

Good Luck!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×