Jump to content
  • 0
osxdude

Permissions Incorrect On Toast 11 Folder

Question

After running the new Toast Installer, I chose the option to install for all users. Once the installer completed, the Toast 11 folder in Applications had permissions for another admin user on my system and that user had read/write and everyone had no permissions. I had to manually change the permissions in order to open the folder and launch the application. I'm curious if anyone else has observed this behavior?

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

As an update, I was able to duplicate this behavior on several other Macs (all running OS 10.6.6) in order to rule out potential system problem on just one machine. I haven't had time to check in depth, but my guess is that the installer is running as a specific user id, which is why the permissions/ownership are set to a different user on each system. I just haven't had time to look in terminal and check and see which user id it is. I'm kind of surprised that no one else seems to be having this issue judging from the forums here.

Share this post


Link to post
Share on other sites
  • 0

I had this exact problem today. I went to double click on the Toast folder and it had a small red line through it. I thought that perhaps I had not installed it properly or that it had not completed in some way, so I re-installed to achieve the same thing. In the end, I clicked on "get info" unlocked the permission and set them to read and write for everyone. From that point, I could then get into the folder and choose the software.

Share this post


Link to post
Share on other sites
  • 0

From what I can tell by running dscacheutil -q user, the Toast installer is setting user id 501 as the owner. This is fine assuming that there is only one user on the system and that you happen to be a user with uid 501. Unfortunately, uid 501 on my systems belongs to an Apple Remote Desktop user account. So I now have to go around and manually change the permissions so that all users on the system can access the program. Interestingly, the installer asks that question (install for all users) yet doesn't set the permissions so that all users can access the program.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×