Jump to content
  • Who's Online   0 Members, 0 Anonymous, 11 Guests (See full list)

    • There are no registered users currently online
  • 0

Media Import


backer

Question

I just purchased Easy Media Creator 8 and installed it. I've also downloaded the update from the support website, but I'm having a problem that I hope someone can help me with.

 

When I launch the media import utility, as soon as I click on any of the options (photo,video,audio), the window just disappears. If I try to get to it thru any other means, the same thing... window pops up and disappears.

 

Any suggestions would be greatly appreciated.

 

-b

Link to comment
Share on other sites

10 answers to this question

Recommended Posts

I JUST loaded EMC8 on my computer after purchasing it from Best Buy a couple of days ago. EXACT SAME deal - I have no problem launching EMC. Then I click "DVD & Video" on the left-side of the Welcome screen.

 

If my Panasonic videocamera is on, then my PC crashes (freezes, locks, whatever) right away. If my camera is not connected or not on, the thing freezes if I click the "Video" button at the top of the next screen. On-line support is NON-EXISTENT and i am PISSED! I bought this thing because Nero's reputation is so poor.

 

ANY suggestions?

-MadStevieK

Link to comment
Share on other sites

I JUST loaded EMC8 on my computer after purchasing it from Best Buy a couple of days ago. EXACT SAME deal - I have no problem launching EMC. Then I click "DVD & Video" on the left-side of the Welcome screen.

If my Panasonic videocamera is on, then my PC crashes (freezes, locks, whatever) right away. If my camera is not connected or not on, the thing freezes if I click the "Video" button at the top of the next screen. On-line support is NON-EXISTENT and i am PISSED! I bought this thing because Nero's reputation is so poor.

ANY suggestions?

-MadStevieK

 

Calm down, just because you have the same symptom that the other two have it doesn't not mean you have the same problem or the same solution.

 

e-mail support to Roxio is free. If you want to rant, do it to them directly. This is a users board where people try to help other people.

 

All three - post your computer specs especially you video card/chip, OS, and make sure you have SP2 for XP or SP4 for 2000. Make sure you have the latest version of Windows DirectX 9c and make sure they are up to date and free of spyware and other malware. Take a look at the minimum specs and make sure that your computers is at or above the minimum and you have all other applicable applications (like IE6).

 

When you installed, did you do so with your anti virus enabled? Bad move. Post your anti-virus software. some create more havoc than others. Did you try opening the program with the anti virus shut down. Some anti virus will also do that since it thinks that it is a virus.

Link to comment
Share on other sites

Intel Pentium 4 2.8 GHz

512 MB of RAM

SP2 compliant

 

Not sure if "Windows DirectX 9c" is up to date...I don't know what it is. I also don't know how to learn the specifications of my video card. I have a laptop and don't know what I am looking for when I use the device manager utility. All I see is "Legacy Video Capture Devices" and double-clicking it just indicates that the device is working properly.

 

I DID install the software with NAV/NIS 2006 running...never any indication that that would be a problem. Since I posted, I tried to download and install the update for EMC8. I received an error message - "The upgrade patch cannot be installed by the Windows Installer service because the program to be upgraded may be missing, or the upgrade patch may update a different version of the program. Verify that the program to be upgraded exists on your computer and that you have the correct upgrade patch."

 

I suppose that NAV might have prevented the s/w from logging the registry - a problem I had with ACT! for Palm.

 

Finally, please don't tell me to "calm down". It's condescending and I fully understand the function of this board. I am indeed looking for help with this problem and I am very frustrated. Software publishers in general, and specifically Roxio, have inexcusable levels of support. $150 for a software package and they CHARGE you for phone support? No offense, but I get very angry when I spend 3 hours trying to solve a nonsense problem like this. I have a family and many other things to do. Help or don't help, but don't act like my dad.

Link to comment
Share on other sites

Finally, please don't tell me to "calm down". It's condescending and I fully understand the function of this board. I am indeed looking for help with this problem and I am very frustrated. Software publishers in general, and specifically Roxio, have inexcusable levels of support. $150 for a software package and they CHARGE you for phone support? No offense, but I get very angry when I spend 3 hours trying to solve a nonsense problem like this. I have a family and many other things to do. Help or don't help, but don't act like my dad.

 

With that attitude, I think I will go for the 'don't help' option.

 

I hope Steve others will too.

Link to comment
Share on other sites

I just purchased Easy Media Creator 8 and installed it. I've also downloaded the update from the support website, but I'm having a problem that I hope someone can help me with.

 

When I launch the media import utility, as soon as I click on any of the options (photo,video,audio), the window just disappears. If I try to get to it thru any other means, the same thing... window pops up and disappears.

 

Any suggestions would be greatly appreciated.

 

-b

I'm experiencing the same problem and I'm wondering if it's because my JVC GR-D72U camcorder is not listed as being supported. Using the older Sonic MyDVD v4.5 capture software still works fine. I'm not too impressed with the Media Import Software crashing like this without leaving an error code especially since the parent MyDVD program hangs when the child process abruptly dies. :)

 

I also would appreciate any suggestions.

 

-J

Link to comment
Share on other sites

Thanks, Digital Geeks...er...Gurus. Your help is appreciated, your preeminent attitude smacks of Nick Burns. Are you so keen to help others or does your smug esoteria quell your insecurity?

 

Oops...better stop ranting or "sknis" might reprimand me with a "calm down"... Better yet, I'll get help elsewhere...even if I have to pay for it.

Link to comment
Share on other sites

I am having the same problem. I have removed the program several times and reinstalled it, but that does not help. I've tried every solution I can find on this forum, but am at a loss. I tried returning the software, but Fry's would not take it back. I can't call the number due to the limited times they are open. The Roxio customer support site does not work, so now what? Please help!!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...