Jump to content
  • Who's Online   0 Members, 0 Anonymous, 2 Guests (See full list)

    • There are no registered users currently online
  • 0

"ghosting" In Captured 16:9 Aspect Ration Video



I am using the Roxio Creator 8 suite to capture a 16:9 PAL format video via a Firewire cable from a Sony DCRHC85 HandyCam. I’ve spent many hours capturing 6 hours of video and then many more weekends since editing the data. Overall I haven’t been very happy with the quality of the end result, as the video seems to have lost a lot of resolution in the editing and authoring process and I was initially blaming compression settings, etc.


During a recent editing session however, I was adjusting the length of a scene when I noticed an effect that can best be described as “ghosting” in the moving image of the captured footage. Imagine for a moment my scene of a shot taken out the side of a moving vehicle with telegraph poles and fences with vertical slats moving past. The individual frames shows these vertical structures repeated almost next to each other, so it looks like there are x2 telegraph poles (and any other starkly obvious vertical structures) repeated right next to each other. This obviously is the cause of the inferior quality of my edited material - the original captured source was bad to start with. Now that I knew what to look out for I found the same effect in all the rest of my captured footage.


I started experimenting; first of all looking at the original tape from the camera and I was relieved to find that the image on that was absolutly fine (no ghosting effect). I recaptured the footage back through the Roxio Capture program and again I see the "ghost" image slightly offset in the captured footage. I deduced that this was now likely to be caused by either: the capture program itself, the camera, or the cable.


To eliminate the camera I tried capturing using a USB cable and that resulted in an image with no ghosting. To eliminate the cable I then spent a fortune on purchasing a genuine Sony i.LINK cable. Here in Australia the cable cost me more than the Roxio software update (without the rebate)!! Anyway I had heard that these Firewire cables can cause obscure problems and seeing as the capture program was able to capture the USB source just fine I thought the software should be OK, so I was confident that the new cable would solve the problem.


WRONG!! I still get the ghosting using my new "million dollar" cable. So just to prove the ghosting is now the fault of the software I fired up Windows Movie Maker (WMM) to see what it would do. In retrospect I should have done this before buying the new cable. Anyway, surprise, surprise, it captures just fine. I’m now a bit miffed that I have x2 firewire cables, both of which are perfectly good, and I still get a foggy capture from the Roxio Capture program.


I’m also a little surprised that nobody else has discovered this problem, but perhaps like me they have been trying to tweak other settings to improve the image quality and didn’t realise there were artefacts being generated by the captured program, so after checking this forum I opened a problem with technical support. I also captured an image from both sets of captured video to demonstrate both the ghosting effect and the OK version from WMM. To date I haven't heard anything...another surprise.


In desperation I downloaded Sony's Vegas editing software, which BTW is absolutely awesome. Funny thing is I get the same ghosting effect when using that and I haven't found the right combination of settings to get a good result. So I had yet another tinker with WMM and found that by changing the Aspect Ratio in the Video Properties section of the Options dialog (found under the Tools menu) between 4:3 and 16:9 I could recreate my problem (4:3) and then fix it (16:9).


On close inspection of the ghosting frames it appears that the lines in the 16:9 source wrap around slightly when captured at 4:3, causing the next line to be offset and therefore causing the ghost image - sorry I'm not that knowledgeable with the technicalities of video and this is purely an observation. When 16:9 is selected the lines now fit and the final image is purr-fect.


I just need to know how to change settings to make the Creator 8 capture program treat the video source in the same way. I've looked but cannot find anything. Anybody got any ideas??


Regards, Alan

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

Mmmmm!!!! I think I might need to park this one for a bit as I have had a friend volunteer to take a look at this problem on their computer and what we discovered now points to being a camera fault.


We captured the data raw with a freeware utility called DVIO. Then we looked at the captured source with another freeware utility called VirtualDub. Straight away we can see the bad ghost image in the frame. Using VirtualDub we then deinterlaced and dropped one of the pairs of frames that make up the final interlaced image and got some non-ghosting image footage - it lacked a bit of resolution as half the lines were now missing but it proved a point. When we experimented by deinterlacing and combining the odd and even frames we got the ghosting back.


So it now looks like there is a strong possibility that there is something wrong with the raw interlaced 16:9 image coming from the camera. Which would explain why I'm having problems in all the other editing software, but NOT why Windows Movie Maker shows the frames OK when the 16:9 aspect ratio setting is used. I need to place a call with Sony and also do some more experimenting with settings that could change the aspect ratio.


More news when I have it.

Link to comment
Share on other sites

Gary you won't believe it. Looking at the results from the DVIO and VirtualDub work earlier I was convinced the output from the camera was simply not right (perhaps the camera was damaged or had a s/w bug). Anyway I was experimenting further at home when I spotted the "Reset" hole in the side of the camera. I hadn't noticed that in a long time. "I wonder ...." I thought. Stuck a paperclip in the hole, waited for the camera to reset and "hey presto" my ghosting problem has gone away!!! I cannot believe it and still don't know what had happened, as I don't believe I have accidentely changed any of the setting camera's settings, but the Reset finally resolved the problem. Wooo Hoooo!!!!


I'll chalk this one up to experience and instead of wasting too much time in the future I'll start with resetting the camera first. It's easier to set up that sucker than re-installing software!!


Thanks for your help. Well add this one to our book of debugging hints and tips.

Link to comment
Share on other sites

Thanks Gary. Although I am comfortable with the general basics of digital video I really must learn more about the technicalities that underpin this video technology and then I should be able to work some of these problems out for myself.


You are right, when I burn a DVD and play the footage on a TV it doesn't look as bad as in the editor's preview window. However, and this is really interesting, when I pause the image and step frame by frame, each frame is crystal clear (no sign of ghosting). When I play the footage, the moving vertical structures blur and I can start to see the same double ghost images that I see when I pause an image in the video editing software. It's not just me that can see this; I've had my stepson say there is something horribly wrong with the image on the TV. Anything that moves becomes fuzzy. So things still aren't right and I suspect that it is something to do with interlacing, a codec, or the format of the widescreen data that is coming from the camera.


I played back the DVD using 2 different DVD players; a Sony one via composite connections and a high-end Toshiba via component connections to a Sony Vega TV, both with the same result. So now I'm just about to de-install anything that remotely touches video from my machine; as I have heard that some people have had problems with the order of the codecs, and I thought I would start again by simplifying my environment, install one video-editing product, and then start experimenting with settings.


FYI: In addition to the Sony HandCam I’m using XP Pro SP2 running on an ASUS P5LD2 motherboard with an Intel P4 3.4 GHz hyper-threaded CPU, and 2Gb memory. Sound and video is handled by the onboard Realtek ALC882 8-channel High Definition Audio component and a Gigabyte GV-NX66T128D graphics card with 128Mb DDRIII memory. All BIOSes have been updated. Video data is stored on a separate dedicated Seagate ST3250823AS 250Gb Serial ATA disk drive that is regularly defraged. DVDs are produced on a Pioneer DVR-A10 dual layer burner to, in this instance, single layer 16x TDK media. I've tried to keep to good quality components as I'ne very much aware of the "weakest link" principle.


I really appreciate your feedback and if you can think of anything else that I should try, I would certainly like to have as much 3rd party input to the process as I can get. Anybody else got other ideas??


If/when successful, I’ll document what I discover here for the benefit of others who may encounter the same issue.


Best regards, Alan.

Link to comment
Share on other sites

Sounds like you have a nice machine. Make sure you have all the Microsoft updates, too. Especially DirectX 9.0c. One other user solved a video display problem by updating the motherboard chipset drivers. I'm not familiar with the Gigabyte video cards. Make sure you have the latest drivers for the video card and sound.

Link to comment
Share on other sites

Sounds like what you are seeing is the results of viewing interlaced video on a non-interlaced device (the monitor). This is NORMAL and will not be seen on a TV which is also interlaced. Try a simple test by creating a 5 minute video of the footage that seems the worse. Burn to a DVD RW disc and play it back on your TV.


There are no settings for capturing DV AVI from a digital camcorder via firewire. It's a straight forward transfer from camcorder to computer. Bit for bit.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...