Jump to content
  • Who's Online   0 Members, 0 Anonymous, 7 Guests (See full list)

    • There are no registered users currently online
  • 0

Creator 2011 Pro Will Not Install


bigmacfann

Question

First off, I'm running a custom built pc with the following specs:

 

Intel Core I7 965 processor

12 GB RAM

Windows Vista Ultimate 64-bit (installed on Intel X25-E 32GB SSD)

 

I believe the key to my problem is that my OS (Drive C) is on the SSD and I have my Program Files on Drive D which is a standard hdd. I downloaded Creator 2011 Pro onto my D Drive and extracted the 3 files using 7-Zip. I now have 3 folders (Roxio2011Content_J898AXD0SQA, Roxio2011ProDisc2_J701AXD0FUL, RoxioCreator2011PRO_JA08NXD0R14). In each folder contains the files that were extracted. I go to the folder 'RoxioCreator2011PRO_JA08NXD0R14' and double click on 'setup.exe.' I select English, then the program crashes giving me the error 'Error attempting to read from the source install database: D:\Users\T...\Roxio Creator 2011 Pro.msi. Now I check the log file which ended up on my C drive under C:\Users\Todd\AppData\Roaming\Roxio Log Files\Roxio Creator 2011 Pro. I have attached the log file for your reference. One thing I notice in the log file is that it's detecting my 64 bit program files folder correctly as D:\Program Files but my x86 is not correct, it is showing C:\Program Files (x86). I do not want anything installed on my C drive. I uninstalled Roxio 9 because it was all over my c drive taking up very valuable space. I don't have much space available on my C drive (only a little less than 1 GB) due to an overinflated winsxs folder (17.9 GB). I have tried the different methods on here describing ways to install this program but they haven't worked obviously. Could someone please help me? I would like to install this program to my D drive ONLY and also I would like it to actually work. Thank you so much!

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

Won't happen without it installing a good portion on the C Drive.

 

Just moments after posting this topic I explored one other option. I have now successfully installed the program to my computer and it is ALL on my D Drive. For those who may have a similar problem, this is what I did:

 

This requires registry modifications -- if you aren't comfortable modifying your registry, be cautious.

Back up your registry!

 

First, copy your Program Files and Program Files (x86) folders to your desired drive.

This works best on a fresh windows install -- if your installation of Windows has been on for a while, I recommend leaving your PF and PF (x86) folders on your C Drive so none of your existing programs get confused.

Next, go to run and type 'regedit'

When your registry editor window opens, click to expand 'HKEY_LOCAL_MACHINE', then 'SOFTWARE', then 'Microsoft', then 'Windows', then select 'CurrentVersion'

On the pane to your right, you will see under the 'Name' column the following items: CommonFilesDir, CommonFilesDir (x86), ProgramFilesDir, ProgramFilesDir (x86)

You will notice that they currently point to your C Drive (or whatever Drive your OS is installed on)

Change the drive letter assignment on each of those 4 items by right-clicking on each item and selecting 'Modify' and changing the 'C' to 'D' (for example)

After you have done that (and this is what I didn't do and that's why my Program Files (x86) folder was still defaulting to my C Drive), go back to the left pane of your registry editor window

Collapse 'Windows' and 'Microsoft' and look further down the 'SOFTWARE' list to find 'Wow6432Node' and expand it

Next, expand 'Microsoft' then expand 'Windows' and click on 'CurrentVersion'

On the right-hand pane, you will see the same 4 items in the step before -- change them the same way you changed the ones before

Now, collapse the registry and exit out

Restart the computer

Now, install Roxio Creator 2011 Pro! It worked fine for me after this.

All (x86) applications should install to your desired drive from this point forward unless the programmer who made the program was lazy and defaults the installation to drive C hopefully they allow you to customize the location of the installation.

If you feel like it, you could change the name of your PF and PF (x86) folders on your C drive to make sure it doesn't screw up any currently installed programs. If it doesn't, then you can probably delete the folders and free up some space (if needed). I hope this helps anyone who may have had this same problem.

Link to comment
Share on other sites

Actually a simple way to save space on C is move the My Documents and temp folders to another drive and also set up pagefile.sys on a separate physical drive (but if you have 8 GB or more of RAM, just remove it completely)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...