Jump to content
  • 0

Invalid Field In Cdb - Every Time I Try To Burn A Disc


Lord_Elpus

Question

My MacBook Pro running Snow Leopard 10.6.8 is unable to burn discs at all - it fails as soon as it tries to write the disc. This can be CD, Data, DVD etc. It happens all the time, started a few months ago but I don't remember it coinciding with any OS X updates.

 

I've deleted Toast, it's Application Support folder and it's plist files from preferences - reinstalled (updated it to the latest build) and still it gives the same error...

 

The drive reported an error:

Sense Key = ILLEGAL REQUEST

Sense Code = 0x24

INVALID FIELD IN CDB

 

I can see this is quite a common problem on a Google search but I can't find a solution. I am using the same Maxell DVD-R discs that I have always used.

 

Finders burner works OK as does 'Burn', 'Dragon Burn' and other simple disc burning apps

 

Has anyone got any ideas as I am stumped now.

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

It saves to a toast image OK but when I then go to burn that image to disc it gives me the same error.

 

Decided to do a clean OS X install and try again. Also reset the MacBook Pro's PRAM for good measure, but the problem still exists although small data files do now burn OK.

 

I have also found that I can burn smaller DVD TS_Video folders also burn OK if I turn off 'Fit to DVD video Compression'.

 

As a temporary work-around I can buy some dual layer DVD's or reduce the content in my iDVD projects to make 2 single layer DVD's instead.

Link to comment
Share on other sites

I'm stumped too. Toast can be more temperamental when burning discs than some other applications. It certainly is more sensitive to problems an optical drive may be having.

 

Try choosing Save as Disc Image and then burn the resulting .toast file using the Image File setting in the Copy window. Choose the slowest available burn speed (which is shown after the blank disc is inserted and recognized). Let me know what happens.

Link to comment
Share on other sites

I got a similar message, and others, while trying to burn a video TS file to double layer DVD. I spent the better part of a day throwing away discs, downloading trial software, and generally getting frustrated. But I did find a solution finally. Download a program called AquaISO... it's free, no strings attached. Create an ISO file of your disk -- it's a piece of cake. Then open Disk Utility, drag the ISO image into the window on the left of Disk Utility's main window, and click Burn. The whole thing takes a few minutes, and you get a playable DVD without the hassles. It's not the media that's bad. And it's not a Mac hardware problem. Hmmmmm...

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...